WebDAV authentication fails - 401RSS

7 replies

Last post Dec 05, 2017 08:42 AM by william.chung

  • WebDAV authentication fails - 401

    May 03, 2010 08:46 AM|delcon|LINK

    I have tried to enable Web Dav on my IIS7 but the authentication fails. This is my log:

    2010-05-03 12:12:43 212.55.220.220 OPTIONS / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 200 0 64 578
    2010-05-03 12:12:43 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 64 421
    2010-05-03 12:13:07 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 437
    2010-05-03 12:13:07 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 453
    2010-05-03 12:13:09 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 453
    2010-05-03 12:13:10 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 515
    2010-05-03 12:13:10 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 421
    2010-05-03 12:13:12 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 125
    2010-05-03 12:13:12 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 62
    2010-05-03 12:13:12 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 171
    2010-05-03 12:13:13 212.55.220.220 PROPFIND / - 80 - 80.219.85.97 Microsoft-WebDAV-MiniRedir/6.0.6002 401 0 5 343

     Does anybody have a clue how to resolve this issue?

  • eokim eokim

    171 Posts

    Microsoft

    Re: WebDAV authentication fails - 401

    May 03, 2010 10:41 AM|eokim|LINK

    WebDAV request should be authenticated. Anonymous WebDAV request is not allowed.

    Could you refer to Installing and Configuring WebDAV on IIS 7 and check anything is missed?

  • Re: WebDAV authentication fails - 401

    May 03, 2010 11:27 AM|delcon|LINK

    That's exactly how I did it. Everything went smoth, except:

    <div mce_keep="true">
    1. On your WebDAV server, open a command prompt session.
    2. Type the following command to connect to your WebDAV server:

      net use * http://localhost/
    </div>

    I get a "Networkname can not be found"

     
  • eokim eokim

    171 Posts

    Microsoft

    Re: WebDAV authentication fails - 401

    May 03, 2010 12:09 PM|eokim|LINK

    From your iis log, it looks like your webdav request was anonymous. I think that's why you get 401.

    Can you make sure Step 2: Logging in to Your WebDAV Site is configured?


     

  • Re: WebDAV authentication fails - 401

    May 03, 2010 05:17 PM|delcon|LINK

    I rechecked. Step 2 is configured fine. I noticed though that Authorization Rules is Named .Net Authorization Rules...

    Still. No luck to authenticate. On the client the Prompt to put in the Username an Password is shown, but it does not accept my Administrator credentials..

    By the way... to be able to publish while solving this WebDav access I tried to use FTP. I turns out that muliple it is a ploblem to use FTP with muliple Websites and bindings! As soon as any bingings are set you can't log in to any FTP. This sucks.

  • eokim eokim

    171 Posts

    Microsoft

    Re: WebDAV authentication fails - 401

    May 05, 2010 01:48 AM|eokim|LINK

    It seems like there is some issue in client. Based on your log, PROPFIND request does not have any authenticatioin info.

    What authentication is enabled on server, such as Windows authentication or Basic?

    Can you go through Using the WebDAV Redirector for your trouble shoot in client side?

     

     

  • Re: WebDAV authentication fails - 401

    May 07, 2010 02:50 AM|delcon|LINK

    Thanks for your answer. But when I try to log in with my Vista-Client I get the Login Screen but it does not validate my Login (I am useing Administrator for testing)

     

  • Re: WebDAV authentication fails - 401

    Dec 05, 2017 08:42 AM|william.chung|LINK

    I know this reply is seven years late, but I just gave WebDav a test drive and had the same error where WebDav would not allow me to authenticate.

    I had enabled it, but in the logs you could see a successful status 200 for the OPTION with a failed 401 error for the PROP request.

    I was trying a number of steps to troubleshoot, including disabling firewalls and editing the WebDav Authorization rules. 

    The last steps that did it for me when it started working was as follows:

    When I browsed to the webdav enabled site, I saw that Directory Browsing was disabled and it would not let me view the contents of the folders in the web browser.  I enabled Directory Browsing in IIS and browsed the files in the web browser.  Not sure if this did the trick because I later disabled directory browsing and WebDav was still working.

    The next thing I tried was using a different account from the one I was logged in with to access the WebDav network drive.

    This remarkably worked.  Not sure why my logged in account wouldn't authenticate, but using a different account worked.