"Windows Authentication" problemsRSS

4 replies

Last post Apr 28, 2010 03:01 PM by pvo01

  • "Windows Authentication" problems

    Apr 15, 2010 09:36 AM|pvo01|LINK

    I am sorry, but I asked this question on the IIS 7 General forum but I have not get any reply and it has been more than 3 days already. Thus, I would ask it one more on this forum because my time is running down and I need to get this work fast.

    **

    I am using windows 2008 r2 with iis 7.5 FastCGI and none thread-safe PHP 5.2.13

    This box is not on a domain.

    Windows Authentication is installed

    After I disable the "Anonymous Authentication" and enable the "Windows Authentication" things begin to acting really weir.

    If Windows Authentication is enabled, then each time I browse to a site/files (using IIS manager) Windows Security keep asking me for credentials. Well, it is weir because even if I enter some random credentials and KEEP-ON-HITTING OK/ or Cancel and it still works. On top of that, no matter what credential I enter in, each time I browse to a new site/link Windows Security just keep on asking for credential.   

    I think there is a miss configuration that I must have done.

    Please show me if you know a fix for this, or any KB that explains this.

    Thanks
  • Re: "Windows Authentication" problems

    Apr 15, 2010 12:16 PM|don.raman|LINK

    Hi,

    If you are using Internet Explorer, please look at KB article regarding why IE can keep prompting for login dialog at http://support.microsoft.com/?id=258063.

    Also look at http://www.asp.net/(S(pdfrohu0ajmwt445fanvj2r3))/learn/mvc/tutorial-18-vb.aspx though it is related to VB.

    Thanks,

    Don.

  • Re: "Windows Authentication" problems

    Apr 15, 2010 01:16 PM|pvo01|LINK

    don.raman

    If you are using Internet Explorer, please look at KB article regarding why IE can keep prompting for login dialog at http://support.microsoft.com/?id=258063.

     This KB only talk about why IE asking for credentials, but it doesn't say how to prevent/fix that.

     
  • Re: "Windows Authentication" problems

    Apr 22, 2010 06:56 AM|WenJun Zhang - MSFT|LINK

    The KB explains in which cases IE will not prompt and automatically finish integrated auth with IIS.

    Please make sure the client machine is joined into the domain and the web site has been added to local intranet zone.

     

  • Re: "Windows Authentication" problems

    Apr 28, 2010 03:01 PM|pvo01|LINK

    WenJun Zhang - MSFT

    The KB explains in which cases IE will not prompt and automatically finish integrated auth with IIS.

    Please make sure the client machine is joined into the domain and the web site has been added to local intranet zone.

     

     

    i am sorry but i don't understand why windows security keep on asking me for credentials. as well, why do i even need to join into a domain. what is the point of having local users/administrators account on the server?