Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection [Answered]RSS

25 replies

Last post Nov 15, 2013 04:48 AM by Ken Schaefer

  • Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Mar 08, 2010 12:04 PM|saqib_dotnet|LINK

    Hi all, 

    I am trying to use Windows Authentication in my asp code. I have read / tried all answers on the web  but couldnt my page to connect to sql. I m using classic asp.

    My conn string looks like :

    OCONN.OPEN ("PROVIDER=SQLOLEDB; DATA SOURCE myserver; INITIAL CATALOG=nrth; Integrated Security=SSPI; ")
    but I m getting following error. I also followed this post but still getting same error. ANY HELP WOULD BE APPRECIATED.

    Microsoft OLE DB Provider for SQL Server

    Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection.

    error '80004005'

     

     

    http://saqdotnet.blogspot.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Mar 08, 2010 12:14 PM|tomkmvp|LINK

    Your answer is most certainly here:
    http://www.bing.com/search?q=site%3Asupport.microsoft.com+Login+failed+for+user+%27%28null%29%27.+Reason%3A+Not+associated+with+a+trusted+SQL+Server+connection&mkt=*&FORM=IE8SRC

    Are you using Windows Integrated authentication and is SQL Server on another box?  If so, you're running into a double-hop delegation issue.  Because IE does not actually send the user's password with Windows Integrated authentication, IIS is then unable to in turn authenticate the user to a different server over the network. 

    If this is your scenario, then you have three options:

    1) enable kerberos for use with Windows Integrated

    2) switch IIS to use Basic authentication (and maybe enable SSL so clear text passwords are protected)

    3) give up on integrated security and just specify a userid and password in your connection string

    I prefer option #3 and I personally see no benefit to using integrated security with SQL Server connections from web apps.

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Mar 08, 2010 12:25 PM|saqib_dotnet|LINK

    I have already enabled kerberos since all my other dotnet websites are working fine (with Windows Auth).

    I dont like option 2 either and for option we need to create a SQL server account and our company doesnt want to do that.

     

    http://saqdotnet.blogspot.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 11:10 AM|jwp8710|LINK

    I am having a similar error but it is trying to log on with username NT AUTHORITY\ANONYMOUS LOGON

     Here is the setup:

    -We have a ASP Classic app, with C++ code components behind it. The client has three servers involved, all Windows Server 2003:

    1. <div mce_keep="true">Our web product installed </div>
    2. <div mce_keep="true">SQL Server 2005</div>
    3. <div mce_keep="true">Active Directory server</div>

     They are connecting with Windows Authentication because it is a requirement. They are military and it is required by the DoD, so I can't change that aspect of the equation :)

    As for authentication they replied "Both, but we use NTLM V2 and refuse all NTLM requests because of the vulnerabilities, but Kerberos is also in use. "

    I sent them a KB article on making sure the servers and services (MSSQLSERVER, etc) are delegates in Active Directory. Is there anything else I should try?

     

    Here is the KB article I sent them and told them to try the steps under "To configure delegation"

    http://technet.microsoft.com/en-us/library/dd296638%28WS.10%29.aspx

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 11:36 AM|tomkmvp|LINK

    What does your connection string look like?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 02:21 PM|jwp8710|LINK

    Provider=SQLOLEDB.1;Integrated Security=SSPI;Persist Security Info=False;Initial Catalog=winst2003;Data Source=XXXXXXXX;Use Procedure for Prepare=1;Auto Translate=True;Packet Size=4096;Workstation ID=XXXXXXX;Use Encryption for Data=False;Tag with column collation when possible=False

    That string is used in a call to OpenFromInitializationString off ATL::CDataSource

    The same exact string is used using the same exact method in our windows program on the same machine and it succeeds, so it's a web related issue.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 03:56 PM|jwp8710|LINK

    As another note, this all works perfectly on our network and no one in the company can repeat the behaviour.  Since the client is military related they can't WebEx or do a Live Meeting because it's not allowed so solution hunting has been hard since I just have to sent them things to try or questions I have and wait back for answers or do it on the phone without physically seeing anything.

     A contractor that works with them has repeated it on a set up of a few virtual machines though and he is availible for Live Meetings so I can test out theories through him and have him walk through screens with me, or give me control of the meeting to let me try to implement some things.

     The client is using ASP.NET 2.0 on their site, but not sure if that comes into play here.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 06:24 PM|tomkmvp|LINK

    Yes, that certainly makes troubleshooting very difficult. No, .NET does not matter in this case.

    Are they authenticating the users to the web app or browsing anonymously?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 09, 2010 08:51 PM|jwp8710|LINK

    Authentication on the virtual directory has Anonymous Access disabled and Windows Authentivation enabled.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 10, 2010 02:43 PM|jwp8710|LINK

    any update Tom? I know you're probably busy, but I was just checking.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 07:47 AM|tomkmvp|LINK

    This is going to be a tough one to sort out because of the tight requirements and lack of access to their system.  To confirm, they want to authenticate each web user to the databse as well?

    I am not all that familiar with kerberos configuration (never needed it myself) but there is plenty of information out there. If they are required to only use Windows Integrated authentication and they must pass this authentication from the web app to the SQL box, then kerberos is the only way to do this. One simple way to confirm this is the problem is to switch to Basic (with SSL of course to protect the passwords) and see if that works.

    I would suggest setting up the exact same environment on your end which will make it vastly easier to troubleshoot this.

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 09:59 AM|jwp8710|LINK

    Yes that is correct. They want to log on the machine with their doman credentials and then access the web app and authenticate with those credentials, then have the web app connect to SQL Server with windows authentication.

     I told them to try Basic Authentication and we'll see if that works.

    I am researching Kerberos. All this IT/network setup stuff is new to me.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 10:33 AM|jwp8710|LINK

    Client changed to only Basic Authentication and says now the web page won't load and gives a "The website cannot display the page."

     

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 10:44 AM|tomkmvp|LINK

    They need to disable friendly error messages in IE so we can see the detailed error.

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 11:02 AM|jwp8710|LINK

    Microsoft OLE DB Provider for SQL Server error '80004005' Login failed for user ''. The user is not associated with a trusted SQL Server connection.

    /wsweb/NOLOGIN.ASP, line 121

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 11:30 AM|tomkmvp|LINK

    What does the IIS log entry show for that request, and what does SQL Server show in its log?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 11:49 AM|jwp8710|LINK

    IIS:

    #Software: Microsoft Internet Information Services 6.0
    #Version: 1.0
    #Date: 2010-11-11 15:17:59
    #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2010-11-11 15:17:59 W3SVC1 10.4.25.244 GET /wsweb - 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 301 0 0
    2010-11-11 15:17:59 W3SVC1 10.4.25.244 GET /wsweb/Default.asp - 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 302 0 0
    2010-11-11 15:17:59 W3SVC1 10.4.25.244 GET /wsweb/NOLOGIN.ASP |121|80004005|Login_failed_for_user_''._The_user_is_not_associated_with_a_trusted_SQL_Server_connection. 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 500 0 0
    2010-11-11 15:18:58 W3SVC1 10.4.25.244 GET /wsweb - 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 301 0 0
    2010-11-11 15:18:58 W3SVC1 10.4.25.244 GET /wsweb/Default.asp - 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 302 0 0
    2010-11-11 15:18:58 W3SVC1 10.4.25.244 GET /wsweb/NOLOGIN.ASP |121|80004005|Login_failed_for_user_''._The_user_is_not_associated_with_a_trusted_SQL_Server_connection. 80 - 10.4.25.249 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+6.1;+WOW64;+Trident/4.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729) 500 0 0
    2010-11-11 15:24:00 W3SVC1 10.4.25.244 GET /wsweb/Default.asp - 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 302 0 0
    2010-11-11 15:24:00 W3SVC1 10.4.25.244 GET /wsweb/NOLOGIN.ASP |121|80004005|Login_failed_for_user_''._The_user_is_not_associated_with_a_trusted_SQL_Server_connection. 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 500 0 0
    #Software: Microsoft Internet Information Services 6.0
    #Version: 1.0
    #Date: 2010-11-11 16:01:13
    #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2010-11-11 16:01:13 W3SVC1 10.4.25.244 GET /wsweb/Default.asp - 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 302 0 0
    2010-11-11 16:01:13 W3SVC1 10.4.25.244 GET /wsweb/NOLOGIN.ASP |121|80004005|Login_failed_for_user_''._The_user_is_not_associated_with_a_trusted_SQL_Server_connection. 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 500 0 0
    2010-11-11 16:06:17 W3SVC1 10.4.25.244 GET /wsweb/Default.asp - 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 302 0 0
    2010-11-11 16:06:17 W3SVC1 10.4.25.244 GET /wsweb/NOLOGIN.ASP |121|80004005|Login_failed_for_user_''._The_user_is_not_associated_with_a_trusted_SQL_Server_connection. 80 - 10.4.25.84 Mozilla/4.0+(compatible;+MSIE+8.0;+Windows+NT+5.1;+Trident/4.0;+GTB6.4;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+OfficeLiveConnector.1.4;+OfficeLivePatch.1.3;+MS-RTC+LM+8) 500 0 0

    SQL SERVER:

    11/11/2010 11:06:17,Logon,Unknown,Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 10.4.25.244]
    11/11/2010 11:06:17,Logon,Unknown,Error: 18452<c/> Severity: 14<c/> State: 1.
    11/11/2010 11:06:17,Logon,Unknown,SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.4.25.244]
    11/11/2010 11:06:17,Logon,Unknown,Error: 17806<c/> Severity: 20<c/> State: 2.
    11/11/2010 11:01:13,Logon,Unknown,Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 10.4.25.244]
    11/11/2010 11:01:13,Logon,Unknown,Error: 18452<c/> Severity: 14<c/> State: 1.
    11/11/2010 11:01:13,Logon,Unknown,SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.4.25.244]
    11/11/2010 11:01:13,Logon,Unknown,Error: 17806<c/> Severity: 20<c/> State: 2.
    11/11/2010 10:25:14,Logon,Unknown,Login succeeded for user 'KMSGDEV\drew'. Connection: trusted. [CLIENT: 10.4.25.244]
    11/11/2010 10:24:00,Logon,Unknown,Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 10.4.25.244]
    11/11/2010 10:24:00,Logon,Unknown,Error: 18452<c/> Severity: 14<c/> State: 1.
    11/11/2010 10:24:00,Logon,Unknown,SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.4.25.244]
    11/11/2010 10:24:00,Logon,Unknown,Error: 17806<c/> Severity: 20<c/> State: 2.
    11/11/2010 10:18:58,Logon,Unknown,Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 10.4.25.244]
    11/11/2010 10:18:58,Logon,Unknown,Error: 18452<c/> Severity: 14<c/> State: 1.
    11/11/2010 10:18:58,Logon,Unknown,SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.4.25.244]
    11/11/2010 10:18:58,Logon,Unknown,Error: 17806<c/> Severity: 20<c/> State: 2.
    11/11/2010 10:17:59,Logon,Unknown,Login failed for user ''. The user is not associated with a trusted SQL Server connection. [CLIENT: 10.4.25.244]
    11/11/2010 10:17:59,Logon,Unknown,Error: 18452<c/> Severity: 14<c/> State: 1.
    11/11/2010 10:17:59,Logon,Unknown,SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.4.25.244]
    11/11/2010 10:17:59,Logon,Unknown,Error: 17806<c/> Severity: 20<c/> State: 2.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 12:12 PM|ArieH|LINK

    Hi,

    (Sorry in advance Tom for poking in :D )

    I'll try to make my answer short though I'm known for making long posts :D

    To have kerberos authentication in a domain environment when dealing with multiple hops you want the following:

    1. Decide whether you want to set the application pool identity to be Network Service or a dedicated domain user.

    2. If using Network Service as the identity of the application pool then the computer object of the server used to running IIS should be set as Trusted for Delegation. On the computer object in AD there should be a Delegation tab where you can set it to use Kerberos.

    3. If using a dedicated domain user, you want to make sure the user object is Trusted for Delegation. If i recall correctly all users created in a domain have a checkbox saying something like: 'This user is sensitive and can not be trusted for delegation' - make sure its not checked. In win2003 domain there should be a tab as well, for delegation where you set it to allow kerberos via that user.

    The dedicated user doesn't need any special local server permissions after you set it as in the Identity tab of the application pool when were talking about default installations. If the server has some layer of special NTFS permissions, you might need to add this user to the necessary drives\folder permissions.

    4. In your web.config you will need 2 lines to appear:

                              authentication mode="Windows"

                              identity impersonate="true"

    5.  Make a Domain group and add the actual domain user of the web application to that group. In your SQL Server, give permission to the domain group on the database it needs access to, and assign the proper permissions for it, build a custom role if you need one (the DBA of the server would know what I'm talking about, i hope for his sake :D) , or use a built in one like datareader for example, if all you do is read from tables (using dbowner is a bad security habit :D).

    If you do NOT use the impersonation setting in web.config, you will have to allow the domain user from the application pool identity, access to the sql server and permissions on the specific database.

    If you have used Network Service as your application pool identity, you need to add servername$ to the logins and assign it permission for the database. Or the other option would be of course to use sql user with appropriate changes to the connection string.

    7. Your web site settings should have only Windows Integrated, not basic and not anonymous.

    8. Make sure the browser used to surf the web site (assuming IE) has Use Windows Authentication setting checked (default is On) in the Advanced tab under the security section at the bottom.

    9. Surf away.

    Sysadmins on that server should start to get familiar with the setspn.exe utility as it will help them see if settings have changed in AD concerning the application pool user. This is one of the basic issues I've seen with implementing kerberos in a domain environment when you are doing multiple hops.

    Hope this gives you a head start. I'm sure you'll have more questions as this is from the top of my head so i might missed something that seems trivial to me but not so to others so don't hesitate to ask :D

    Take Care,

    Arie H.

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 02:16 PM|jwp8710|LINK

    Thanks. The only thing that confuses me is the web.config. I thought adding those lines were for .NET. Since this is classic ASP does that matter?

    Also, why do they need to make the domain group? Can't they just add themselves as a user in SQL as DOMAIN\USERNAME?

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 02:39 PM|tomkmvp|LINK

    Thanks for the log info, that's very helpful.

    web.config is for ASP.NET so it does not apply in this case.

    What the IIS log tells me is that the web site (or at least the requests in what you provided) is allowing anonymous access, which means that the SQL requests from ASP are going as the anonymous user.

    IIRC, you could create the same local anonymous user on your SQL box (give it the same name and password as on the IIS box) and then give that account access to the DB.  You could also use a domain account.  This MSKB is relevant: http://support.microsoft.com/kb/176380/

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 02:50 PM|jwp8710|LINK

    But if I add the anonymous user to SQL won't it be hitting SQL as that user. The whole point is that the client wants people logging into SQL Server as their DOMAIN\USERNAME.

    How could it be allowing Anonymous access if Anonymous authentication is disabled?

     I beginning to think I'll never solve this. I emailed a co-worker about it and his advice was "Delegation is not a simple topic. There are potentially huge issues, especially for an application that has never been developed or tested for this.  My recommendation is that you advise the client that the configuration is not currently supported and add it to the next release plan." lol. That is sounding like better advice every minute :)

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 11, 2010 07:23 PM|tomkmvp|LINK

    jwp8710

    How could it be allowing Anonymous access if Anonymous authentication is disabled?

    Those log entries prove that it is not.  : )

    jwp8710

    There are potentially huge issues, especially for an application that has never been developed or tested for this. 

    That is true, and is why I suggested setting up a similar environment in your shop.

    jwp8710

    My recommendation is that you advise the client that the configuration is not currently supported and add it to the next release plan.

    A reasonable approach for sure.

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 12, 2010 01:06 PM|jwp8710|LINK

    Yeah I guess I'd better try to set it up here and see if it repeats with 3 virtual machines. I'm just (a) lazy and (b) don't know jack about setting up AD and getting things going :)

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 19, 2010 01:59 PM|jwp8710|LINK

    Just as a follow up. Setting up Kerberos delegation fixed the problem. :)

  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Sep 25, 2013 10:08 AM|SJ_dotnet|LINK

    Hi ,

    I'm having a similar kind of issue but all the work arounds you had posted here does not work for me !

    I'm having a ASP.NET website which talks to the SQL DB through a WCF service. The application is deployed in Production and we are having issues recently that Save wont work only in 1 page during a certain period of time about 2:45PM until next day morning 6 AM. The error we get it an unhandled exception 

    Login failed for user '(null)'. Reason : Not associated wiuth a trusted SQL connection.

    The web app uses IIS app pool identity with a AD group username and pwd and Anonymous access option and Intergrated windows authentication are both enabled. The web app,WCF and the SQL server are all in different physical servers.

    We checked the event log and nothing suspicious except there is a memory pressure on the SQL server's SQL log during that period of time.But saving from any other page works just fine during the same window 2:45 PM - 6 AM. 

    Any help would really be appreciated. Thanks a bunch!


  • Re: Login failed for user '(null)'. Reason: Not associated with a trusted SQL Server connection

    Nov 15, 2013 04:48 AM|Ken Schaefer|LINK

    This forum is for Classic ASP issues on IIS5/6

    Please start a new thread in the appropriate forum, and post your actual configuration (e.g. your Kerberos configuration), what you expect to happen (or what happens when it's working), and what happens when it's not working.

    Thanks