Failing to restore backup on different IIS7 server [Answered]RSS

8 replies

Last post Jan 15, 2010 03:50 AM by workstation

  • Failing to restore backup on different IIS7 server

    Jan 07, 2010 06:25 AM|workstation|LINK

    Hi, Iam trying to migrate one IIS7 server to a different server and failing during restoring- Steps - 1. Took the backup of IIS7 using appcmd.exe on one server 2. Copied the backup to second server and then tried to restore the backup using appcmd.exe 3. appcmd.exe restore failed with the following error - ERROR ( hresult:80070426, message:Command execution failed. The service has not been started. ) Can someone guide me where Iam going wrong or provide the appropriate links where I can find the relevant information.
  • Re: Failing to restore backup on different IIS7 server

    Jan 07, 2010 06:27 AM|workstation|LINK

    Correction - Actually this is IIS7.5 on Windows 2008 R2 Appreciate your help
  • Re: Failing to restore backup on different IIS7 server

    Jan 07, 2010 07:12 AM|workstation|LINK

    Can we actually restore this way or is there any other way to restore or migrate?
  • Re: Failing to restore backup on different IIS7 server

    Jan 07, 2010 02:18 PM|Jamescoo|LINK

    There is a pretty nifty tool for syncing to iis7 servers as well as migrating from previous versions.  Lots of info including a download link below.

    http://www.iis.net/expand/WebDeploymentTool

    There is also a forum just for questions about this tool under General > 'Web Deployment Tool(MSDeploy)'

    Even though it says IIS6.0 and IIS7.0, it does also work with IIS7.5

  • Re: Failing to restore backup on different IIS7 server

    Jan 08, 2010 01:26 AM|workstation|LINK

    Thanks for the info. I will try this tool now.
  • Re: Failing to restore backup on different IIS7 server

    Jan 13, 2010 04:20 AM|workstation|LINK

    Hi James, Is there a way to do this without using any external tool? can you brief me why the restoring the backup of one server fails on other?
  • Re: Failing to restore backup on different IIS7 server

    Jan 13, 2010 04:24 AM|workstation|LINK

    Is there a way to do this without using any tool?
  • Re: Failing to restore backup on different IIS7 server

    Jan 13, 2010 01:00 PM|Jamescoo|LINK

    I do not know all the causes of this but any encryptions in configuration will be machine specific.  So if you have encrypted passwords in your applicationHost.config such as setting up a specific username/password on an applicationPool.  This encryption would be meaningless if just moved to another machine.

    WebDeployment Tool will do these kinds of things for you so your username/password will work on another box.

    This is probably not all the reasons though.

  • Re: Failing to restore backup on different IIS7 server

    Jan 15, 2010 03:50 AM|workstation|LINK

    In my case, I did not set any password for Application Pool. Hence I too think there are some more things involved here. If you know, could you please direct me to where can I get the required info on this?