We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Getting error right before seo analysis completes.RSS

6 replies

Last post Feb 19, 2010 08:48 PM by CarlosAg

  • Getting error right before seo analysis completes.

    Dec 16, 2009 08:26 AM|dcwhisen|LINK

    Hey guys this is my first post to the IIS community, so hello everyone. Anyways I am a noob to IIS, especially IIS7 but I am starting to love it more and more. I started to play with the SEO Analysis Reports yesterday and it has been great, however I get an error when I run our main site: http://www.rsfh.com. Once the analysis progress bar gets completely full, I get the following error: There was an error while performing this operation. Details: Invalid character in ‘_META_LINKSITE_{SECURE}’. The ‘{‘ character, hexadecimal value 0x7B, cannot be included in a name. Can anyone helps, advise? Thanks!

    seo toolkit

  • Re: Getting error right before seo analysis completes.

    Dec 17, 2009 10:10 AM|CarlosAg|LINK

    Thanks for reporting this.
    Unfortunately this is a bug in the current version that is triggered by a META tag that includes a name with certain characters (such as a ‘{’ and others).
    We have fixed this bug (and a couple of other issues reported) and will be releasing an update for it in a couple of weeks or so.

  • Re: Getting error right before seo analysis completes.

    Jan 29, 2010 11:02 PM|bugmenot|LINK

    I just downloaded and installed the IIS SEO Toolkit, and I encountered the same message. Any word on the availability of an update that addresses this?

     Thanks so much!

  • Re: Getting error right before seo analysis completes.

    Feb 01, 2010 03:01 AM|CarlosAg|LINK

    We have released a refresh version of the IIS SEO Toolkit that includes the fix for this problem, so please install the latest version and you should stop seeing this problem. Apparently replication was happening at the time you probably downloaded the version. Please try again and it should work.

    http://blogs.msdn.com/carlosag/archive/2010/02/01/announcing-iis-seo-toolkit-v1-0-1.aspx

     

  • Re: Getting error right before seo analysis completes.

    Feb 01, 2010 07:33 PM|bugmenot|LINK

    Thanks very much! I re-downloaded and reinstalled, and indeed I was able to view the report. Thanks again!
  • Re: Getting error right before seo analysis completes.

    Feb 19, 2010 07:37 PM|StreamL1ne|LINK

    Getting error at end of scan.
    Invalid name character in '_META_RECORD_....Solutions_' The ',' character, hexadecimal value 0x2c, cannot be included in a name.

    I installed the update, is there anything else I can do?
    Any help you can provide will be great.

  • Re: Getting error right before seo analysis completes.

    Feb 19, 2010 08:48 PM|CarlosAg|LINK

    Please make sure you have the latest version:

    http://go.microsoft.com/?linkid=9695987

    this shoudl be fixed in the latest version. Could you check the registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\IIS Extensions\IISSEO

    You should have a Version number there that is at least:   7.1.731.0

    This is the refresh release, if you have 7.1.672.0 or smaller then you are running the RTW or less which includes that issue.