We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Tag style was not closed correctly...RSS

6 replies

Last post Feb 01, 2010 02:54 AM by CarlosAg

  • Tag style was not closed correctly...

    Dec 15, 2009 10:32 PM|clively|LINK

    I'm getting the following error:

    The Tag 'style' was not closed correctly, the Tag 'head' was closed instead.

    I looked at my html and I can't locate the issue.  I have one style tag, and it is closed.  It's in the format of <style id="StylePlaceholder" type="text/css"></style>

    Is there a problem with that?

     

  • Re: Tag style was not closed correctly...

    Dec 16, 2009 10:22 AM|jeff@zina.com|LINK

     Does the style tag appear inside the head?  If not, it's improper.

    Jeff

    Have you Binged a solution before posting?
  • Re: Tag style was not closed correctly...

    Dec 16, 2009 11:13 AM|CarlosAg|LINK

    Any chance you could share the full markup (or at least inside the <head></head>)., or even better if you could share the URL of the page if its in the internet. If you want you can send it to me same user at microsoft . com .

  • Re: Tag style was not closed correctly...

    Dec 16, 2009 08:17 PM|clively|LINK

  • Re: Tag style was not closed correctly...

    Dec 16, 2009 11:57 PM|CarlosAg|LINK

    Thanks for reporting this, it is indeed a bug in our parser. It will be fixed in a release that we'll have in a couple of weeks.

  • Re: Tag style was not closed correctly...

    Dec 17, 2009 12:00 AM|clively|LINK

    Great!

    Thanks, thought I was going crazy.

  • Re: Tag style was not closed correctly...

    Feb 01, 2010 02:54 AM|CarlosAg|LINK

    FYI, there is now a new version of the IIS SEO Toolkit that includes the fix for this problem, so please install the latest version and you should stop seeing this problem.

    http://blogs.msdn.com/carlosag/archive/2010/02/01/announcing-iis-seo-toolkit-v1-0-1.aspx