We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Invalid name character in '_META_COLOR:BACKGROUND'. The ':' character, hexadecimal value 0x3A, cannot be included in a nameRSS

2 replies

Last post Feb 01, 2010 02:55 AM by CarlosAg

  • Invalid name character in '_META_COLOR:BACKGROUND'. The ':' character, hexadecimal value 0x3A, ca...

    Dec 15, 2009 03:29 PM|Rick_Kierner|LINK

    I recently downloaded the SEO toolkit app and ran it against my site.  It failed near the end of the process with the following error message:

    Invalid name character in '_META_COLOR:BACKGROUND'. The ':' character, hexadecimal value 0x3A, cannot be included in a name

    I brought my site down locally and removed all the blog posts.  It was successful to process it then.  One by one, I added back in my blog posts until it failed again.  The post it failed on was a standard post with nothing special in the HTML....so I edited the post until I had narrowed down the single line of markup causing the problem.  It was a link to a colleague's site.  On his site, he has

    <div class="msg Nth"><meta name="color:Background" content="#D0CCC1"/></div> <div class="msg Nth"> </div> <div class="msg Nth">On line 6 of his markup.  Note the ":" character in the name property.  I believe that is what is causing the problem. My complaint is that regardless of who I link to, I wasn't asking for information about seo on my colleague's site...only on mine.</div> <div class="msg Nth"> </div> <div class="msg Nth">Any information would be helpful</div>

    bug seo toolkit

    Rick Kierner - http://rickdoes.net
  • Re: Invalid name character in '_META_COLOR:BACKGROUND'. The ':' character, hexadecimal value 0x3A...

    Dec 17, 2009 10:08 AM|CarlosAg|LINK

    Thanks for reporting this.
    Unfortunately this is a bug in the current version that is triggered by a META tag that includes a name with certain characters (such as a ‘,’ ':' and others).
    We have fixed this bug (and a couple of other issues reported) and will be releasing an update for it in a couple of weeks or so.

     

  • Re: Invalid name character in '_META_COLOR:BACKGROUND'. The ':' character, hexadecimal value 0x3A...

    Feb 01, 2010 02:55 AM|CarlosAg|LINK

    A new version of the IIS SEO Toolkit that includes the fix for this problem, so please install the latest version and you should stop seeing this problem.

    http://blogs.msdn.com/carlosag/archive/2010/02/01/announcing-iis-seo-toolkit-v1-0-1.aspx