We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

ASP Upload and Windows 7 UltimateRSS

3 replies

Last post Nov 12, 2009 01:50 AM by qbernard

  • ASP Upload and Windows 7 Ultimate

    Nov 05, 2009 07:45 PM|MuskokaMark|LINK

    Hi folks.  I upgraded from xp pro to W7U64.  On my old install I had terminal services installed and web services enabled with an ASP upload script on there.  I am a graphic designer and had a need for my clients to upload large files to me and prefer they do that right ot my computer rather than some remote server.  Everything worked great in xp pro.  However in W7 I find I am plagued with an file size upload limit.  For the life of me I cannot find where to remove or increase this upload file size limit in any of the docs or online.


    Can someone help me please?

  • Re: ASP Upload and Windows 7 Ultimate

    Nov 05, 2009 08:57 PM|qbernard|LINK

    You can look at the ASP - limit properties - maxRequestEntityAllowed, and Request Filtering - Edit Feature Settings - maxAllowedContentLength.
    Bernard Cheah
  • Re: ASP Upload and Windows 7 Ultimate

    Nov 11, 2009 05:43 AM|MuskokaMark|LINK

    Here are the settings I have in there.

    Client Connection Test Inverval              00:00:03
    Maximum Request Entity Body Limit     200000
    Queue Length                                      00:00:00
    Request Queue Time-out                      00:00:00
    Response Buffering Limit                      4194304
    SAcript Time-out                                  00:01:30
    Threads per Processor Limit                  25

     These settings are the basic install settings nothing has been altered.  in IIS for XP pro I could use that script to upload 300 megs with no issue at all.  With Windows 7 I am crapping out on 400k files getting the following error

    007~ASP 0104~Operation not Allowed~

    The most likely cause for this error is the incorrect setup of AspMaxRequestEntityAllowed in IIS MetaBase. Please see instructions in the

     This is of course what you had stated but this is not a field in the ASP Features of windows 7 ultimate.


  • Re: ASP Upload and Windows 7 Ultimate

    Nov 12, 2009 01:50 AM|qbernard|LINK

    My Win 7 is not with now. :( 

    Err.. I posted maxRequestEntityAllowed for ASP section.
    so either - Go to the IIS Manager, navigate to the site, then click on 'asp' icon. in the limit property setting, change it to the value you want.

    or try appcmd to configure it.
    appcmd set config /section:asp /maxRequestEntityAllowed:int

    Bernard Cheah