Running Classic ASP site on 64bit Windows 7 [Answered]RSS

5 replies

Last post Mar 14, 2012 11:50 AM by newclique

  • Running Classic ASP site on 64bit Windows 7

    Nov 04, 2009 06:57 AM|Mintyman|LINK



    This is my first post here. I'm not a super duper techie so i've included as much information as I can think of in order to help explain my issue. Please go easy on me!

    I havebeen using an old PC running Win XP Pro with IIS 5 and SQL Server 2000 which ran my development environment for my website. It uses a mixture of both MS Access and SQL databases (not got round to migrating everything over to SQL yet!). I have just bought a new PC with 64bit Windows 7 on it.

    When I try and set up my site, I get the following error:

    ADODB.Recordset error '800a0e7a'
    Provider cannot be found. It may not be properly installed.
    , line 33

    Line 33 refers to a connection string in an include file:

    Dim MM_Directory_STRING
    MM_Directory_STRING = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=c:\xxxxxx\xxxxxxx\Directory.mdb;Persist Security Info=False"

    After a bit of hunting, I read that I need to create a new application pool in IIS (whatever that is!) . Anyway, I found the right section and created a new one. I also set it to allow 'enable 32-Bit Applications' in the advanced settings screen. I applied this application pool to the default website, restarted IIS and refreshed the page.

    Now I get this error:

     error '80004005'
    , line 86

    Line 86 refers to the following:

    85 - Set Upcoming_Events = Server.CreateObject("ADODB.Recordset")
    86 - Upcoming_Events.ActiveConnection = MM_DirectorySQL_STRING
    87 - Upcoming_Events.Source = "SELECT *  FROM Q_Upcoming_Events  WHERE Start_Date <= (GetDate() + 60)  ORDER BY Start_Date ASC"

     MM_SemiDirectorySQL_STRING is related to a connection to a local SQL Express, which is connected to via a DSN connection with mixed mode authentication.

     That's as far as i've got to.

    Can anyone help me with this? I'll be eternally grateful.



  • Re: Running Classic ASP site on 64bit Windows 7

    Nov 04, 2009 09:06 PM|artbytes|LINK

    I'm having exactly the same problem. Applications that ran with the JET.OLEDB.40 driver are getting the same error as above on WIindows 7.  I have used these applications on XP Pro and Vista computers without problems.

     I found my MSJET40.dll file. It''s version 4.00.9756.0, so it exists.

    I tried installing the drivers for MS Office 2007 and using this connection string:

    Provider=Microsoft.ACE.OLEDB.12.0; Data Source=c:\aWeb\234\data\mydb.mdb;

     That did not work either.

    IIf anyone know the solution, I'd love to hear it.

     Thanks so much.


  • Re: Running Classic ASP site on 64bit Windows 7

    Nov 10, 2009 04:56 AM|WenJun Zhang - MSFT|LINK

    Make sure the authenticated identity has Read/Write NTFS permission on System temp directory. If anonymous access is allowed, the account should be IUSR_<machinename> .

    If still no success, run tools like process monitor to track down the I/O of w3wp.exe process and repro the issue. It will show you where the denied access is.

  • Re: Running Classic ASP site on 64bit Windows 7

    Nov 10, 2009 06:45 AM|ahmetqw|LINK

    Make sure you check:

    (or through IIS7 manager:

    1. Right click on the Application Pool and select “Advanced Settings…”
    2. Change the “Enable 32-bit Applications” to True)

    As far as I remember, JET is x86 and therefore not enabled/used (by x64 IIS) by default.

  • Re: Running Classic ASP site on 64bit Windows 7

    Apr 05, 2011 08:56 PM|bsardinha|LINK

    If you don't place your DLLs in the SysWOW64 folder you'll get the error Permission denied on the CreateObject statement.  I haven't seen this solution anywhere!

  • Re: Running Classic ASP site on 64bit Windows 7

    Mar 14, 2012 11:50 AM|newclique|LINK

     One other thing to check, especially if you have copied files from one machine to another: Check the NTFS security settings on the .asp files and be very, very sure that the AppPool account can actually read and execute them.

    classic asp permission windows 7 access denied 401