ASP not working [Answered]RSS

13 replies

Last post Sep 28, 2009 05:55 PM by tipprovider

  • ASP not working

    Sep 25, 2009 03:05 PM|wonsteroca1|LINK

    After I installed IIS 6.0 on Windows server 2003 and Allowed "Active Server Pages" in the IIS Manager the "test.asp" does not even come up.  I get an error on the browser saying "The page cannot be displayed" and at the bottom of the page I have "Cannot find server or DNS Error"

    I am able to browse to a test.htm page but asp does not work.

    Any help is really appreciated.

    Thanks

    won...

  • Re: ASP not working

    Sep 25, 2009 03:10 PM|ServerIntellect_BH|LINK

    Hello,

    As you are able to get to a test.htm page but asp doesn't work, it sounds like either the Web Service Extensions aren't allowing .NET 1.1 or your handler mappings aren't set correctly.

    See the following on how to set up .NET 1.1 on IIS 6:

    http://www.asp.net/learn/whitepapers/aspnet-and-iis6/

    Hope this helps!

    Brock Hensley
  • Re: ASP not working

    Sep 25, 2009 03:26 PM|tomkmvp|LINK

    ServerIntellect_BH

    it sounds like either the Web Service Extensions aren't allowing .NET 1.1 or your handler mappings aren't set correctly

    .NET does not handle classic asp.  ; )

    Plus if it was web service extensions then the OP would see a 404 error (page not found) with sub-status code 2.

    Anyway, that error is saying your browser can not connect to or find the server, which given that you can browse test.htm does not make sense. We must be missing something here.

    What URL do you use to browse test.asp and test.htm?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: ASP not working

    Sep 25, 2009 03:57 PM|wonsteroca1|LINK

    I use the URL

    1. http://localhost/test.asp

    2. http://10.202.166.177/test.asp

    3. http://mem2psp01/test.asp

    All return same error.

     

    Thanks

  • Re: ASP not working

    Sep 25, 2009 03:59 PM|wonsteroca1|LINK

     I use the following...

    1. http://localhost/test.asp (just localhost)

    2. http://10.202.166.177/test.asp (ip address)

    3. http://mem2psp01/test.asp (hostname)

    They all return the same error.

     

    Thanks.

  • Re: ASP not working

    Sep 28, 2009 09:05 AM|tomkmvp|LINK

    ... and all of those with test.htm work?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: ASP not working

    Sep 28, 2009 09:30 AM|wonsteroca1|LINK

     Yes the test.htm works.  That is why I am so confused.  Also when I prohibit ASP I get the following error.

    HTTP Error 404 - File or directory not found.

    Which I think is normal since I turned off ASP.  This thing is driving me crazy.  I have uninstalled IIS and reinstalled IIS twice already to no avail.  I can't figure out what might be causing this.  One more thing.  This is a VMWare Virtual Machine I am trying to do this on.  I don't think this has anything to do with it but maybe it might have an effect.

    Thanks

  • Re: ASP not working

    Sep 28, 2009 10:20 AM|tomkmvp|LINK

    Is anything getting logged by IIS for the ASP requests?

    Anything appearing in the server's system or application event logs?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: ASP not working

    Sep 28, 2009 02:51 PM|tipprovider|LINK

    Have you guys updated your server recently?

  • Re: ASP not working

    Sep 28, 2009 02:57 PM|tipprovider|LINK

     I was just thinking - is this on VMware?

  • Re: ASP not working

    Sep 28, 2009 05:00 PM|tomkmvp|LINK

    wonsteroca1

    This is a VMWare Virtual Machine I am trying to do this on. 

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: ASP not working

    Sep 28, 2009 05:04 PM|tipprovider|LINK

    Ah, I missed that. I was able to do some "tinkering" and fix his issue for him I think.

  • Re: ASP not working

    Sep 28, 2009 05:19 PM|tomkmvp|LINK

    Can you share the fix for the benefit of other readers?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: ASP not working

    Sep 28, 2009 05:55 PM|tipprovider|LINK

    I was trying to get a response out of the poster but he won't bite. Ha.

     

    Re-application of service pack 2.