We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

HTTP Error 500.23 - How do i solve this? [Answered]RSS

9 replies

Last post Oct 31, 2013 12:32 PM by h2romero

  • HTTP Error 500.23 - How do i solve this?

    Sep 18, 2009 09:28 AM|uid331497|LINK

     hi guys,

    i've just switched to Windows 7 RTM and installed ASP.NET and IIS

     i seem to get the error HTTP Error 500.23 - Internal Server Error

    An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode

    how do i solve this problem?

     

  • Re: HTTP Error 500.23 - How do i solve this?

    Sep 18, 2009 09:36 AM|ganeshanekar|LINK

    This error 500.23 translates to - An ASP.NET httpHandlers configuration does not apply in Managed Pipeline mode.

    Check the httpHandlers configuration in IIS. Try following:

    1. Open Server Manager
    2. Select Roles>Web Server (IIS)>IIS Manager>Select the Server>Applocation Pools
    3. Select the appPool that your asp.net app is running under>Click on 'Advanced Settings' from the right hand pane.
    4. Under Advanced Settings>General>Managed Pipeline Mode, select "Classic"
    5. Recycle app pool and test your app.

    HTH.

    ~ Ganesh

    Please: Don't forget to click "Mark as Answer" on the post that helped you. That way future readers will know which post solved your issue.
  • Re: HTTP Error 500.23 - How do i solve this?

    Sep 18, 2009 09:37 AM|ServerIntellect_BH|LINK

    Hello!

    You will need to open IIS manager, and go to the Application Pool for your site.

    Change the properties of the application pool from "Integrated" to "Classic".

    For more information see:

    http://technet.microsoft.com/en-us/library/cc731755(WS.10).aspx

    http://learn.iis.net/page.aspx/244/how-to-take-advantage-of-the-iis7-integrated-pipeline/

    Hope this helps!

    Brock Hensley
  • Re: HTTP Error 500.23 - How do i solve this?

    Sep 24, 2009 07:09 PM|anilr|LINK

    Also, if you want to remain in integrated mode, please use the instructions in the custom-error message and also in this blog post to migrate the handler/module entries to the new section.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: HTTP Error 500.23 - How do i solve this?

    Nov 22, 2010 06:54 AM|sinkeera|LINK

    Do I need to be logged in as Administrator, or can I be logged as a User with Admin rights ?

  • Re: HTTP Error 500.23 - How do i solve this?

    Jan 19, 2011 04:22 AM|shijo4567|LINK

  • Re: HTTP Error 500.23 - How do i solve this?

    Jan 21, 2011 01:46 PM|cor2879|LINK

     The above answers which refer to reverting to Classic mode may be adequate solutions for many cases, however it is possible to fix this problem while keeping your app pool in integrated mode, which may be desirable for many scenarios (such as when impersonation is being used to authenticate).

     To fix this while maintaining integrated mode, add the following markup to your application's web.config in the configuration section:

        <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        </system.webServer>
    "The difference between genius and stupidity is that genius has its limits."

    - Albert Einstein
  • Re: HTTP Error 500.23 - How do i solve this?

    Aug 08, 2011 03:37 AM|Daada|LINK

    Thanks. I am new to Window Server 2008. The interface totally different from Window server 2003. I had solved my problem refers to your reply above. Thanks a lot.

  • Re: HTTP Error 500.23 - How do i solve this?

    Jun 01, 2012 07:32 AM|aslam1|LINK

    IIS Manager>Application Pools>ASP.NET (any version running on your PC)>

    Double Click on it and set it to Classic and hit OK.

    Then Right Click on Your current project 

    Manage Application>Advanced Settings>Application Pool>ASP.Net (any version running on your PC)

    Note: The  Application Pool will be initially "DefaultAppPool". You need to change it to ASP.Net(Version)

    This should solve your issue.

    If it still dose not solve the issue. Follow the steps below along with the above steps.

    Click on the top of the tree structure i.e., the Server/Your PC

    In ISS you may find ISAPI and CGI Restrictions

    Double Click >Make sure all the Restrictions are set to Allowed.

    If you are currently running a 32-Bit version of Operating System then it dose not then do not worry if all the Restrictions are not set to Allowed.

     

  • Re: HTTP Error 500.23 - How do i solve this?

    Oct 31, 2013 12:32 PM|h2romero|LINK

    If you want to stay on pipeline mode do the following on your Web.config

     <!-- Comment out httpHandlers -->  

    <!--<httpHandlers>   <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" validate="false"/>  </httpHandlers>-->

     

    <!--Add handlers -->   

    <handlers>        <add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/>    </handlers>