8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!! [Answered]RSS

7 replies

Last post Sep 28, 2009 07:33 AM by benliddicott

  • 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Aug 25, 2009 03:41 PM|Narnian|LINK

    I recently set up my IIS to do SMTP relay to my Domino email server so that I could use Antigen for SMTP, and it works great (mostly).  MAil has been routing successfully for two weeks.  However, I discovered that some messages are getting tossed without notice.  As it turns out, my Domino email server can't handle 8bitmime and is rejecting the relayed messages.  I poked around and found this article that explains how to turn off 8bitmime on the IIS SMTP service so it doesn't get advertised, which should eliminate the problem: 

     http://support.microsoft.com/default.aspx?scid=kb;[LN];Q262168

     I've run into an incredibly frustrating snag.  First, it mentions that the utility you need to turn off 8bitmime is MDUTIL.EXE, and that it's located in the I386 directory of your install CD.  Well, it's not there.  I searched both install CD's for win2003 R2, it's not to be found.  Not in cabs, not in any folders.  No where.

     I dug out a copy of windows 2003 R1.  It had a file called MDUTIL.PDB.EXE.  I copied that over and tried running it but get an error "program too big to fit in memory".

    I've spent four hours trying to track down MDUTIL.EX_ and instructions from the net,

    I'm stumped.  I can't figure out how you're supposed to get the SMTP service to stop advertising for 8bitMime on windows 2003R IIS 6.  Can ANYONE PLEASE help me before I shoot myself :)

     

  • Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Aug 30, 2009 12:38 PM|Narnian|LINK

    I guess nobody knows.

  • Rovastar Rovastar

    5482 Posts

    MVP

    Moderator

    Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Aug 30, 2009 07:39 PM|Rovastar|LINK

     That appears to be a windows 2000 program.

    And it is unclear if the solution anyway would work for windows 2003/iis6.

    But you could try editing the metabase anyway with those values under smtpsrv.

    mdutil is just an old metabase editor. You could use metaedit instead and drill down.

    Back up you metabase first.

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Sep 01, 2009 01:01 AM|Narnian|LINK

    Yay!  Thank you for your help!  I've posted on four different forums and this is the first response I've gotten.

    I don't know if this is going to solve my issue, but searching for metabase editor got me to the tools I needed to download from MS.  The IIS 6 resource kit includes a Metabase editor:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=56fc92ee-a71a-4c73-b628-ade629c89499&displaylang=en 

    A little more headscratching on locating the right key, and I was able to edit the value mentioned in the first MS article. The value is as advertised in the article, so I'm crossing my fingers and hoping that following their recommendation and restarting IIS will turn 8bitMime off.

    I'll check everything tomorrow evening or the next day and see if I'm still getting rejections on 8BitMime messages.  If you don't see a follow up posting, then assume it's case closed.  If I still have trouble I'll at least post here so anyone else with the same problem knows to keep digging.

    I really should upgrade to Win2008 and IIS 7, but I'm chicken of breaking something.  Err, maybe next month . . . or the month after that . . . or . . .

     

  • Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Sep 01, 2009 06:01 AM|espa|LINK

    Dear Narnian,

    You wrote:

    "A little more headscratching on locating the right key..."

    Can you help me on locating this key please ?

    Thanks

  • Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Sep 01, 2009 09:26 AM|espa|LINK

    Finally I managed to find the key.

    The key is the  36998 SmtpInboundCommandSupportOptions

    1. Install the "IIS 6.0 Resource Kit"

    2. Start "Metabase Explorer"

    3. Navigate to SERVER NAME -> LM -> SmptpSvc (for all SMTP Instances)

    4. Select Menu "View -> Inherited Data (CNTR-I)"

    5. Locate 36998 SmtpInboundCommandSupportOptions and set the value 3503297 = 3574C1    Default but with 8bitmime Disabled or any other value you may need

    Good Luck

  • Rovastar Rovastar

    5482 Posts

    MVP

    Moderator

    Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Sep 01, 2009 10:13 AM|Rovastar|LINK

    Well done of fine tuning that. It will come in useful for others and a much better way that that knowledge base article. :)

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: 8BITMIME problem on Windows 2003 R3 - mdutil not found. HELP!!!!

    Sep 28, 2009 07:33 AM|benliddicott|LINK

    I strongly recommend you turn off 8BITMIME, BINARYMIME and CHUNKING.

    As far as I can tell, this is because IIS SMTP service has a bug which results in an unneccessary "Gateway Transformation" to remove any quoted printable encoding, including quoted-printable encoding of HTML email. This seems to occur when a message is transmitted to a server which supports BINARYMIME, i.e. the transformation occurs on the sending server, if the recipient supports BINARYMIME. So if you are relaying via IIS, and your IIS advertises BINARYMIME, the transformation occurs. This can cause lines to exceed 1024 characters, which the relay will then happily transmit to any server which advertises 8BITMIME. Many servers cannot handle lines over 1024 characters, and indeed doing so is not a requirement of 8BITMIME. (8BITMIME is utterly pointless IMHO).

    This will cause you problems relaying to PostFix servers which support 8BITMIME but not BINARYMIME, and have a very short line length to boot.

    Be aware that the following flags are undocumented but you shouldn't turn them off:

    0x4000 controls Authentication

    0x10000 controls AUTH=LOGIN basic authentication

    There are other undocumented flags, 0x1, 0x2000, 0x40000 which are set by default and I don't know what they do so leave them alone.

    To keep the default and turn off BINARYMIME and 8BITMIME, use 357569.

    To also turn of TURN, ATRN, ETRN, use 356417. 

    The easy way to do this is:

    cscript c:\path\to\adsutil.vbs SET SmtpSvc/1/SmtpInboundCommandSupportOptions 356417

    If you have more than one SMTP service you may have to do this with other numbers than 1, for example SmtpSvc/2/SmtpInboundCommandSupportOptions.