IIS on Windows 7 - management service missingRSS

8 replies

Last post Jul 28, 2011 11:35 AM by amgc

  • IIS on Windows 7 - management service missing

    Aug 08, 2009 12:46 PM|Rytis|LINK

    I am trying to configure FTP with IIS Manager Authentication on Windows 7 Ultimate. The problem is, that "Management service", "IIS Manager Users", "IIS Manager Permissions" icons is missing on IIS Manager. "IIS Management Service" is enbaled in Windows Features. What I am doing wrong? Thanks!
  • Re: IIS on Windows 7 - management service missing

    Aug 08, 2009 10:34 PM|rickycheng|LINK

    same case here...

  • Re: IIS on Windows 7 - management service missing

    Aug 20, 2009 12:58 PM|zc0000|LINK

    i am exactly meeting the same case ! how to solve it ? Experts please help !
  • Re: IIS on Windows 7 - management service missing

    Aug 20, 2009 04:32 PM|CarlosAg|LINK

    Unfortunately that feature is not available in Windows Client SKU's, you can still configure it programmatically or through manually using the configuration, but I think the simplest is using a simple powershell commandlet.

    If all you want to do is add new IIS Users and Grant them permissions to a specific Site you can use Microsoft.Web.Management API for that, just add a reference to it and the code would be something like:

    // Add a new IIS User
    ManagementUserInfo user =
           ManagementAuthentication.CreateUser("MyUser", "ThePassword");

    // Grant Permissions for The user to connect to Default Web Site

    ManagementAuthorization.Grant(user.Name, "Default Web Site", false);

    // Grant Permissions for regular Windows User to connect to Default Web Site
    ManagementAuthorization.Grant("MyDomain\\NonAdminUser", "Default Web Site", false);

     

    All of these should be "easy" to call directly from PowerShell directly without having to build a custom application.

  • Re: IIS on Windows 7 - management service missing

    Dec 06, 2009 06:04 AM|reuvygroovy|LINK

    Is there any way to allow people to connect via Windows Authentication instead?

    What is the purpose of the "Web Management Service" in Windows 7 if you cannot manage it remotely?

    Is there any way to allow a person to fully manage another Windows 7 IIS from a remote machine without having to grant access to a specific site?

    Can you write the code (or show me where to find it) to undo the permissions in your powershell code?

  • Re: IIS on Windows 7 - management service missing

    Mar 04, 2010 06:38 AM|SteveSpicer|LINK

     Unbelievable.  I've been trying to configure IIS for two days now on a new Windows 7 machine after my motherboard died on my old XP machine. Using my old asp.net files and trying to set up a new Intranet on the new machine. Where do these engineers live? On the moon? How do I find and use the "Microsoft.Web.Management API" and what does "...something like:" mean?

    *****
    Just because you think you know where you are going doesn't mean you can't get lost.
    *****
  • Re: IIS on Windows 7 - management service missing

    Jul 13, 2011 11:26 AM|xlent_f|LINK

    Open Web Platform Installer(WPI) and add IIS: Management Service, under Products. If you don't know where to find WPI go to IIS Manager -> Server Node -> Management Section in the Server. If it's not on there install it from http://www.microsoft.com/web/gallery/install.aspx?appid=WDeploy

    IIS 7.0

  • Re: IIS on Windows 7 - management service missing

    Jul 25, 2011 11:49 AM|rojar|LINK

    Install a feature (for example SMTP server) that requires IIS, here you will have opportunity to install IIS management feature. check back your IIS manager.
  • Re: IIS on Windows 7 - management service missing

    Jul 28, 2011 11:35 AM|amgc|LINK

    Sorry to answer too late, but I have the same problem. At the following link http://technet.microsoft.com/en-us/library/cc753473.aspx is explained that Management Service and Tools are available on Windows 7 (clients) but I can check that to be enabled from "Turn on or off windows features".

    Best regards

    Ángel Manuel