PHP 5.3.0 IIS7 500 Error [Answered]RSS

2 replies

Last post Aug 07, 2009 05:37 PM by ntcrash

  • PHP 5.3.0 IIS7 500 Error

    Aug 07, 2009 04:52 PM|ntcrash|LINK

    I am getting a 500 error on some pages but not all.  My WordPress Blog is working fine, it is an older TimeTracking site that I am having issues moving to my new 2008 boxes. 

    http://mysite/timesheet/daily.php?client_id=0&proj_id=0&task_id=0&month=8&year=2009&day=7 gives me a 500 error

    and  http://mysite/timesheet/calendar.php works fine.  I also have a site using zencart that no longer functions I just get the 500 internal error page... Any help would be great appreciated.

     I have followed a lot of the tutorials on this site and others but keep getting the same issue, I have also tried 5.2.10, and 5.3.1 (DEV)

    Thanks!


  • Re: PHP 5.3.0 IIS7 500 Error

    Aug 07, 2009 05:04 PM|don.raman|LINK

    Hi,

    Please turn off the browser "Show friendly HTTP error messages" and see what error you are getting and let me know. In Internet Explorer you can do it by:

    • <div mce_keep="true">Going to Tools--->InternetOptions</div>
    • <div mce_keep="true">Got to Advanced</div>
    • <div mce_keep="true">Under Browsing section uncheck the box "Show friendly HTTP error messages"</div>
    • <div mce_keep="true">Rerun the code and tell what error messages you are getting</div>

    Also ensure that error reporting is set to E_ALL in your PHP.INI file.

    Thanks,

    Don.

  • Re: PHP 5.3.0 IIS7 500 Error

    Aug 07, 2009 05:37 PM|ntcrash|LINK

    Re-installed 5.2.10, enabled Short-tags, and timezone, set logging to e_all, changed IE to show non friendly error messages, and it showed me the line that was causing issues.

     [timeformat]  to ['timeformat'] and it works

    Thanks!