FastCGI does not work with PHP 5.3.0 VC9 ??RSS

5 replies

Last post Oct 10, 2010 09:19 PM by jrhyne2584

  • FastCGI does not work with PHP 5.3.0 VC9 ??

    Aug 04, 2009 02:51 PM|buckelkratz|LINK

    My system:

    • Windows Server 2003 x64
    • IIS 6.0
    I have set-up my system to use PHP with FASTCGI. The MS 2008 C++ Runtime x64 is installed.

     

    If I use PHP 5.3.0 VC9 I get the following error message when I want o load an .php page:

    FastCGI Error

    The FastCGI Handler was unable to process the request.

    Error Details:

    • Error Number: 14001 (0x800736b1).
    • Error Description: This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.

    HTTP Error 500 - Server Error.
    Internet Information Services (IIS)

    If I use PHP 5.3.0 VC6 everything works fine. I can reproduce the error by changing the php files (and thus the php version) in my c:\php folder. I have also tested PHP 5.2.10 VC6, it works also.

     Do you have any idea to counter this problem, since php.net recommends the usage of the VC9  packages when running on IIS. (http://windows.php.net/download/)

     

    Thanks for your help

    buckelkratz

     

     

     

     

     

     

  • Re: FastCGI does not work with PHP 5.3.0 VC9 ??

    Aug 05, 2009 07:50 AM|JulienTLD|LINK

    Hi, 

    Did you use the VC9 x86 edition or the VC9 x64 edition of PHP 5.3.0 ?

    You have normally to use the x64 binaries.

    You can also try to test TS or NTS versions to see if one works better.

  • Re: FastCGI does not work with PHP 5.3.0 VC9 ??

    Aug 05, 2009 10:11 AM|buckelkratz|LINK

    There is only the VC9 x86 edition of PHP 5.3.0 available right now (= http://windows.php.net/download/, 2009-08-05), so I used the x86 version.

    The combo box on the top of the download page contains the x64 version, but it is not listed below....

     

  • Re: FastCGI does not work with PHP 5.3.0 VC9 ??

    Sep 30, 2009 10:47 AM|david_g17|LINK

    you need the 64 bit version of:

    Microsoft Visual C++ 2008 Redistributable Package (x86)

     

     http://www.microsoft.com/downloads/thankyou.aspx?familyId=9b2da534-3e03-4391-8a4d-074b9f2bc1bf&displayLang=en

    There's also a 64 bit version for 64 bit operating systems.

     

    I had the same problem and installed the 32 bit package above, and it fixed the problem.  I think the version 5.3 of PHP does not include some developmental files which are included in the redistributable package above.

     

    I posted in this thread b/c it comes up when I google the error message I was getting.

    PHP IIS iis 6 fastCGI custom PHP 5.3

  • Re: FastCGI does not work with PHP 5.3.0 VC9 ??

    Jun 24, 2010 04:06 PM|beetlejelly|LINK

    Worked!

    thanks.

  • Re: FastCGI does not work with PHP 5.3.0 VC9 ??

    Oct 10, 2010 09:19 PM|jrhyne2584|LINK

    I just wanted to clarify something, if you are using the 32 bit version of PHP, you need to download the x86 version of the Visual C++ 2008 Redistributable Package, even if you are running 64 bit OS.