Too many php-cgi.exe IIS6RSS

5 replies

Last post Dec 21, 2012 08:37 AM by gabriel.froes

  • Too many php-cgi.exe IIS6

    Jul 28, 2009 11:57 AM|jdafonte|LINK

    I have a server that is spinning off hundreds of php-cgi.exe and consuming all the memory. This is crashing the server on a daily basis.

     

    W3k3

    IIS

    PLESK

    PHP5

    php-cgi processes

  • Re: Too many php-cgi.exe IIS6

    Jul 29, 2009 02:50 PM|ruslany|LINK

    Are you using FastCGI 1.0 or 1.5? There was a bug in 1.0 that caused this. Please try upgrading to 1.5 RC: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=227219aa-6aec-4b80-a9fa-76f811ee9e84

  • Re: Too many php-cgi.exe IIS6

    Nov 15, 2011 07:49 AM|PyroJoke|LINK

    Hi, I'm experiencing same issue as jdafonte described. I'm using FastCGI 1.5. So, FastCGI update is not a solution. How I can diagnose root cause of the issue? Regards, Dmitry.
  • Re: Too many php-cgi.exe IIS6

    Nov 15, 2011 08:36 AM|HCamper|LINK

    Hi,

    This is an old thread the FastCGI Release 1.5 with updates should work.

    If your experiencing the same issues as jdafonte described you should

    Install the Debug Diag 1.2 tool  http://www.microsoft.com/download/en/details.aspx?id=26798 

     Using the Debug Diag & Guide http://support.microsoft.com/kb/919791 Microsoft Support

                          create a crash dump file that can be use when you open a case with Microsoft Support

     http://support.microsoft.com/?LN=en-us&x=16&y=12 this will cost for Analysis and Suggestions.

    Sorry the IIS  Forums are setup to help with crash dump analysis.

    You should also contact PLESK Support about the problems and  case information contact with Microsoft Support.

    Martin

     

     

     

     

     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: Too many php-cgi.exe IIS6

    Nov 17, 2011 08:47 AM|PyroJoke|LINK

    Thnx for the reply. I'll try Debug Diag 1.2 and get back with the result.
  • Re: Too many php-cgi.exe IIS6

    Dec 21, 2012 08:37 AM|gabriel.froes|LINK

    Hi Guys! 

    I know this post it's a litle old but I getting this issue using FastCGI 1.5 with IIS6.

    PyroJoke, do you solve your problem?

    Thank you! Gabriel