curl_exec timeout [Answered]RSS

7 replies

Last post Jul 18, 2009 09:19 AM by ShadowDanser

  • curl_exec timeout

    Jul 14, 2009 07:07 PM|ShadowDanser|LINK

    I'm receiving a time out probably while doing an curl_exec job.

    Anyone knows where to extend the time setting?

    Thank you!

  • Re: curl_exec timeout

    Jul 14, 2009 07:58 PM|don.raman|LINK

    IN all probability you are seeing an activity timeout. This can be changed using the UI/Command line. I am providing below links which will help:

    http://forums.iis.net/t/1150670.aspx

    http://forums.iis.net/t/1147730.aspx

    Hope this helps. Please do let us know if this doesn't solve your problem.

    Thanks,

    Don.

  • Re: curl_exec timeout

    Jul 15, 2009 05:03 PM|ShadowDanser|LINK

    Thanks for your reply!

    I have installed Administration Pack for IIS 7.0 and used the settings as mentioned in other forum posts. I have also extended the max request of php to 60 seconds.

    Unfortunately, this did not help. I still receive the same error: Fatal error: Maximum execution time of 60 seconds exceeded. When I set the Fast-cgi execution time lower than the PHP time then I receive an error about Fast-cgi.

    Prr, I see that a lot of people here have problems with this issue. Is there a solution?

  • Re: curl_exec timeout

    Jul 16, 2009 09:01 PM|don.raman|LINK

    The message suggests you need to increase to even higher value. Can you make it something like 300 seconds and try. 300 second is what gets set with the new PHP 5.2.10 installer.

    Thanks,

    Don.

  • Re: curl_exec timeout

    Jul 17, 2009 04:06 AM|ShadowDanser|LINK

    I will remove my PHP installation (installed from zip file), also my PHP settings in IIS, and then make use of the Extension pack. I will keep you updated. Or should I also reinstall IIS?

  • Re: curl_exec timeout

    Jul 17, 2009 07:49 PM|ShadowDanser|LINK

    Tried extenting the request time out, installed all windows updates, removed PHP, installed PHP again... nothing seems to work. :(

  • Re: curl_exec timeout

    Jul 17, 2009 08:00 PM|don.raman|LINK

    What message you are getting now?

    Thanks,

    Don.

  • Re: curl_exec timeout

    Jul 18, 2009 09:19 AM|ShadowDanser|LINK

    HTTP Error 500.0 - Internal Server Error

    C:\PHP\php-cgi.exe - The FastCGI process exceeded configured activity timeout

    AND

    Somehow, don't ask me how, now it works.

    Thanks 4 your supoprt.