Help: Web Platform Installer ProblemRSS

5 replies

Last post Jul 17, 2009 03:33 PM by richma

  • Help: Web Platform Installer Problem

    Jul 04, 2009 11:10 PM|venlily0220|LINK



           I try to install the web platorm in my computer, but when I run the  "Web Platform Installer ", it shows me an error: " InternetOpenUrl failed!".


    I have searched some info. about how to correct this problem in the forum, and I got some experience in a web page in "". I try to follow the step mentioned in the page, but the error still happens. 

    I have attached the error document so you could refer in this post.   

      I hope someone could give me a solution about it

    IISnternetOpenUrl failed Web、PI intaller Problem

  • Re: Help: Web Platform Installer Problem

    Jul 05, 2009 04:28 AM|ma_khan|LINK

     are you as well behind a proxy or a firewall by any chance???

  • Re: Help: Web Platform Installer Problem

    Jul 05, 2009 08:20 AM|venlily0220|LINK

    HI, Thanks for your reply. But The problem comes both when I try it in a network that connect the internet without a proxy and another with a proxy. I don't know why. I have updated the IE from version 6 to 8, but the problem remains. I need someone's help. thanks again. ven
  • Re: Help: Web Platform Installer Problem

    Jul 06, 2009 03:35 PM|ma_khan|LINK

     the screenshot you have given shows ... what's with that ?

  • Re: Help: Web Platform Installer Problem

    Jul 17, 2009 01:02 AM|cepheids|LINK

    Hi, I am also having this problem. Is there a manual download option?


    Using Windows Server 2003, IP is 10.x.x.x

  • Re: Help: Web Platform Installer Problem

    Jul 17, 2009 03:33 PM|richma|LINK

    Hi cephids,

    You can try the following regarding the InternetOpenFailedUrl  error.  If you want to manually download files  you will find link for some installations on the license acceptance screen. If there are there others you wish to download please specify  the program name.


    In the following directory you will find the webpi.txt  log files for each webpi attempt.

    %USERPROFILE%\Local Settings\Application Data\Microsoft\Web Platform Installer\logs\webpi
    Open the most recent file and look for the InternetOpenUrlFailed error.
    Above this error you should find the URL that webpi failed to connect to.  Test this url in IE manually. If this also fails then check the following article  for troubleshooting connectivity with IE.
    If this works in IE but WebPi continues to fail Are you connecting via a Proxy Server ?
    If so you can setup the proxy settings via  config file called "webplatforminstaller.exe.config"  and placing it here :   C:\Program Files\Microsoft\Web Platform Installer\ 

    In the Config you can try either of the following  config settings. 

    <?xml version="1.0" encoding="utf-8" ?>
    <defaultProxy enabled="True" useDefaultCredentials="True"/>     

    <?xml version="1.0" encoding="utf-8" ?>
    autoDetect="False" />   

    Please let us know if this helps.