We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

The AppPoolNotFound dependency check found the AppPool ....RSS

5 replies

Last post Dec 16, 2011 01:31 PM by Mel078

  • The AppPoolNotFound dependency check found the AppPool ....

    Jun 17, 2009 11:01 AM|spyinsky|LINK

    I am using the web deployment tool from my computer to create a new site from an old site on a server (\\server-002)

    C:\Program Files (x86)\IIS\Microsoft Web Deploy>msdeploy -verb:sync -source:meta
    key=lm/w3svc/1378685816,computername=\\server-002 -dest:metakey=lm/w3svc/2397814
    18,computername=\\server-002 -whatif > msdeploysync.log


    Error:  The AppPoolNotFound dependency check found the AppPool '7-8' to be in us
    e by the source data but not defined in source data or on the destination machin
    e.  Applications referencing this app pool will have configuration issues.

    Error:  [Error]The AppPoolNotFound dependency check found the AppPool '7-8' to b
    e in use by the source data but not defined in source data or on the destination
     machine.  Applications referencing this app pool will have configuration issues
    .
    Error count: 2

  • Re: The AppPoolNotFound dependency check found the AppPool ....

    Jun 17, 2009 11:09 AM|spyinsky|LINK

     Also, should I need to install the web deployment tool on the remote machine & start the Microsoft Web Deployment Service before I initiate the copy?

    -----------------------------------------------------------------------------------------------------------------------------

    I have also done a dependency check for appPool that I want to copy, here are the dependencies on it.

     C:\Program Files (x86)\IIS\Microsoft Web Deploy>msdeploy -verb:getDependencies -
    source:metakey=lm/w3svc/1378685816,computername=\\server-002
    <dependencyInfo>
      <dependencies>
        <dependency name="AnonymousAuthentication" />
        <dependency name="WindowsAuthentication" />
      </dependencies>
      <apppoolsInUse>
        <apppoolInUse name="7-8" definitionIncluded="False" />
      </apppoolsInUse>
      <isapis>
        <isapi dll="C:\WINDOWS\system32\inetsrv\httpodbc.dll" enabled="False" />
      </isapis>
    </dependencyInfo>

     

  • Re: The AppPoolNotFound dependency check found the AppPool ....

    Jun 17, 2009 11:35 AM|spyinsky|LINK

     Found the problem, The AppFriendlyName for that website was saying "Default Application", it needs to be the same name as the appPool Name it works.

    thanks guys, hope this solution helps for others using the tool.

    Sundeep.

  • Re: The AppPoolNotFound dependency check found the AppPool ....

    Jun 17, 2009 12:39 PM|kateroh|LINK

    You can also try to enable the appPool extension on your sync:

    -enableLink:AppPoolExtension

  • Re: The AppPoolNotFound dependency check found the AppPool ....

    Jun 17, 2009 03:30 PM|spyinsky|LINK

     do we have to install MSDEPLOY on the remote server to use it as a Source/Destination.

     

    Following is the detailed error I receive :


    Error:  The AppPoolNotFound dependency check found the AppPool '7-8' to be in us
    e by the source data but not defined in source data or on the destination machin
    e.  Applications referencing this app pool will have configuration issues.
    Microsoft.Web.Deployment.DependencyCheckBlockException: [Error]The AppPoolNotFou
    nd dependency check found the AppPool '7-8' to be in use by the source data but
    not defined in source data or on the destination machine.  Applications referenc
    ing this app pool will have configuration issues.
       at Microsoft.Web.Deployment.DependencyRuleHandler.PreSync(DeploymentSyncConte
    xt context)
       at Microsoft.Web.Deployment.DeploymentSyncContext.ProcessSync(DeploymentObjec
    t destinationObject, DeploymentObject sourceObject)
       at Microsoft.Web.Deployment.DeploymentObject.SyncToInternal(DeploymentObject
    destObject, DeploymentSyncOptions syncOptions, PayloadTable payloadTable, Conten
    tRootTable contentRootTable)
       at Microsoft.Web.Deployment.DeploymentObject.SyncTo(DeploymentProviderOptions
     providerOptions, DeploymentBaseOptions baseOptions, DeploymentSyncOptions syncO
    ptions)
       at MSDeploy.MSDeploy.Execute()
       at MSDeploy.MSDeploy.Main(String[] unusedArgs)
    Error count: 2

     

    when i run:

    ---------------------

    C:\Program Files\IIS\Microsoft Web Deploy>msdeploy -verb:sync -source:manifest=7
    -8.xml,computername=\\server-002 -dest:manifest=7-10.xml,computername=\\webdev-0
    02 -whatif -enableLink:AppPoolExtension -debug -enableLink:ContentExtension > ms
    deploysync.log

     

    Does Server-002 require a MSDEPLOY install?
  • Re: The AppPoolNotFound dependency check found the AppPool ....

    Dec 16, 2011 01:31 PM|Mel078|LINK

    Thanks Kateroh,

    Works Great