Permission problems on Wordpress Uploads on IIS 7RSS

10 replies

Last post Apr 18, 2013 06:26 AM by Vimana

  • Permission problems on Wordpress Uploads on IIS 7

    Jun 17, 2009 02:25 AM|nobrainr|LINK

    I'm a noob on IIS. But I've been looking everywhere for a solution but nothing works. The following mentions 2 problems. I think I've already fixed the first one but the second one is the key issue.

    I have Server 2008 x64 Virtual Machine / IIS 7 / Wordpress 2.8 / MySQL NTS / PHP

    Everything works fine except media uploads. When I click upload using internet explorer, the blogging platform alerts me that I have a problem:

    <div id=media-upload-error>Unable to create directory C:\inetpub\wwwroot\blog/wp-content/uploads/2009/06. Is its parent directory writable by the server?</div> <div> </div> <div>To fix this problem, I allowed NETWORK SERVICE to have access to the uploads folder and I'm able to get as far as writing the folders and the file (*upload path*/2009/06/test.jpg)</div> <div> </div> <div>When I look at the permissions on test.jpg, IIS_IUSRS does not have read access. I can simply change that manually and see the picture on the site.</div> <div> </div> <div>But how can I get NETWORK SERVICE to write test.jpg with IIS_IUSRS permissions set automatically to read? I thought if my uploads folder had IIS_IUSRS permissions set, it would propagate the necessary credentials to the nested folders.</div> <div> </div> <div>Thanks in advance.</div>

    permissions IIS 7 WordPress PHP IIS_IUSRS Unable to create directory is its parent directory writable by the server? Windows Server 2008 NETWORK SERVICE

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Jun 17, 2009 07:24 AM|Paul Lynch|LINK

    Hi,

    Are you allowing the NTFS permissions on the root folder to propagate to sub-folders ?

    Regards,

    Paul Lynch
    MCSE
  • Re: Permission problems on Wordpress Uploads on IIS 7

    Jun 18, 2009 02:20 PM|Shanceaylown|LINK

    Thanks for very fast reply!
  • Re: Permission problems on Wordpress Uploads on IIS 7

    Aug 30, 2009 05:05 PM|stephen.mora|LINK

    OK I have the same prolem and scenrio as you only mine is a physical server with 2008 standard, in any case I have the latest wordpress and using php etc.. I cant seem to write to the uploads folder.  I tried allowing NETWORK SERVICE access to the uploads folder but nothing.  What were the exact permission that yuo gave that account access?  was it just on uploads of the whole wp-content folder?  everything else works flawlessly.  Thank you in afvance. 

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Aug 30, 2009 09:16 PM|nobrainr|LINK

    Hate to say this on an IIS site but I scrapped that whole thing, added the Hyper-V role, installed Ubuntu Server as a virtual machine, turned on LAMP, configured Apache, configured MySQL, then installed Wordpress on that. Had no problems after that. CHMOD seems a lot more straightforward than NTFS permissions IMO.
  • Re: Permission problems on Wordpress Uploads on IIS 7

    Aug 31, 2009 01:26 AM|stephen.mora|LINK

    I hear ya, and thanks for the quick reply. None the less I am not very abitious regrading this project, to make a change,  Its a side thing on this server, you know an if I can thing and learning experince.  I do apprciate the imput, but I think I  will hold out  until I find a solution or bust heheheh. I do agree in regards to PHP and Wordpress it was more developed to cater to the linux community, NTFS is a different animal, I just need to find the right formula.. we will see, thanks again.. : )

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Sep 02, 2009 11:54 PM|kjcristiano|LINK

    On IIS 7 grant the permissions you want on the directory to the IIS_IUSRS group. For Wordpress give the group write permission to the directory. I run many wp sites on IIS and this has not been an issue for me. good luck.
  • Re: Permission problems on Wordpress Uploads on IIS 7

    Sep 03, 2009 02:30 PM|ruslany|LINK

    Also check if fastcgi.impersonate is set 1 in php.ini and what account is used for IIS anonymous authentication. It may happen that the IIS anonymous authentication is configured to use IUSR account and if PHP impersonates that user it will not have write permissions. You can either grant write permissions to that user or configure the anonymous authentication to use application pool identity, e.g.:

    <authentication>
         <anonymousAuthentication enabled="true" userName="" />
    </authentication>

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Sep 03, 2009 09:15 PM|stephen.mora|LINK

    thank you for the responces.. I will look into them.. I had found quick fix, but am checking the security around it, basically one said to just give the everyone group write access and it will work the IIS_IUSERS remain read and execute only..

    but this sounds logical, I will rethink my setup.. thanks..

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Jul 15, 2011 04:17 AM|dotmit|LINK

    This problem was racking my brains most of this week. Have a look at the permissions on the php temporary uploads directory - you should be able to find the location of this in the PHP admin component, or in php.ini

     I moved the location of the temporary upload folder to a subfolder within uploads, and granted the IUSR account write permission and that resolved the problem. We are using an IIS7 authentication plugin for wordpress so I also gave our upload user group permission to write too.

  • Re: Permission problems on Wordpress Uploads on IIS 7

    Apr 18, 2013 06:26 AM|Vimana|LINK

    RE: stephen.mora reply

    Yes this is definitely the correct way of solving this issue :) 

    I had the same problem and it was solved by correcting the persmission issues with the IIS_IUSRS for the wordpress install or any other file or directory issues on the IIS sites.

    Thanks to this forum I was able to get our wordpress issues resolved.