We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

IIS on Windows 2003 R2 x64 [Answered]RSS

7 replies

Last post Jun 03, 2009 06:50 AM by Hlongwane

  • IIS on Windows 2003 R2 x64

    Jun 02, 2009 07:42 AM|Hlongwane|LINK

    Hi.

    I have a server with Windows Server 2003 R2 Enterprise x64.

    I added IIS components (including the World Wide Web Service).

    But then when I start the default application, It does not start.

    the w3svc is also not installed. All in all, my ISS is not correctly or fully installed.

    What could I be doing wrong?

     

    Wonder

  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 09:39 AM|Hlongwane|LINK

    if I Register ASP.NET isapi using aspnet_regiis.exe -i on C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727

    I get the following at the bottom of my Log File :

    2009-06-02 15:32:13  Starting Opening handle to W3SVC
    2009-06-02 15:32:13  Failure  Opening handle to W3SVC: OpenService failed with HRESULT 80070424: 'The specified service does not exist as an installed service.  '
    2009-06-02 15:32:13 Failure  Restarting W3SVC: RestartW3svc failed with HRESULT 80070424: 'The specified service does not exist as an installed service.  '

  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 11:01 AM|Paul Lynch|LINK

    Hi,

    It sounds like your installation failed. Have you tried uninstalling and the re-installing IIS ?

    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/910e7485-d74c-4647-87a5-f9d0f9aae51e.mspx?mfr=true

    Regards,

    Paul Lynch
    MCSE
  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 11:27 AM|Hlongwane|LINK

    I have tried that a couple of times.

    I am also suspecting the OS's service pack is the problem.

    We are downloading SP 2.

  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 12:51 PM|ggandy|LINK

     Hey Im running XP Pro x64 SP1 and I am having the exact same issues.  I can't get anywhere with this problem and was wondering if you happened to get past this problem.

  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 03:25 PM|murtaza_t|LINK

     I would also recoomend you guys to check:

    http://www.microsoft.com/windowsxp/using/64bit/russel_x64faq.mspx

    It covers all most every thing on IIS with 64 Bits.

    Please Mark the post as Answer if it has helped you.
    Regards,
    Murtaza
  • Re: IIS on Windows 2003 R2 x64

    Jun 02, 2009 08:41 PM|lextm|LINK

    Please read through this thread,

    http://forums.iis.net/t/1155970.aspx?PageIndex=2

    If you rather rebuild the system, it is OK. If you don't like this, you can follow my suggestions.

    Lex Li
    Want to have a chat on the issues you meet? Book an appointment at https://buy.stripe.com/cN24ia0yi7sAdIA7sv
    ---------------------------
    This posting is provided "AS IS" with no warranties, and confers no rights.
  • Re: IIS on Windows 2003 R2 x64

    Jun 03, 2009 06:50 AM|Hlongwane|LINK

    We tried Lextm's solution of using the Process monitor.

    Found out that the administrators only had read access to the Registry.

    We have our IIS running.

    Thanks to Lextm.