Rewrite module doesn't show up in IIS ManagerRSS

6 replies

Last post Apr 24, 2009 11:41 AM by ma_khan

  • Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 07:04 AM|helri|LINK

    Hi,

    I'm having an strange behavior in IIS manager. When I install URL Rewrite version 7.1.0314.0 RTW in IIS 7.0, when I go to IIS Manager i can't view the URL Rewrite module in the features view (no matter the grouping and i tried reseting IIS and access to IIS manager with other accounts, including all administrators accounts in the machine), but the module is installed, i can view it when listing the modules through appcmd and i can use it and configure rules via appcmd but i can't do it in IIS Manager GUI.

    I've had some case when uninstalling and reinstalling the URL Rewrite would make it show up in IIS manager.

    Anyone knows why this happens and how can I be sure the module appears on IIS Manager?

    We're automating installations of IIS and some modules, including URL Rewrite and we need to be sure the modules are correctly installed and configured and also be sure they can be easily used through IIS manager. It's not feasible for us to have to uninstall and install the module again and hope it appears on IIS manager...

    Thank you

     Helri

     

  • Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 07:19 AM|ma_khan|LINK

    Do you have any error related to IIS Manager/URL rewrite module in the event viewer??

  • Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 09:45 AM|helri|LINK

    Hi, thank you for the reply,

    i haven't seen any error related to IIS in event viewer.

  • Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 10:42 AM|ma_khan|LINK

    helri

    I've had some case when uninstalling and reinstalling the URL Rewrite would make it show up in IIS manager.

    What do you mean by that?

    Also, what is the modules section in your administration.config?

  • Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 11:21 AM|helri|LINK

    This problem doesn't happen everytime we install URL Rewrite, it has happened only on some machines, which makes it difficult to trace teh issue. We're using Windows Server 2008 as OS and the machines don't have any significant changes between them either in OS, software or hardware.

    When this happens we usually go to Programs and Features and uninstall URL Rewrite and then install it again and it then shows up in IIS Manager.

    What we've been trying to do is to find a solution that will alow us to always see the module in IIS manager or a workaround different then uninstalling and installing again. As I said before, for us the installation of IIS and its modules is an automated process and we do not want to add any manual workarounds to it.

    We've been also having the same issue with the latest version of WebFarms.

    Does the order in which we install IIS modules have any impact on viewing the modules in IIS Manager?

    Currently i don't possess any administration.config of the machines.

    Thank you. 

     

     

  • Rovastar Rovastar

    5474 Posts

    MVP

    Moderator

    Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 11:36 AM|Rovastar|LINK

     I am curious *if* you install it again and again does it appear?

    Troubleshoot IIS in style
    https://www.leansentry.com/
  • Re: Rewrite module doesn't show up in IIS Manager

    Apr 24, 2009 11:41 AM|ma_khan|LINK

    When the module does not appear in the UI...I think you should note the Modules and ModuleProviders section of the administration.config... so that you can see if an entry for Rewrite module is made in the file...If not, then I think you should have something in the event viewer... (I know you checked, just checking again :) )