Problem with caching?RSS

5 replies

Last post Apr 21, 2009 12:44 AM by ruslany

  • Problem with caching?

    Apr 01, 2009 09:24 AM|lonevvolf|LINK

    I have found what appears to be a major problem in the URL rewriter.  Hopefully there's a workaround.

    I have a rule, which adds the customer's language to the URL path.  The language is read out from the HTTP_COOKIE field.  It appears that the URL rewriter is using some kind of output caching on the HTTP_COOKIE field, though, since when clicking on a link on the page, the language is added, but the language seems to come from a completely different cookie than is being sent in the request.

    This problem only appears in final release of the rewriter (DLL version 7.1.315.0), while version 7.1.252.0 (I believe this was the Go Live release) is working correctly.  Naturally, I would like to move to the newest version, if there is a way around this problem.  Please let me know if you have any ideas, or need more feedback to hunt this down.

  • Re: Problem with caching?

    Apr 01, 2009 02:09 PM|ruslany|LINK

    Would it be possible for you to repro this with the Failed Request Tracing turned on and send me the trace log file at ruslany at microsoft dot com? Thanks for reporting this!

  • Re: Problem with caching?

    Apr 02, 2009 03:45 AM|lonevvolf|LINK

    ruslany

    Would it be possible for you to repro this with the Failed Request Tracing turned on and send me the trace log file at ruslany at microsoft dot com? Thanks for reporting this!

    EDIT: Please ignore what I wrote below.  Something is getting completely messed up, and I don't want to jump the gun before I find out what's up.  I'll look into this a bit more on my side, and get back to you.

    Ok...now this problem is getting to be very strange.  I wanted to go and get a trace for you, so I installed the feature, which I hadn't installed on my machine yet.  As soon as I installed the feature, my problem disappeared!  Please note, that I didn't even have to have it enabled in IIS.  I have confirmed this on three other development machines.  Those people who happen to have the feature installed, don't have the caching problem.  Those people who don't have it, have a problem.  Is the Rewrite module performing some other logic, when FREB is simply installed on the IIS Server as a feature??

  • Re: Problem with caching?

    Apr 02, 2009 10:20 AM|lonevvolf|LINK

    ruslany

    Would it be possible for you to repro this with the Failed Request Tracing turned on and send me the trace log file at ruslany at microsoft dot com? Thanks for reporting this!

    I've just sent off an email with the FREB log for the failing request, as well as the applicable rules which we are using.  Please let me know if you find anything of interest.

  • Re: Problem with caching?

    Apr 16, 2009 10:03 AM|lonevvolf|LINK

    Just to update this issue: ruslany has confirmed that this is a problem in the module itself.  The current workaround is to disable the internal caching of the module, with the following command:

    reg add HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\InetStp\Rewrite /v RewriteCacheEnabled /t REG_DWORD /d 0
  • Re: Problem with caching?

    Apr 21, 2009 12:44 AM|ruslany|LINK

    The URL Rewrite 1.1 release has a fix for this bug. It is highly recommended to upgrade to that release. 

    Here is more informaiton about this release http://ruslany.net/2009/04/url-rewrite-module-11-for-iis-7/