http error 500.19 while migrating joomla website [Answered]RSS

3 replies

Last post Mar 30, 2009 06:34 AM by Leo Tang - MSFT

  • http error 500.19 while migrating joomla website

    Mar 25, 2009 08:55 AM|necropal_co|LINK

    sir, i made a website in joomla and im ready to publish it. i used windows 2008 server and its iis7. i installed php and mysql. they are working perfectly. however, when i integrate them with fastcgi... and checked my website thru "localhost/name of my website", i got this http error 500.19. it states the following:

     module: iis web core

    notification: begin request

    handler: net yet determined

    error code: 0x8007000d

    config error: the configuration section 'rewrite' cannot be read because it is missing a section declaration

    config file: \\?\c:\inetpub\wwwroot\950th ceisg\web.config

    requested url: http://localhost:80/950th ceisg

    physical path: c:\inetpub\wwwroot\950th ceisg

    logon method: not yet determined

    logon user: not yet determined

     

     

    500.19 error joomla

  • Re: http error 500.19 while migrating joomla website

    Mar 25, 2009 11:38 AM|ksingla|LINK

    Hi,

    500.19 is the error you get when IIS sees invalid configuration. In your case IIS is complaining that configuration in c:\inetpub\wwwroot\950th ceisg\web.config is not valid. Error message tells that your web.config has rewrite rules but configuration system doesn't recognize the section. If you install IIS urlrewrite module from www.iis.net/extensions, this error should go away.

    Thanks,
    Kanwal

  • Re: http error 500.19 while migrating joomla website

    Mar 25, 2009 11:09 PM|necropal_co|LINK

    sir, thanks for the info... the error 500.19 was removed.

    however, i got this http error 403.14 now after executing what you said.

    it contains the following:

    module: directorylisitingmodule

    notification: executerequesthandler

    handler:staticfile

    error code: 0x00000000

    requested url: http://localhost:80/950th ceisg

    physical path: c:\inetpub\wwwroot\950th ceisg

    logon method: anonymous

    logon user: anonymouse

    most likely causes: a default document is not configured for the requested url, and directory browsing is not enabled on the server.

    things to do:

    1. if you do not want to enable directory browsing, ensure that a default document is configured and that the filew exists.

    2.enable directory browsing using iis manager.

        open iis manager. in the features view, double-click directory browsing. on the directory browsing page, in the actions pane, click enable.

     

    3. verify that the configuration/system.webserver/directorybrowse@enabled attribute is set to true in the site or application configuration file.

     

     I CHECKED THIS SITE... http://learn.iis.net/page.aspx/527/joomla-on-iis/

    but i do not know how to do this part...

    Grant write permissions on configuration file

    Joomla uses configuration file called configuration.php in order to store key configuration settings. Before running the installer you need to create this file to  give the web server write privileges to the new file. Joomla's installer will modify the configuration.php file as needed with the details you provide during the installation process.

    After creating the new file you can assign write permissions to it with the command (from the installation directory):

    C:\inetpub\wwwroot\Joomla>icacls configuration.php /grant BUILTIN\IIS_IUSRS:(M)

    Grant write permissions to tmp folder

    Joomla uses the tmp folder to store temporary files. Because of that it needs to be able to write and modify files in this folder. To enable that, grant modify permissions to this folder:

    C:\inetpub\wwwroot\Joomla>icacls tmp /grant BUILTIN\IIS_IUSRS:(OI)(CI)(M)

  • Re: http error 500.19 while migrating joomla website

    Mar 30, 2009 06:34 AM|Leo Tang - MSFT|LINK

    Hi,

    I assume you do not want to enable directory browsing. To resolve the error 403.14 issue, you can try the following steps:
    1.Open IIS Manager, click "950th ceisg" in the tree view
    2.Click Default Document icon in the Home page
    3.Click Add… on the Actions panel,
    4.Type the file's name you want to set as default document, click OK

    The configuration.php file does not exists. Hence, we need to create an empty file in the root installation directory first to grant the write permissions. 

    To grant write permissions on the configuration file and to the tmp folder , you should open a command prompt and change to the installation directory. Then, run the two icacls commands above.

    Please mark the replies as answers if they help or unmark if not.
    Feedback to us