Random 500.50 "URL Rewrite Module Error." after an IIS (re)start [Answered]RSS

2 replies

Last post Apr 26, 2009 05:07 PM by alex-N

  • Random 500.50 "URL Rewrite Module Error." after an IIS (re)start

    Mar 23, 2009 07:04 PM|alex-N|LINK

    Hi,

    We use the URL rewrite module in a webfarm and randomly after an update, we get 500.50 errors on static or dynamic files. It doesn't happen consistently on all servers of the farm at the same time and the issue is solved after a few (or a lot) of IISResets.

    The application pool runs in integrated mode and we have quite a large web.config file (~110 ko) with ~160 rewrite rules added at the end of the file. The web.config has encrypted sections but none of those are in <system.webServer>.

    I cannot reproduce the issue but have around 1 chance of 2 to get this error after an IIS start or restart. The problem doesn't occur once IIS started without this error.

    Below is an extract of the failed request log. Thanks for your help!


    <div class="duration"> </div> <div class="severity-warning">Warning</div>51. -MODULE_SET_RESPONSE_ERROR_STATUS  <div class="hidden" id="section_detail_51_details" style="display: block;">
    ModuleName RewriteModule
    Notification 1
    HttpStatus 500
    HttpReason URL Rewrite Module Error.
    HttpSubStatus 50
    ErrorCode 2147942487
    ConfigExceptionInfo
    Notification BEGIN_REQUEST
    ErrorCode The parameter is incorrect. (0x80070057)
    </div>
    <div class="duration"> </div> <div class="severity-warning">Warning</div>52. -SET_RESPONSE_ERROR_DESCRIPTION  <div class="hidden" id="section_detail_52_details" style="display: block;">
    ErrorDescription The action's expression "{R:1}/Security/Login.aspx" is invalid.
    </div>
  • Re: Random 500.50 "URL Rewrite Module Error." after an IIS (re)start

    Mar 23, 2009 07:35 PM|DanielVL|LINK

    Alex,

    This could be a bug in rewrite; perhaps a raise condition, Could please send me you web.config file to my email? my email is my IIS alias + Microsoft dot com.

    Thanks.

    Daniel Vasquez Lopez
    IIS Team
  • Re: Random 500.50 "URL Rewrite Module Error." after an IIS (re)start

    Apr 26, 2009 05:07 PM|alex-N|LINK

    Hi Daniel,

    I installed version 1.1 of the URL Rewrite module as suggested per PM and that solved the issue.

    Thanks for your help!

    Alex