We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Error: Try disable the Application Pool CPU Limit featureRSS

1 reply

Last post Mar 17, 2009 09:45 PM by jtalbot

  • Error: Try disable the Application Pool CPU Limit feature

    Mar 16, 2009 08:26 PM|jtalbot|LINK

    I'm trying to setup a website running joomla on IIS7. The hosting company just enabled FastCGI so that I can get joomla's SEO settings to work, but as soon as I tried running a php test script with FastCGI I got the following error:

    Unable to place a FastCGI process in a JobObject. Try disable the Application Pool CPU Limit feature

    I've seen this post: http://forums.iis.net/p/1146572/1857584.aspx but I don't see how this helps. It seems reasonable for the hosting company to want to use a CPU limit on my site, including putting a CPU limit on my php scripts. But the post says that CPU limit and FastCGI are mutually exclusive, and that "you can continue to limit the cpu for non-FastCGI applications". So what should I tell them to change so that I have my FastCGI and they can be sure that my site doesn't use up unreasonable CPU resources?

    Thanks

    Jimmy

    PHP FastCGI IIS7

  • Re: Error: Try disable the Application Pool CPU Limit feature

    Mar 17, 2009 09:45 PM|jtalbot|LINK

    Well, the hosting company seems to have figured it out... so it's all working now.

    I still would like to know the answer to my question though.