php write permission - COMPUTER\USERS ? RSS

7 replies

Last post Nov 13, 2009 02:17 AM by weedle

  • php write permission - COMPUTER\USERS ?

    Dec 27, 2008 11:43 AM|RustySpoon|LINK

    Php (FastCGI) can't write files in a directory with the IUSR_COMPUTER full control permission, but with COMPUTER\USERS group full control permission everything works perfect. Why? :(
  • Re: php write permission - COMPUTER\USERS ?

    Dec 27, 2008 02:40 PM|thomad|LINK

    For security reasons the IUSR account as well as all members of the Users group have only read permissions. You can grant permissions by using the Security tab when opening the Properties dialog for the directory or you can use the ICACLS tool. Example:

    ICACLS <directory> /grant IUSR:F /grant IUSR:(OI)(IO)(CI)F

    Hope this helps.

     

    Thomas Deml
    Group Program Manager
    Internet Information Services
    Microsoft Corp.
  • Re: php write permission - COMPUTER\USERS ?

    Dec 28, 2008 06:11 AM|RustySpoon|LINK

    I granted all right (write, modify, full control, etc..) for the IUSR :( Can't write php.. The wriring to file method works only if Im granting for the Computer\Users group the writing, modify rights. I dont understand why..
  • Re: php write permission - COMPUTER\USERS ?

    Dec 28, 2008 11:59 AM|thomad|LINK

    Are you using any kind of authentication. Giving IUSR access only gives permission to the anonymous user, i.e. the user IIS uses when anonymous authentication is enabled. If you use authentication (Windows, Digest, Basic auth) the authenticated user is impersonated and its identity is used to write the file.

    Hope this helps

     

    Thomas Deml
    Group Program Manager
    Internet Information Services
    Microsoft Corp.
  • Re: php write permission - COMPUTER\USERS ?

    Dec 29, 2008 12:37 PM|RustySpoon|LINK

     I didnt authenticated the user. I think the writing request processed by the Anonymous user..

  • Re: php write permission - COMPUTER\USERS ?

    Jan 01, 2009 08:45 PM|Andrew Zhu - MSFT|LINK

    thomad

    If you use authentication (Windows, Digest, Basic auth) the authenticated user is impersonated and its identity is used to write the file.
     

    Another you can try: switch your php app pool's identity from "NetworkService" to "LocalSystem".

    Thanks

     

    Andrew Zhu
    Microsoft online ASP.NET support
    Please remember to click “Mark as Answer” on the post that helps you. This can be beneficial to other community members reading the thread.
  • Re: php write permission - COMPUTER\USERS ?

    Jan 07, 2009 05:15 AM|RustySpoon|LINK

     Nothing changes.. :(

  • Re: php write permission - COMPUTER\USERS ?

    Nov 13, 2009 02:17 AM|weedle|LINK

    Hi not being to bright with computers. I can install stuff no problem until it comes up with an error, user permission needed what r they talking about.  It's just me on the puter, I'm going to install a t 1.5 hard drive. I tried to install fsx and it came up with can't write cache file and this write permission thing, I'm 67 and don't need this grief i just want to play my games. I have sleep apnea and only sleep 2 hours aday I want to play my games I hope you can help. Thank you in advance, if you could send answer to my e-mail because I'll never find my way back here, I'm running vista premreir which I don't like can I go back to xp on my new hard drive. I'm sorry this was so long but I need help. Thanks again     ELP    ctvalley1@yahoo.com