Webdav - File names with + symbol not working correctly when copied to webdav mapped network drive [Answered]RSS

6 replies

Last post Jan 08, 2009 01:17 PM by JaroDunajsky

  • Webdav - File names with + symbol not working correctly when copied to webdav mapped network driv...

    Oct 09, 2008 10:01 AM|KeithHutch|LINK

    OK I'm having a weird problem that I would like to know if anyone else is experiencing.

    Windows 2008 server (RTM any version)

    IIS 7.0 with Webdav module and QFE hotfix with request filtering disabled or not installed.

    Try and copy a file with a file name containing a + symbol from another computer with a mapped network drive to the webdav share 'http://www.mytestsite.com/test'.  Like this:

    'This is a + test.txt'

     What I am seeing is that the file will be created but the + symbol will disappear. When saved to the webdav share the file will appear as:

    'This is a   test.txt'

    It seems webdav is not processing files with a + in the filename even though this is a totally valid file name in the win32 file system.

     Can anyone else confirm this?  I'm at a loss as to how we can go about fixing this problem.

    Cheers,

    Keith

  • eokim eokim

    171 Posts

    Microsoft

    Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Oct 10, 2008 11:01 AM|eokim|LINK

    It seems like '+' is not allowed in url.

    Please, refer to

    http://blogs.iis.net/thomad/archive/2007/12/17/iis7-rejecting-urls-containing.aspx

    Thanks.
  • Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Oct 10, 2008 04:02 PM|KeithHutch|LINK

     I have already tried setting allowDoubleEscaping="true" and while it allows a file to be served (GET) when you do a webdav PUT the file 'This is a + test.txt' becomes 'This is a  test.txt'

     It seems like there is some kind of bug in the webdav module that does not properly URL encode/decode a file with a + symbol.

    'This is a + test.txt' should become:

    'This+is+a+%2B+test%2Etxt'

    However when the webdav module receives the PUT command it does not properly URL decode and instead becomes:

    'This is a  test.txt'

    I view this as a pretty serious bug because files with +'s in them are totally valid in the win32 file system.  Due to the nature of the files and customers I'm working with it is not possible for me to rename these files.

    Anyone from the IIS team want to comment?

  • Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Nov 04, 2008 05:39 PM|KeithHutch|LINK

    Still experiencing this issue...  Can anyone else confirm the same issue? Anilr? IIS team?

  • Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Nov 07, 2008 02:24 PM|vijaysen|LINK

    Keith,

    This is a bug and we are looking into this.

  • Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Nov 17, 2008 04:01 PM|KeithHutch|LINK

    vijaysen

    Keith,

    This is a bug and we are looking into this.

    Any updates on this bug status or work-a-rounds I can implement in the meantime?

    Cheers,

    Keith

  • Re: Webdav - File names with + symbol not working correctly when copied to webdav mapped network...

    Jan 08, 2009 01:17 PM|JaroDunajsky|LINK

    The issue was fixed in the following WebDAV update http://support.microsoft.com/kb/957001

    Jaroslav Dunajsky (MSFT, IIS)