URL Rewrite doesn't seem to be enabledRSS

4 replies

Last post Sep 16, 2008 02:55 PM by msjonker

  • URL Rewrite doesn't seem to be enabled

    Sep 16, 2008 09:11 AM|msjonker|LINK

    Hi,

    I downloaded and installed URL Rewriter for x64. The icon shows up in both the main server screen and for each web site. However, the rules I create never seem to be evaluated. I tried doing a failed request trace, but "Rewrite" is not even an option for WWW Server, as shown in the tutorial. This leads me to believe that URL Rewrite is not installed correctly or enabled? Not sure what could have gone wrong.

     Any help would be much appreciated. Thanks!

  • Re: URL Rewrite doesn't seem to be enabled

    Sep 16, 2008 11:51 AM|DanielVL|LINK

    Hi,

    What is the output for the following command?

     %SystemRoot%\system32\inetsrv\appcmd list config -section:globalModules

    Thanks.

    Daniel.

    Daniel Vasquez Lopez
    IIS Team
  • Re: URL Rewrite doesn't seem to be enabled

    Sep 16, 2008 12:15 PM|msjonker|LINK

    Hi Daniel,

    Thank you for your help. The output is:

    <system.webServer>
      <globalModules>
        <add name="UriCacheModule" image="%windir%\System32\inetsrv\cachuri.dll" />
        <add name="FileCacheModule" image="%windir%\System32\inetsrv\cachfile.dll" />
        <add name="TokenCacheModule" image="%windir%\System32\inetsrv\cachtokn.dll" />
        <add name="HttpCacheModule" image="%windir%\System32\inetsrv\cachhttp.dll" />
        <add name="DynamicCompressionModule" image="%windir%\System32\inetsrv\compdyn.dll" />
        <add name="StaticCompressionModule" image="%windir%\System32\inetsrv\compstat.dll" />
        <add name="DefaultDocumentModule" image="%windir%\System32\inetsrv\defdoc.dll" />
        <add name="DirectoryListingModule" image="%windir%\System32\inetsrv\dirlist.dll" />
        <add name="ProtocolSupportModule" image="%windir%\System32\inetsrv\protsup.dll" />
        <add name="HttpRedirectionModule" image="%windir%\System32\inetsrv\redirect.dll" />
        <add name="ServerSideIncludeModule" image="%windir%\System32\inetsrv\iis_ssi.dll" />
        <add name="StaticFileModule" image="%windir%\System32\inetsrv\static.dll" />
        <add name="AnonymousAuthenticationModule" image="%windir%\System32\inetsrv\authanon.dll" />
        <add name="RequestFilteringModule" image="%windir%\System32\inetsrv\modrqflt.dll" />
        <add name="CustomErrorModule" image="%windir%\System32\inetsrv\custerr.dll" />
        <add name="HttpLoggingModule" image="%windir%\System32\inetsrv\loghttp.dll" />
        <add name="RequestMonitorModule" image="%windir%\System32\inetsrv\iisreqs.dll" />
        <add name="IsapiModule" image="%windir%\System32\inetsrv\isapi.dll" />
        <add name="IsapiFilterModule" image="%windir%\System32\inetsrv\filter.dll" />
        <add name="CgiModule" image="%windir%\System32\inetsrv\cgi.dll" />
        <add name="FastCgiModule" image="%windir%\System32\inetsrv\iisfcgi.dll" />
        <add name="ManagedEngine" image="%windir%\Microsoft.NET\Framework\v2.0.50727\webengine.dll" preCondition="integratedMode,runtimeVersionv2.0,bitnes
    s32" />
        <add name="ConfigurationValidationModule" image="%windir%\System32\inetsrv\validcfg.dll" />
        <add name="ManagedEngine64" image="%windir%\Microsoft.NET\Framework64\v2.0.50727\webengine.dll" preCondition="integratedMode,runtimeVersionv2.0,bi
    tness64" />
        <add name="RewriteModule" image="%SystemRoot%\system32\inetsrv\rewrite.dll" />
        <add name="ApplicationRequestRouting" image="%ProgramFiles%\IIS\Application Request Routing\requestRouter.dll" />
        <add name="CustomLoggingModule" image="%windir%\System32\inetsrv\logcust.dll" />
        <add name="TracingModule" image="%windir%\System32\inetsrv\iisetw.dll" />
        <add name="FailedRequestsTracingModule" image="%windir%\System32\inetsrv\iisfreb.dll" />
      </globalModules>
    </system.webServer>

  • Re: URL Rewrite doesn't seem to be enabled

    Sep 16, 2008 02:20 PM|DanielVL|LINK

    As you can see in the global module list, FailedRequestsTracingModule is after RewriteModule, that means that you installed the Tracing role service / feature after installing URL Rewrite Module. Please run the Rewrite Setup again in Repair mode in order to add the Rewrite tracing area under the WWW Server provider.

    Thanks.

    Daniel Vasquez Lopez
    IIS Team
  • Re: URL Rewrite doesn't seem to be enabled

    Sep 16, 2008 02:55 PM|msjonker|LINK

    Thank you very much for your help! I did not know installation order made a difference.