Error 500 - Internal Server Error [Answered]RSS

3 replies

Last post Sep 11, 2008 10:25 PM by ksingla

  • Error 500 - Internal Server Error

    Sep 10, 2008 10:24 PM|FaTe709|LINK

    Hey,

    I know this has been posted alot but I have yet to find a post to help me out. I am currently running Windows Server 2008 x64 with IIS 7 and FastCGI with PHP 5.2.6 Non-thread-safe. I did the phpinfo.php test and that worked fine but now my website scripts do not seem to work. Here is a screenshot of the error...

    http://img183.imageshack.us/img183/5466/errorxm9.jpg

    If someone could help me out that would be great.

    Thanks

    -Mike

     

  • Re: Error 500 - Internal Server Error

    Sep 11, 2008 11:08 AM|ksingla|LINK

    Hi Mike,

    Are you able to execute your php page on command line using <phpinstallpath>\php-cgi.exe <file>.php? If yes, then we can dig more to find problem with IIS. If not, you need to get some help at php.net.

    Thanks,
    Kanwal

  • Re: Error 500 - Internal Server Error

    Sep 11, 2008 07:58 PM|FaTe709|LINK

    Hey,

    Thanks for responding and yes, I can execute the file using command line, the same errors come up and then it shows all my PHP coding fine but I keep getting an undefined index error and the 500 - Internal Server Error. Any ideas?

    Thanks

    -Mike

  • Re: Error 500 - Internal Server Error

    Sep 11, 2008 10:25 PM|ksingla|LINK

    Mike,

    I understand you are getting the same errors with IIS and fastcgi as you are getting when you execute the script from commandline. Your phpinfo test is also working fine which rules out php install issue to some extent. I would recommend getting help from http://php.net.

    Thanks,
    Kanwal