GUI Nowhere to be found.RSS

9 replies

Last post Aug 18, 2008 11:13 PM by sinbadkan

  • GUI Nowhere to be found.

    Jul 11, 2008 11:14 PM|madkidd|LINK

    I installed this module on my Vista Ultimate SP1 box and the rewrite rules work when I drop them into the web.config but the GUI part is nowhere to be found.

    Am I missing something?

    Best regards,

    Jeremy Hodges | Windows Server 2003 MCP
    Managed Microsoft hosting: www.orcsweb.com
  • Re: GUI Nowhere to be found.

    Jul 14, 2008 04:07 PM|ruslany|LINK

    The module should work fine on Vista SP1 and the UI should be available after installation. Have you tried to run the installer for the module in repair mode (from Add/Remove Programs UI)?

    URL Rewrite Setup UI

  • Re: GUI Nowhere to be found.

    Jul 14, 2008 04:41 PM|madkidd|LINK

    Thank you for the reply. Yes, I have tried to run a repair with the installer as well as an uninstall and fresh install.

    Kind of funky that the rewrite rules work just fine, but the GUI part is nowhere to be found.

    Best regards,

    Jeremy Hodges | Windows Server 2003 MCP
    Managed Microsoft hosting: www.orcsweb.com
  • Re: GUI Nowhere to be found.

    Jul 14, 2008 06:42 PM|ruslany|LINK

    Could you check if rewrite module provider is registered in administration.config file located in %WINDIR%\system32\inetsrv\config?

    The reasons why the UI does not appear may be:

    • <div mce_keep="true">The module provider is not registered in administration.config in moduleproviders section.</div>
    • <div mce_keep="true">CurrentBinding protocols is different from http or https.</div>
    • <div mce_keep="true">The UI assemblies are not in the GAC.</div>

    Setup UI

  • Re: GUI Nowhere to be found.

    Jul 14, 2008 07:49 PM|CarlosAg|LINK

    Defintely look in %windir%\system32\inetsrv\config\Administration.config in the moduleProviders for a Rewrite module, and if you could also check in the EventVwr in the Application Log to see if there are any entries in there from IIS-Manager.

  • Re: GUI Nowhere to be found.

    Jul 14, 2008 09:18 PM|madkidd|LINK

    Under moduleProviders for Rewrite I have this:

     <add name="Rewrite" type="Microsoft.Web.Management.Iis.Rewrite.RewriteModuleProvider, Microsoft.Web.Management.Rewrite, Version=7.1.0.000, Culture=neutral, PublicKeyToken=1A5B963C6F0FBEAB" />

    Application logs I have:

    Product: Microsoft URL Rewrite Module for IIS 7.0 -- Configuration completed successfully.

    Windows Installer reconfigured the product. Product Name: Microsoft URL Rewrite Module for IIS 7.0. Product Version: 1.0.0.080407. Product Language: 1033. Reconfiguration success or error status: 0.

    Windows Installer installed the product. Product Name: Microsoft URL Rewrite Module for IIS 7.0. Product Version: 1.0.0.080407. Product Language: 1033. Installation success or error status: 0.

    Best regards,

    Jeremy Hodges | Windows Server 2003 MCP
    Managed Microsoft hosting: www.orcsweb.com
  • Re: GUI Nowhere to be found.

    Aug 03, 2008 05:43 AM|RubenvdZwan|LINK

     I have the same problem, the GUI doesn't show anything.

    After manually adding the line to the module providers it appeared in the GUI. I'm using a centralconfig that's replicated with DFSR. I couldn't find the line in c:\windows\system32\inetsrv\config\administration.config either.

     So it just wasn't added.

  • Re: GUI Nowhere to be found.

    Aug 11, 2008 01:58 PM|xsbr|LINK

    I'm using Shared Config too and my config path is D:\config

    The installation updates the administration.config on IIS' default path ..inetsrv\config and applicationHost.config on D:\config

    I copy the two new lines from administration.config to my shared config and the button on GUI appears!

  • Re: GUI Nowhere to be found.

    Aug 18, 2008 10:57 PM|sinbadkan|LINK

    I have the same problem , and didnt understand the solution given here in this thread (by xbsr)

     

    can any one help

  • Re: GUI Nowhere to be found.

    Aug 18, 2008 11:13 PM|sinbadkan|LINK

     Sorry..... it is solved

      but for any beginner like me ,  Just  go to the Administration.config

       then to    -->  </moduleProviders> section

     you will find this code block

             <!-- ASP.NET Modules-->

     

    copy this line 

    <add name="Rewrite" type="Microsoft.Web.Management.Iis.Rewrite.RewriteModuleProvider, Microsoft.Web.Management.Rewrite, Version=7.1.0.000, Culture=neutral, PublicKeyToken=1A5B963C6F0FBEAB" />
     

    and past it before the code line given above ( <!-- ASP.NET Modules--> )