500.19 Error When Enabling 32-bit Application Pool [Answered]RSS

25 replies

Last post Oct 26, 2012 10:30 AM by tobateksingh

  • 500.19 Error When Enabling 32-bit Application Pool

    Jun 08, 2008 02:24 PM|JoelDKraft|LINK

    So I am trying to get a classic ASP server running on IIS7 under Win2008 x64.  The application relies on a number of 32-bit ActiveX controls, so I need to keep it in 32-bit application pool.

    This all seems pretty easy.  I have all of the ASP support installed.  My controls are registered.  I've adjusted some of the "gotcha" settings for moving to IIS7. I am using a separate site for my testing with its own application pool, and I can actually get the application going in x64 mode.   I can load static content, but of course it crashes as soon as it tries to load one of my ActiveX controls, because it isn't registered. 

    SINCE everything appears to be working correctly, I figured that that only real change here was to set the application pool's enable32BitAppOnWin64 to true... right?  Well when I do that, nothing works at all.  I receive a 500.19 0x8007007e error for ANY request...even static content.

    The error message says "The requested page cannot be accessed because the related configuration data for the page is invalid."  The error code means "The module cannot be found".   The DynamicCompressionModule is the source of the error every time for any handler.

    I traced the errors, and got the following information from both compression modules.  I figured that I would just try to disable them as a workaround for now, but every time I try, I get a "lock violation", so I guess I'm going to try to troubleshoot now!

     Any insights?

    Thanks,
    Joel
     

    82. view trace Warning -MODULE_SET_RESPONSE_ERROR_STATUS  <div class="hidden" id="section_errors_82_details" style="display: block;">
    ModuleName StaticCompressionModule
    Notification 16
    HttpStatus 500
    HttpReason Internal Server Error
    HttpSubStatus 19
    ErrorCode 2147942526
    ConfigExceptionInfo
    Notification MAP_REQUEST_HANDLER
    ErrorCode The specified module could not be found. (0x8007007e)
    </div>
    StaticCompressionModule
    99. view trace Warning -MODULE_SET_RESPONSE_ERROR_STATUS  <div class="hidden" id="section_errors_99_details" style="display: block;">
    ModuleName DynamicCompressionModule
    Notification 536870912
    HttpStatus 500
    HttpReason Internal Server Error
    HttpSubStatus 19
    ErrorCode 2147942526
    ConfigExceptionInfo
    Notification SEND_RESPONSE
    ErrorCode The specified module could not be found. (0x8007007e)
    </div>
    DynamicCompressionModule

     


     

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 01:37 AM|anilr|LINK

    What are the outputs of the following commands (from an elevated command prompt)?

    %windir%\system32\inetsrv\appcmd.exe list config -section:system.webServer/httpCompression

    dir %windir%\syswow64\inetsrv\gzip.dll

     

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 08:05 AM|JoelDKraft|LINK

    Here you go!

    Joel 

    <system.webServer>
      <httpCompression directory="%SystemDrive%\inetpub\temp\IIS Temporary Compressed Files">
        <staticTypes>
          <add mimeType="text/*" enabled="true" />
          <add mimeType="message/*" enabled="true" />
          <add mimeType="application/javascript" enabled="true" />
          <add mimeType="*/*" enabled="false" />
        </staticTypes>
        <dynamicTypes>
          <add mimeType="text/*" enabled="true" />
          <add mimeType="message/*" enabled="true" />
          <add mimeType="application/x-javascript" enabled="true" />
          <add mimeType="*/*" enabled="false" />
        </dynamicTypes>
        <scheme name="gzip" dll="%Windir%\system32\inetsrv\gzip.dll" />
        <scheme name="xpress" doStaticCompression="false" doDynamicCompression="true" dll="C:\Windows\system32\inetsrv\suscomp.dll" staticCompressionLevel="10" dynamicCompressionLevel="0" />
      </httpCompression>
    </system.webServer>

     Directory of C:\Windows\syswow64\inetsrv

    01/19/2008  09:53 AM            27,136 gzip.dll
                   1 File(s)         27,136 bytes
                   0 Dir(s)  27,683,934,208 bytes free
     

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 08:26 AM|JoelDKraft|LINK

    AHHH... we're on the right track now.  WSUS is installed on this server (SharePoint, too, actually), but I was blindly thinking that they didn't interact since they are in different application pools and such.  I see now that I dont' have a copy of the 32-bit suscomp.dll (they should really provide that if they are going to configure it in IIS at the server level).

    So the question is, how do I get rid of that compression scheme for a particular site?  I don't see this exposed in the IIS Manager.

    Joel
     

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 12:08 PM|anilr|LINK

    You cannot get rid of it for that site - compression schemes are registered globally - to get rid of the scheme altogether, run below 

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

     

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 02:10 PM|JoelDKraft|LINK

    Hmm... does that disable the compression scheme completely for the server??  I don't want to do anything that might interfere with WSUS.

    Is it possible to remove it on a per-site basis?

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 03:45 PM|anilr|LINK

    Schemes are registered globally - maybe, you can find the 32-bit suscomp.dll from 32-bit install of WSUS - otherwise, disabling this compression scheme should not break WSUS - probably only slow it down because responses are not compressed.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 09, 2008 05:13 PM|JoelDKraft|LINK

    I actually do have a copy of the 32bit DLL.

    Thanks! 

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 12, 2008 07:39 AM|baijuputhoor|LINK

    How can we enable the scheme again if needed? can you give the command for that?

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 12, 2008 01:16 PM|anilr|LINK

    %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /+[name='xpress',doStaticCompression='false',dll='%windir%\system32\inetsrv\suscomp.dll']

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 22, 2010 02:34 PM|ViperRT10Matt|LINK

     Anilr,

    I registered solely to say thanks for posting this.

     So, thanks for posting this.

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Oct 18, 2010 02:48 PM|IlikePancakes|LINK

    Anil; you just fixed an entire day of frustration!

    Please tell your employeer that I have granted you a 300% pay increase and that they should back pay you to the date of this post.

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Oct 29, 2010 02:22 PM|mooka|LINK

    I have a report that this change did break WSUS as a customer site where we are having this problem. Not 100% sure of the details yet.

     Has everyone confirmed that with this change their WSUS is fully working (used in conjunction with MS ConfigMgr)?

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 07, 2011 03:27 PM|KevinCow|LINK

    Hi Anilr,

    I encounter the same problem on my Windows Small Business Server 2008.  I followed you script intend to disable the compression scheme but I got ERROR < hresult:8007005, message:Failed to commit configuration changes. Access is denied. >.  during that I have turned off the IIS and the Application Pools too. 

    Any cause that prevents me to change the the configuration?  will there be a graphical interface instead of command line because I am not so comfortable to use command lines.

    Thanks for your help!

    Kevin

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 15, 2011 09:55 AM|KevinCow|LINK

    Microsoft Support helped me to do this:

    -> Take IIS backup.
    -> Open IIS
    -> Click on server module node at the top of the left hand tree and choose "Modules".
    -> Right click on DynamicCompressionModule and choose "Unlock"
    -> Right click on StaticCompressionModule and choose "Unlock".
    -> Open desired websites -> Open Modules.
    -> Right click on DynamicCompressionModules and choose "remove".
    -> Right click on StaticCompressionModule and choose "Remove".
    -> Do IISRESET.

     

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 16, 2011 12:14 PM|burtie|LINK

    Hi

    I have a similar issue with a sbs2008 server with iis7.

    I've tried the above fix from KevinCow but with no luck.

    Enabling 32bit apps in iis7 stops the DefaultAppPool and serves a 503 error page.

    The only fix mentioned here I've not tried is copying suscomp.dll because I cant find a copy of it.

    Is there any other suggestions anyone has got to make iis7 work with Access?

    Thanks in advance

    Andy

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 16, 2011 12:35 PM|KevinCow|LINK

    HI Andy,

    if it is error 503, there may be RPCproxy.dll is not 32 bit.  you may need to set conditional loading of this dll in ApplicationHost.config file. Please see this article:

    http://support.citrix.com/article/CTX120153

    Oh, should be this one:

    http://blogs.msdn.com/b/carloc/archive/2009/02/04/service-unavailable-in-iis7-with-32-bit-application-pool.aspx

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 16, 2011 12:40 PM|burtie|LINK

    Thanks for the quick reply Kevin

    I'll have a read and keep my fingers crossed

    Thanks again

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Mar 16, 2011 01:44 PM|burtie|LINK

    HI again

    I've tried all the above and no luck.

    I cant uninstall RPC http has client uses it.

    Any more ideas I would be greatfull

    Thanks again

    Andy

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Apr 07, 2011 03:07 AM|Steveh-ITB|LINK

    Hello all.

    I was having trouble with a new 32Bit application that a client wanted installed.

    Tech support for the  application suggested disabling compression for the entire server, which is SBS 08 running WSUS and other Apps, as others have mentioned this is not an option.

    KevinCow's suggestion of Unlocking and manually removing the individual modules worked well in my case.

    As per others I have signed up purely to give a big thanks. This forum saved a lot of hair pulling.

    Regards

    Steve

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jun 08, 2011 06:49 PM|spacenet|LINK

    Yes. Great.. This solved my similar issue, but then I landed up in staticCompressionModule issue. By removing & Unlocking it at the Server # Website level respectively, was able to get pass thro' all the error. Viola... my first IIS 7.5 website is up & running now... Thanx to every one / in a similar fashion,
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Jul 13, 2011 01:23 AM|Utsavi Gajjar|LINK

    Hi There, I have a .net application developed using Visual Studio 2005 (.Net Framework 2.0). My application depends on a 32-bit dll. Now I need to run this application on a 64 bit server with IIS 7.0. so I created an Application Pool for my app in IIS and set "Enable 32-bit Applications" to "TRUE". Now when I try to run my .net application all I see is this message "Service Unavailable" and it also stops the application pool. I looked at the IIS event viewer and found this error The Module DLL 'C:\Inetpub\CSPGateway\CSPms.dll' could not be loaded due to a configuration problem. The current configuration only supports loading images built for a x86 processor architecture. The data field contains the error number. To learn more about this issue, including how to troubleshooting this kind of processor architecture mismatch error, see http://go.microsoft.com/fwlink/?LinkId=29349 C:\Inetpub\CSPGateway\CSPms.dll is related to the database we use (its InterSystems CACHE 2010.2) I am not sure if the issue is related to the CSPms.dll OR to the setting "Enable 32-bit applications". Any help would be very much appreciated.
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Aug 08, 2011 11:45 AM|alb3rt0.b1as1utt1|LINK

    Hi everyone. I suppose I'm having the same issue, trying to run an old 32bit application on a Win 2008 R2 server 64bit.

    My question is: if I find a 32 bit version of suscomp.dll, do I have to replace the 64bit version or is there a way to use the correct .dll basing on the application bitness?

    If replacing is the only option, is the 32bit version fully compatible with the 64bit operating system?

    In addition, is there a way to set the entire <scheme> for the compressione to have preCondition="bitness64"? I have found such a solution in a site (can fin the page anymore now), but if I try to add the preCondition to the compression scheme entry it gives me an error on the xml format. adding it to a <module> (like for RPCproxy.dll) it works correctly.

    There is onother possibility: I "brutally" copy/pasted the application from a win server 2000 to the win srv 2008 (solving a little issue with the way file paths were handled in win 2000).. Do I need to change the way the web.config file is written in order to make it funciton with IIS 7?

    I'll post the current web.config file below; if necessary, can anyone help me doing so (or point me where to find a way to "translate" web.config from iis5 to iis7?

    web.config:

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <defaultDocument>
                <files>
                    <clear />
                    <add value="index.html" />
                    <add value="Default.htm" />
                    <add value="Default.asp" />
                    <add value="index.htm" />
                    <add value="iisstart.htm" />
                    <add value="default.aspx" />
                </files>
            </defaultDocument>
        </system.webServer>
    </configuration>

    That's a lot of nuts! I'm not english, so I apologize if my request isn't clear, in that case I'll try to explain my situation better.

     Thank you in advance,

     Alberto

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Aug 09, 2011 10:32 PM|HCamper|LINK

    Hello @ Alberto,

    Just so you know Anil Ruia left the IIS Team some time ago.

    I suggest that you create a new thread for your question.

    With the new thread IIS Net Users then can try and help.

    Martin

     


     

    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Aug 10, 2011 02:40 AM|alb3rt0.b1as1utt1|LINK

    Hi Martin,

    thank you for answering.

    I'll open a new thread shortly.

    Alberto

  • Re: 500.19 Error When Enabling 32-bit Application Pool

    Oct 26, 2012 10:30 AM|tobateksingh|LINK

    Thanks KevinCow and Anil!! Your tips and advice helped me understand our problem and fix it. Thanks so much!!! Like a few other people here, I created an account on this forum just to thank you :)