fastcgi error [Answered]RSS

3 replies

Last post Jun 01, 2008 01:43 AM by jrhubb1967

  • fastcgi error

    May 30, 2008 01:13 PM|mindaugas|LINK

    I made sure to follow the setup guide found here:

    http://learn.iis.net/page.aspx/246/using-fastcgi-to-host-php-applications-on-iis7/

    And php seems to run good, I can phpinfo, I can get to part of a wordpress install, but when I try to go to the config url it doesn't work. If I switch to running php without fastcgi it works good. Here's a URL and error I am getting.

    http://69.24.65.58/wordpress/wp-admin/setup-config.php

    PHP Notice: Undefined variable: admin_dir in C:\inetpub\wwwroot\wordpress\wp-admin\setup-config.php on line 36

    phpinfo working

    http://69.24.65.58/wordpress/info.php

    Any ideas guys?
     

    fastCGI error

    More robots less humans
  • bills bills

    415 Posts

    Microsoft

    Re: fastcgi error

    May 30, 2008 08:04 PM|bills|LINK

    I've seen some randomness in recent builds of Wordpress on Windows.  What version of wordpress are you using?  You might try a slightly older version...

     

    ~~~~~~~~~~~~~~~~~~~~~~~~
    Bill Staples
    Product Unit Manager, IIS
    blog: http://blogs.iis.net/bills
  • Re: fastcgi error

    May 31, 2008 12:25 PM|mindaugas|LINK

    I can give that a shot, I'm using the latest version as of yesterday. But it does work without using FastCGI, so I think it has something to do with that. Maybe I'm missing a config setting for it or something?  

    More robots less humans
  • Re: fastcgi error

    Jun 01, 2008 01:43 AM|jrhubb1967|LINK

    I was getting the same error on Vista using Apache with PHP 5.2 and Wordpress 2.5.1.  I manually created a wp-config.php file, which got my past that problem, but then I got an error complaining about not having MySQL installed.  The problem in this case was that my configuration was not complete.  This is what I did to get past it:

    Added my php extension directory to my PATH (c:\php\ext)

    Edited my php.ini file and made sure that the following two lines were uncommented:

    extension=php_mysql.dll
    extension=php_mysqli.dll

    Once I did that, I could login to Wordpress, though now I'm only getting a directory listing of files, but that's just another config issue to overcome.  I don't know if this will be helpful with your configuration, but hopefully it will.