We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Install ISAPI Extension DLL in IIS 6 [Answered]RSS

8 replies

Last post May 31, 2008 06:13 PM by VReinhart

  • Install ISAPI Extension DLL in IIS 6

    May 29, 2008 08:36 AM|Salmi|LINK

    I am new to web work. I have developed an ISAPI extension DLL in Delphi and debugged it using Delphi's Web App Debugger. I now have to install the DLL in IIS. I haven't a clue what to do to achieve that, or how to know what I should enter into a browser to access it. I need some VERY basic instructions.

    I found a very similar earlier post in this forum, but couldn't follow it. Partly perhaps that is because it concerned IIS 7 rather than IIS 6, and partly because it went straight over my head.

     Any help would be very welcome!

    isapi 6.0

  • Re: Install ISAPI Extension DLL in IIS 6

    May 29, 2008 09:27 AM|tomkmvp|LINK

  • Re: Install ISAPI Extension DLL in IIS 6

    May 29, 2008 01:15 PM|Salmi|LINK

    Hi Tom, and thanks for your reply - so fast as well. Unfortunately I fell at the first fence. I tried the IisExt /AddFile ... command and I got the response:

         Connecting to server ...Done.

         Error while configuring application or extension.

         You were not connected because a duplicate name exists on the network.

         Go to System in Control Panel to change the computer name and try again.

    I know there is definitely no other computer on the network with the same name. Anyway, I disconnected the server from the network, changed the server name, rebooted and then retried the IisExt /AddFile command. This produced exactly the same result as before.

    I have changed the server name back to the original, but I can't find any hint what to try next. Any suggestions?

  • Re: Install ISAPI Extension DLL in IIS 6

    May 29, 2008 01:31 PM|tomkmvp|LINK

    You're trying this remotely?  Can you logon locally or through terminal services?

  • Re: Install ISAPI Extension DLL in IIS 6

    May 29, 2008 01:43 PM|Salmi|LINK

    No, I'm working on the server locally, not remotely. I get this problem when logged directly onto the server locally as administrator.

  • Re: Install ISAPI Extension DLL in IIS 6

    May 29, 2008 03:17 PM|tomkmvp|LINK

    Anyway, I think that process might not be necessary.  Put your dll somewhere under the web root file path.  In the IIS MMC, make sure that on the Directory tab for the folder it has Execute Permissions set to "Scripts and Executables".  You may also need to go into the Web Service Extensions and setup an entry for this dll as well.

  • Re: Install ISAPI Extension DLL in IIS 6

    May 30, 2008 12:14 PM|Salmi|LINK

    hmmm ... what have I missed?

    I created a folder under wwwroot, with a scripts sub-folder. I then copied my DLL into the scripts sub-folder.

    I created a virtual directory under the default web site in IIS.

    In the properties sheet for the virtual directory I put the full path to the scripts sub-folder as the local path. I also set the Execute permissions to "Scripts and Executables".

    I can see my DLL when I click on the virtual directory in IIS.

    I added a new entry under Web Service Extensions and specified my DLL as a required file. I set this new entry to "Allowed".

    I compared the properties for my new virtual directoru with those of "Remote". They were basically the same (except mine does not require SSL).

    In a browser I put the address:

         http://MyServerName/MyVirtualDirName/MyDLLName.dll

    I am asked if I want to run scripts, and then asked if I want to run ActiveX and plug-ins. I answer YES to both. Specifying just the DLL name with no parameters should just return a simple "no info available" message from my DLL, but instead I get "The page cannot be displayed". I also tried with meaningful parameters, with the same "The page cannot be displayed" result.

    It seems that the DLL is not being found, or not being allowed to run, but I don't know what to do about it.

     

  • Re: Install ISAPI Extension DLL in IIS 6

    May 30, 2008 01:58 PM|tomkmvp|LINK

    Make sure friendly error messages are disabled in IE.

  • Re: Install ISAPI Extension DLL in IIS 6

    May 31, 2008 06:13 PM|VReinhart|LINK

    I have the same exact error message -- here is the command executed on Server 2003 SP2:

    Iisext /AddFile "C:\Program Files\Autodesk\MapGuideEnterprise2009\WebServerExtensions\www\mapagent\isapi_MapAgent.dll" 1 mapagent 0 mapagent

    Gives:
    Connecting to server ...Done.
    Error while configuring application or extension.
    You were not connected because a duplicate name exists on the network.  Go to System in Control Panel to change the computer name and try again.

    The computer name is unique on the network.  This is a package, with many other dll files besides this one.  What can I do?

    Thank you

    Victor Reinhart