We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

II7 w2k8 error 0x80070643 [Answered]RSS

15 replies

Last post Nov 09, 2012 12:30 PM by rosrooster

  • II7 w2k8 error 0x80070643

    Mar 21, 2008 06:25 PM|Kanien|LINK

    I installed FCGI then later went to add ASP and CGI features to the Web Server.  Upon reboot it failed to install the role services and crapped the whole web server.  I tried uninstalling the web server, but it gives same error when attempting to remove.  Any idea how to get past this without a complete reinstall?


    Web Server Crash 

  • Re: II7 w2k8 error 0x80070643

    Mar 27, 2008 12:05 PM|HSeiler|LINK

    Unfortunately this is not a simple IIS setup error, IIS never returns failure during uninstall. The error code 0x80070643 indicates that at this point the CBS component store is corrupted with a failed transaction that it will forever try and process. 

    Two things to try:

    1) OS repair – insert media and start setup.exe,  then choose Upgrade


    2) if that does not work then you will need to clean install OS.


    Henry Seiler
    Program Manager
    IIS Deployment
  • wadeh wadeh

    115 Posts


    Re: II7 w2k8 error 0x80070643

    Mar 27, 2008 12:45 PM|wadeh|LINK

    I just wanted to jump in here to clarify a few things.

    I've been chatting with Henry (hseiler) for the last few minutes.  Suggesting a clean install of the OS is very serious business.  If there are any behaviors in FastCGI (or any other part of IIS) that can lead to this, I want to make sure that we look into it.

    What has happened here is that an internal component of the Windows setup engine (the component store that Henry mentioned) has somehow become corrupted.  I've discusssed potential causes for this and he tells me that with the way the IIS component setup works, there is nothing we are doing that will lead to this.  There is also no way a user could induce this situation by setting up something incorrectly.  In the instances we know of where this problem has been seen, it has occurred randomly during install or uninstall of some component.  The specific component does not matter.

    Unfortunately, once the machine is in this state, the Windows installer is broken.  It cannot add or remove any Windows components and it cannot apply updates to the system.

    We have reason to believe that the OS repair that Henry describes may correct the problem, as it rewrites the component store.  It should also preserve the configuration of the machine.  Note that you will need to re-install any OS updates after doing this, since the nature of the repair is to restore OS files from your media.

    Please let us know how the OS repair works for you.  We are interested in confirming that this action corrects the problem (since we've never been able to get our hands on a machine in this state to try it for ourselves.)



  • Re: II7 w2k8 error 0x80070643

    Feb 16, 2009 06:52 PM|brenton.crosby|LINK

     Hi guys,

    I'm in an identical situation (http://forums.iis.net/p/1155241/1893505.aspx) - IIS install is giving the 0x80070643 error. I will also try the OS repair and see how that goes. We were going to blow away the machine and then start from scratch again but this may save us some time.


  • Re: II7 w2k8 error 0x80070643

    Mar 30, 2009 09:19 PM|mattshadbolt|LINK

     I found removing the Windows Process Activation Service and then reinstalling IIS fixed this issue for me.

  • Re: II7 w2k8 error 0x80070643

    Jun 24, 2009 05:43 AM|Tiemroth|LINK

    This also fixed the problem for me - Thanks


  • Re: II7 w2k8 error 0x80070643

    Jul 31, 2009 05:19 PM|brien20|LINK

    How do you remove Windows Process Activation Services from w2k8?
  • Re: II7 w2k8 error 0x80070643

    Jul 31, 2009 05:27 PM|anilr|LINK

    In server manager, go to remove features.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: II7 w2k8 error 0x80070643

    Jul 10, 2010 12:46 PM|Gengar003|LINK

    I know this is an old thread, but...

    I have this same error on a Server 2008 Enterprise R0 (Service Pack 2) machine.

    I tried removing WPA and IIS7, as suggested... but now those installs fail AS WELL - I can't put them back.

    I cannot choose "upgrade" from the install media, because the installer wants me to have a "More recent" version of Windows (instead of the same version, apparently).

    Short of re-installing the entire server (which would be an exceedingly large inconvenience), is there anything else I can do to save this machine?
  • Re: II7 w2k8 error 0x80070643

    Oct 25, 2010 04:11 PM|Supertao|LINK

     I fixed the same problem by removing the Windows Process Activation Service and then reinstalling IIS.

  • Re: II7 w2k8 error 0x80070643

    Jan 11, 2012 01:44 PM|redarmy|LINK

    Hello, i had the similar problem as i assume. I am writing this post as someone can find this helpful one day. Maybe this is not so correct resolution, i am sorry if it is not, but it DID work for me. I have had a functioning webfarm made of 3 servers - 1 controller, 1 primary, 1 secondary. Everything was working for me, but then somehow, during making some minor changes the webfarm stuck. I tryed re-making, where the farm stuck at AddServer process, unable to get into load balancing state. I had some other issues before, which reinstalling IIS and WFF, ARR components made my farm work. So i decided to try reinstalling IIS to resolve this issue. First issue i ran into was that i was unable to remove the web server role. I figured out that the problem was in machine.config in %windir%\Microsoft.NET\Framework(64)\v4.0..\config folder. I have just taken the machine.config from my primary (functioning) server and replaced it. //This is the part where i am not sure about the correctness of my solution//. Then i was able to uninstall the web server role, but getting errors on installing it back. I tryed repairing .NET 4 from Control Panel > Programmes and Features, reinstalling WAS but after time went i found out that the problem was in ASP. NET, .NET Extensibility in Application Development of Web Server Role Services. I was getting the above listed error code. I tryed to run aspnet_regiis.exe -i from Framework v2.0 folder to get errors. I got an idea to check the machine.config too, and i have absolutely no clue why, but it was also corrupted. I replaced it with a wroking one from Framework v4.0 folder and it did solve my problem. Hope i was helpful for someone :)

    0x80070643 0x80070643 error install asp .net unable to install asp .net module

  • Re: II7 w2k8 error 0x80070643

    Feb 02, 2012 08:18 PM|HCamper|LINK

    Hi redarmy,

    Thanks for the information:

    Yes it is helpful for the Community and users :)

    FYI: The thread post  http://forums.iis.net/members/Kanien is marked answered.

    The users TIA, 




    Windows and Linux work Together IT-Pros
    Community Member Award 2011
  • Re: II7 w2k8 error 0x80070643

    Mar 02, 2012 05:00 PM|Reha.Kocatas|LINK

    The removal of WPA allowed for the full uninstall/reinstall of IIS. 

    We did have a problem uninstalling WPA because the existing (bad) iis installation was using a shared config file.  Once we disable the shared config everything went as planned.  

     Many thanks to all the posters here who prevented a full blown os reinstall. 

  • Re: II7 w2k8 error 0x80070643

    May 01, 2012 03:48 PM|Paul Schwartz|LINK

    I got this error after trying to uninstall ONLY the FTP components. I had built a test Windows Cluster and had clustered IIS/FTP following the steps here: http://support.microsoft.com/kb/974603/en-us My shared configuration file was accidentally erased and I did not have a good backup. Once I uninstalled all the IIS components I could add them again.
  • Re: II7 w2k8 error 0x80070643

    Oct 22, 2012 10:45 AM|joshlfisher|LINK

     I am having the same issues with a slightly different setup. A new install on S2K8 R2, with only a handful of programs installed.

    I went to install some updates, which failed. I restarted the machine, and the updates installed fine. Then, I tried to install IIS (first time on the server). It too failed with the 0x80070643 code being given, and a message that I needed to restart the machine, which I did. Still no luck installing IIS. I tried installed WPA, restarting multiple times, uninstalling WPA, etc., with no luck.

     Here is the output from the System Readiness Update Tool:

    Checking System Update Readiness.
    Binary Version 6.1.7601.21645
    Package Version 16.0
    2012-10-22 10:06

    Checking Windows Servicing Packages

    Checking Package Manifests and Catalogs

    Checking Package Watchlist

    Checking Component Watchlist

    Checking Packages

    Checking Component Store
    (f)    CSI Manifest Failed Catalog Check    0x00000000    winsxs\Manifests\amd64_bf3dfeb646666c5e8d81487ff7ee67a0_31bf3856ad364e35_9.4.8112.20530_none_58cc0b1089ad03d8.manifest    amd64_bf3dfeb646666c5e8d81487ff7ee67a0_31bf3856ad364e35_9.4.8112.20530_none_58cc0b1089ad03d8   
    (f)    CSI Manifest Failed Catalog Check    0x00000000    winsxs\Manifests\amd64_595dd85193aafd853d18ec438dacf379_31bf3856ad364e35_9.4.8112.16430_none_918e647666dcc004.manifest    amd64_595dd85193aafd853d18ec438dacf379_31bf3856ad364e35_9.4.8112.16430_none_918e647666dcc004   
    (f)    CSI Manifest Failed Catalog Check    0x00000000    winsxs\Manifests\amd64_microsoft-windows-scripting-jscript_31bf3856ad364e35_9.4.8112.16430_none_f77256a2c9d11c52.manifest    amd64_microsoft-windows-scripting-jscript_31bf3856ad364e35_9.4.8112.16430_none_f77256a2c9d11c52   
    (f)    CSI Missing Identity    0x00000000    identity    amd64_80f818728c52c3b91614c5209e283add_31bf3856ad364e35_9.4.8112.16430_none_30e89271db31ecc3   
    (f)    CSI Manifest All Zeros    0x00000000    winsxs\Manifests\amd64_80f818728c52c3b91614c5209e283add_31bf3856ad364e35_9.4.8112.16430_none_30e89271db31ecc3.manifest    amd64_80f818728c52c3b91614c5209e283add_31bf3856ad364e35_9.4.8112.16430_none_30e89271db31ecc3   
    (f)    CSI Missing Identity    0x00000000    identity    amd64_9766edba274bb0e4a20d580e3b84320f_31bf3856ad364e35_9.4.8112.20530_none_dfb25b16a408b7a9   
    (f)    CSI Manifest All Zeros    0x00000000    winsxs\Manifests\amd64_9766edba274bb0e4a20d580e3b84320f_31bf3856ad364e35_9.4.8112.20530_none_dfb25b16a408b7a9.manifest    amd64_9766edba274bb0e4a20d580e3b84320f_31bf3856ad364e35_9.4.8112.20530_none_dfb25b16a408b7a9   
    (f)    CSI Manifest Failed Catalog Check    0x00000000    winsxs\Manifests\x86_microsoft-windows-i..ersandsecurityzones_31bf3856ad364e35_9.4.8112.16430_none_cd56ea63f1193f62.manifest    x86_microsoft-windows-i..ersandsecurityzones_31bf3856ad364e35_9.4.8112.16430_none_cd56ea63f1193f62   

    Seconds executed: 191
     Found 8 errors
      CSI Manifest All Zeros Total count: 2
      CSI Manifest Failed Catalog Check Total count: 4
      CSI Missing Identity Total count: 2

    Unavailable repair files:


    Joshua Fisher
    Self-employed IT consultant and hopeless technophile.
  • Re: II7 w2k8 error 0x80070643

    Nov 09, 2012 12:30 PM|rosrooster|LINK

    I found a much easier solution that worked for me, just install KB975443, then reboot then re-add the role and it should work fine