Failed to access IIS metabase, when trying to browse to .NET 2.0 Website [Answered]RSS

36 replies

Last post Oct 24, 2011 05:02 AM by tvimalarajah

  • Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 02, 2008 11:58 AM|pyrokenesis|LINK

    Okay I hope someone can help as I may have to kill a amall mammal out of frustration otherwise... the neighbours cat may be my first victim!

    I'm trying to access the CruiseControl.NET website on my machine (running XP SP2, IIS 5.1, with .NET 1.1 and 2.0) but I keep getting the following error:

    Failed to access IIS metabase.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Web.Hosting.HostingEnvironmentException: Failed to access IIS metabase.

    The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions, please see http://support.microsoft.com/?kbid=267904.

     I've googled and attempted the various given solutions, i.e. re-install .NET 2.0, register asp.net with aspnet_regiis tool, made sure the website is set to the right Framework... nada!

    Browsing to a .html page in the site works fine, browsing to a .NET 1.1 site works fine... what's the deal with .NET 2.0 sites?

    Any help would be massive!

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 02, 2008 01:49 PM|jeff@zina.com|LINK

    pyrokenesis

    The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions, please see http://support.microsoft.com/?kbid=267904

    Did this work?

    Jeff

    Have you Binged a solution before posting?
  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 02, 2008 04:51 PM|pyrokenesis|LINK

    No the article did not help. It said for .NET 2.0 use the tool aspnet_regiis with the options /ga <IUSR_MACHINE_NAME>, but that didnt work.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 03, 2008 12:03 AM|steve schofield|LINK

    Try granting the ASPNET user permissions.  Another couple of tricks that can help identify this is use Filemon, it'll help track down which folders / files are being denied.  Also look in the security event log, this would list failed access issues.  You would need to enable failure auditing of 'object access'.  You would use the Local Security Policy editor to enable this.

    Filemon (the swiss army knife of admins), not to use on the neighbor's cat. :)

    http://technet.microsoft.com/en-us/sysinternals/bb896642.aspx

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 03, 2008 08:54 AM|tomkmvp|LINK

    Yes, most likely the ASPNET account does not have access to your content files and folders.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 03, 2008 09:58 AM|pyrokenesis|LINK

    Thanks for the responses guys. I'll try your suggestion when I get home Steve; the cat may yet retain it's nine lives.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Oct 28, 2008 11:06 PM|ketanbece|LINK

    Hello There,

     

    Your Problem Shold be Should By register ASP.net But it's Unfortunatly it not Solved.So First Check that Your Server Is Running or Not. Second Uninstall your IIS and Again Install it Sometimes This happen First You need to install VS then Install IIS and Then register.

    Hope your Problem Solved.

     

    http://dotnet-magic.blogspot.com/2008/10/failed-to-access-iis-metabase.html 

     

    http://dotnet-magic.blogspot.com/ 

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Feb 10, 2009 05:42 AM|ayyappasb|LINK

    HI,

     

      Please reset your IIS and .Net register setings so that it will work. Please follow the below common Lines

     C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i

    Try This this may Help you

    Regards,

    Ayyalappa S B

    System Administrator

    Genisys Softwares & BPO

    +919886816811

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Feb 22, 2009 06:12 PM|joezep|LINK

    I was having the exact same problem and spent hours trying to solve it.

    After I ran "aspnet_regiis" from the correct directory everything started working great.

     Much Thanks,

    Joe

    please see http://support.microsoft.com/?kbid=267904." "The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Apr 23, 2009 12:45 AM|KKhushboo|LINK

     Possible Cause:-

    When you install IIs after .Net 2.0 Framework,the right of asp.net user has not been set correctly.

    Resolution:-

    Repair(uninstall if repair does not work, .Net Framework2.0)

    Run the following from your command line to reset IIS registry settings for aspnet user.

    C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727>aspnet_ regiis -i

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 08, 2009 11:17 AM|VipulPathak|LINK

     Thanks Guys ....

     I had the same problem of installing IIS later than ASP.NET and it was resolved after trying the above aspnet_regiis stuff.

     Thanks.

     

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 09, 2009 03:37 AM|emel|LINK

    Hi all, I'm also having this problem and none of the suggestions I've read about here and other forums on the web have worked.

    I've tried doing both aspnet_regiis -ga ASPNET and aspnet_regiis -ga MACHINENAME\ASPNET as well as uninstall and reinstall (-u and -i options respectively) to no avail.

    I've also uninstalled and installed the .NET framework. I've also checked the ASPNET account has access to the relevant folder and even the IIS metabase.bin file.

    The only thing that worked is if I add the ASPNET user account to the Administrators group. Now this doesn't seem to be right to me. Any ideas on how I can refine this a little further so that I don't have to grant full blown access to the ASPNET account?

    Any help much appreciated.

    asp 2.0 iis dotnet .Net 2.0 "The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions aspnet_regiis

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 10, 2009 10:34 AM|tomkmvp|LINK

    What version of IIS are you on?

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 13, 2009 11:03 PM|emel|LINK

    tomkmvp

    What version of IIS are you on?

    Hi Tom,

    I'm using IIS 5.1 on Windows XP SP3.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 14, 2009 10:25 AM|tomkmvp|LINK

    tomkmvp

    most likely the ASPNET account does not have access to your content files and folders.

    So this did not work?  You made sure ASPNET has at least NTFS Read permissions to the content files and folders?

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 15, 2009 04:36 AM|emel|LINK

     

    tomkmvp

    tomkmvp

    most likely the ASPNET account does not have access to your content files and folders.

    So this did not work?  You made sure ASPNET has at least NTFS Read permissions to the content files and folders?

    Yes, I have checked. The files are stored under the C:\Inetpub\wwwroot directory and the ASPNET account belongs to the Users group. Granting the ASPNET account full control to the content folder makes no difference.

    I've also checked that the ASPNET account has read access to the IIS metabase using the Metabase Explorer. Changing the permissions to full control also has no effect. Strange.

    My last thought was to reinstall IIS and .NET, but the when I try to uninstall IIS I get errors from Windows XP with a very vague error regarding the failing to delete some files. I've tried other things like aspnet_regiis -u first as well as uninstalling the .NET framework and rebooting, but still no go.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 15, 2009 06:28 PM|steve schofield|LINK

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 17, 2009 02:40 AM|emel|LINK

    steve schofield

    Enable auditing, repro the issue and look in the security event log.

    http://weblogs.asp.net/steveschofield/archive/2008/03/07/detecting-permission-issues-using-auditing-and-process-monitor.aspx

     

    Hi Steve, thanks for the tip. Unfortunately, I did not see any failed audit events in the event log after enabling auditing as described in your post.

    I've also tried using Filemon filtered by the aspnet_wp.exe process. There are a couple of errors but it didn't look like anything of the access denied category. Any ideas what I should be looking for? I see a couple of NAME_NOT_FOUND results for registry queries and some BUFFER_OVERFLOW errors when accessing some of the .NET configuration files.

    The file is too large to include here, so if anyone can indicate what would be beneficial to help debug the issue, I could include some snippets.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 17, 2009 08:15 AM|steve schofield|LINK

    I would filter in filemon or process monitor on the PID (process ID) vs. monitoring everything.  that can help reduce noise. 

    I'd turn off WWW service, then type netstat -an to see if 0:0:0:0:80 is displayed.  That would show something is also listening on port 80

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 18, 2009 01:15 AM|emel|LINK

    steve schofield

    I would filter in filemon or process monitor on the PID (process ID) vs. monitoring everything.  that can help reduce noise. 

    I'd turn off WWW service, then type netstat -an to see if 0:0:0:0:80 is displayed.  That would show something is also listening on port 80

    As mentioned in my previous post, I'm filtering by process name (aspnet_wp.exe).

    I've just confirmed their are no other processes listening on port 80.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Oct 11, 2009 01:04 AM|Basheer.a|LINK

    Granting aspnet user to have metabase access solved for me. you can try on executing the below line on your v2.0 root folder  

    aspnet_regiis -ga aspnet

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Dec 28, 2009 11:26 AM|esh222|LINK

    Dear Ayyalappa S B

     It worked for me.I was trying this for a month and now i resolved my problem with your sujjestion.

    If you have time kindly tell me  other attributes  for  aspnet_regiis

    Thank you so much

    thanks and regards,

    lokesh

    lokesh.kumar@cplmg.com

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 26, 2010 10:14 AM|ppawanverma|LINK

    Please chk if ASP.NET or ASPNET users has the R&W permissions on your website contents folder and similarly on the %WINDIR%/Microsoft.Net/Framework/<Version folder>/ folder.

    If not give the RW permissions to ASPNET user account.

    Your issue will be resolved. If still not you can get back to us.

     

     

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    May 06, 2010 12:47 AM|paemilind|LINK

    Well reinstalling IIS solves this Issue, suggest to run below steps

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    May 06, 2010 12:47 AM|paemilind|LINK

    Well reinstalling IIS solves this Issue, suggest to run below steps

     

    Run the following from your command line to reset IIS registry settings for aspnet user.

    C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727>aspnet_ regiis -i

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    May 24, 2010 05:53 AM|nripinbabu@msn.com|LINK

    steve schofield

    Try granting the ASPNET user permissions.  Another couple of tricks that can help identify this is use Filemon, it'll help track down which folders / files are being denied.  Also look in the security event log, this would list failed access issues.  You would need to enable failure auditing of 'object access'.  You would use the Local Security Policy editor to enable this.

    Filemon (the swiss army knife of admins), not to use on the neighbor's cat. :)

    http://technet.microsoft.com/en-us/sysinternals/bb896642.aspx

    Great Thanks !!!
  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Jun 30, 2010 02:10 PM|apoorvgupta29|LINK

    Thanks, it woks for me

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Jul 31, 2010 07:44 AM|sanusaneesh|LINK

     Hi All,

    I have also faced this issues . In my case basic cause of the issue is Symantec Antivirus . Because of that i am not able to register aspnet_regiis. Hence i formatted the machine and installed all software's again. Then also coming the same errors and IIS issues.  At last i found that these all error made because of Symantec. So i have uninstalled the Symantec and my problem gets solved .

    Errors that i have received,

    1) ---------------------------
    aspnet_regiis.exe - Application Error
    ---------------------------
    The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.
    ---------------------------

     2)System.Web.Hosting.HostingEnvironmentException: Failed to access IIS metabase. The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions, please see http://support.microsoft.com/?kbid=267904.

     

    Please try to uninstall Antivirus, may be this will help you

    Thanks

    Saneesh K P, Paipra

     

     

     

     

     

     

    .net 3.5 .NET Framework 3.5 IIS 5.1 "The process account used to run ASP.NET must have read access to the IIS metabase (e.g. IIS://servername/W3SVC). For information on modifying metabase permissions .net 3.5 SP1 VS 2008

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 02, 2010 08:56 AM|mkravil|LINK

    To resolve that issue please follow steps below -

    1. Unregister all the versions of ASP.NET with command "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –ua".

    2. Delete the ASPNET account from "Local Users and Group – Users".

    3. Then registere ASP.NET 2.0 with IIS using "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –i".

    4. Give permissions to the ASPNET account using "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis –ga machinename\ASPNET".

    5. Reset the IIS and that resolved the issue for ASP.NET 2.0.

    6. Register ASP.NET 1.1 with IIS as well using command "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis –i".

    7. Reset the IIS.


    After following the above steps we configured virtual directory versions as required and test both ASP.NET 1.1 and ASP.NET 2.0 application.

    Everything will work after that.

     Please don't forget to mark as a solution.

    Thanks!

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Aug 02, 2010 09:00 AM|mkravil|LINK

    Hi Saneesh

    This thread will resolve your problem...

    http://www.symantec.com/connect/forums/sep-ru5-0xc0000005-error 

    Main thing that you should be doing is

    “sc config sysplant start= disabled”

    and reboot...

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Feb 15, 2011 01:26 AM|sbazd32|LINK

    It solves my problem.

    Thanks Very Much

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 16, 2011 05:40 PM|visualtree|LINK

    Thanks, it worked.

    Rgs, Sid.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Mar 24, 2011 11:25 AM|SubashS|LINK

     Thanks it works for me too!!!

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Apr 26, 2011 04:26 AM|poinsy|LINK

    The cause of my problem was very similar to Saneesh's. In  my case it was some other security software called DeviceLock. This is designed to prevent data transfer to USB sticks etc. My attempts to run aspnet_regiis were fruitless, nothing happened at all. It worked at version 1.1, but all subsequent versions failed as above, with no message. Also, this must have been an update to the software, as it had been working for ages. As soon as I stopped the 2 executables belonging to DeviceLock, the aspnet_regiis -ga command worked and all was well again.

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Jun 15, 2011 04:26 PM|Sanjeewa|LINK

    I got the same error, try running

    aspnet_regiis -i

     This will register latest framework with iis. This solved my issue.

     

  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Oct 06, 2011 04:34 PM|jagilbert|LINK

    Sanjeewa

    I got the same error, try running

    aspnet_regiis -i

     This will register latest framework with iis. This solved my issue.

     

    Worked for me.
  • Re: Failed to access IIS metabase, when trying to browse to .NET 2.0 Website

    Oct 24, 2011 05:02 AM|tvimalarajah|LINK

    Yes. Running aspnet_regiis -ga aspnet Will solve the problem.

    iis 5.1 asp 2.0

    BRgds,
    vimal