Configuring PHP on IIS7 : Newbie question [Answered]RSS

2 replies

Last post Sep 19, 2007 04:09 AM by linus78

  • Configuring PHP on IIS7 : Newbie question

    Sep 16, 2007 09:50 AM|wildthing4ever|LINK

    Hi all,

    I'm pretty new to all this, so please bear with me!



    I wanted to run PHP+MySQL on IIS7. I've installed PHP5, and configured ISAPI as the default handler (not FastCGI). I was able to get this done, but when I get a PHP error, I get the IIS7 generic error page - error 500. It doesn't show me the exact error (missing ; etc). For example, I get:

     

    Server Error in Application "Default Web Site"


    HTTP Error 500.0 - Internal Server Error

    Description: The page cannot be displayed because an internal server error has occurred.

    Error Code: 0x00000000

    Notification: ExecuteRequestHandler

    Module: IsapiModule

    Requested URL: http://localhost:80/test/test2.php

    Physical Path: C:\demo\test2.php

    How do I configure IIS7 to show the actual error?

    Thanks!

     

     


     

    php error

    If it doesn't work the first time...RTFM!
  • Re: Configuring PHP on IIS7 : Newbie question

    Sep 17, 2007 05:30 PM|jeff@zina.com|LINK

    Two things.  First, in internet explorer, disable friendly errors.  In IIS 7, enable failed request tracing for the 500 error and you'll get a much better report.  See:

    http://www.iis.net/articles/view.aspx/IIS7/Managing-IIS7/Diagnostics-in-IIS7/Using-Failed-Request-Tracing/Troubleshooting-Failed-Requests-using-Tracing-in-I

    Jeff

    Have you Binged a solution before posting?
  • Re: Configuring PHP on IIS7 : Newbie question

    Sep 19, 2007 04:09 AM|linus78|LINK

     I would recommened you just install Zend core. Than FastCGI and PHP is installed automatically the best way it is working at the moment:

    http://www.zend.com/de/products/zend_core 

     Regards Linus