.swf files not down loading and playing in and archive. [Answered]RSS

18 replies

Last post Mar 16, 2010 03:12 AM by qbernard

  • .swf files not down loading and playing in and archive.

    Jul 11, 2007 05:09 PM|NSTA|LINK

    I have a seminar archive that plays in shockwave/flash, works fine from the older .asp server and from my local xp machine using .net 2.x.

    does not work when put on newer server IIs 6. there are 2 .swf files that is needs. from my machine and the old asp server they both get downloaded to the temp inet folder and work fine. when trying from the new server the larger of the 2 swf files downloads but the other doesn't and it just keeps saying loading and never comes through.

    http://learningcenter.nsta.org/products/symposia_seminars/archive/tectonics_archive/ava_player.html

    Any ideas? I have added the mime types to IIS but that shouldn't have any effect since it is not streaming?

    Thanks

    Jeff

     


    Did a redirect to a URL linked back to the original server and they work fine. something about the .net site or server? doesn't work from another .net site either.

    iis 6.0

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 10:44 AM|mvolo|LINK

    How are the SWF files being served on the server - as static files, or by a script/something else?

    Are you able to download the SWF files directly (without playing them with the player) by doing Save Target As in your browser?

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more inside information on IIS7, IIS and ASP.NET

    Mike Volodarsky
    CTO at LeanSentry
    Former IIS/ASP.NET PM

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 10:58 AM|NSTA|LINK

    It is essentially a shockwave program. there is a folder with all the files that are needed to run the program. it seems to down load every thing it needs into the internet temp folder and runs from there in the shock-wave plug-in.

    if i access the folder directly from my mapped drive it will run fine, but doing it throught the url from the web site it does not down load the .swf file that are the slide set that runs in the white board area of the player window. I have put it on 2 different servers runnig .net applications (web sites) and it won't work from either. al though it does work from my local machines .net web site.

    If you follow this link directly to the .swf file that isn't down loading it does play in internet explorer.

    http://institute.nsta.org/archive/birds_cd/dswmedia/NSDL_birds.swf

    the funny thing about this is that there is 2 .swf files there, one has the logo (single image) that shows up in the player window. the other is the slide set, and it just never downloads to the temp folder so the progam just runs saying that is is just loading.

     

    this is a link to the one on the other .net server that also doen't seem to work.

    http://supportsciguides.nsta.org/rep/bones_cd/ava_player.html

    I had to do the redirect to url as the live site has some 30 archives, so they needed to work.

     

    Thanks

    Jeff.

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 12:30 PM|tomkmvp|LINK

    Is it a mime-type issue?
    http://support.microsoft.com/kb/326965

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 12:55 PM|NSTA|LINK

    Those were added yesterday and wws was restarted and even rebooted the server. did nothing.

    .flv        video/x-flv
    .swf       application/x-Shockwave-Flash

    it is funny that it will download the smaller .swf file but not the larger one. and as I said I have a web site running on my local machine (.net 2.0) that these file work fine from as well as the older .asp server.

    I'm thinking that there must be some obscure setting on these 2 servers, they are running .net web sites and the other was just .asp site. but I can't seem to figure out what the difference is. wouldn't think it was a .net application issue?

    Thanks,

    Jeff.

     

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 01:17 PM|tomkmvp|LINK

    I wouldn't expect it to be related to ASP.NET.  Is ASP.NET handling the swf in any way?

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 01:27 PM|NSTA|LINK

    It isn't, its just a link to an HTML page, on that page it has a check to see if you have window media player and shockwave. once you click the link to the archive it will bring up the shockwave player, all the files that are needed are in the directory and several folders below it.

    It is really puzzling.

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 02:01 PM|NSTA|LINK

    Ok when running the archive through the URL that works these files are down loaded to the temp Internet folder

    ava_client.dcr
    nsdl.swf
    nologo.gif
    wmplogo.gif
    spacer.gif
    ava_player.html
    ava_1a.html
    avacast_live_2.jpg
    FlavioBkg.jpg
    flash.js
    swns.js
    mediacheck.js
    browser_cd.js
    swie.vbs
    bones.wma
    custom.xml
    bones_cd.xml
    checkmark.gif
    index.html
    event_ondemand.log
    bones.swf

    when running it from the servers it does not work on it is missing these files (isn't down loading them for some reason )

    the log file and bones.swf file are the ones that run the white board section of the archive.

    checkmark.gif
    index.html 
    event_ondemand.log
    bones.swf

     

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 04:28 PM|mvolo|LINK

    I am not a shockwave expert, but it does seem like a mimetype issue.  When I request the file (http://institute.nsta.org/archive/birds_cd/dswmedia/NSDL_birds.swf), I get

    HTTP/1.1 200 OK\r\n
    Server: Microsoft-IIS/5.0\r\n
    X-Powered-By: ASP.NET\r\n
    Date: Thu, 12 Jul 2007 20:20:46 GMT\r\n
    Content-Type: application/octet-stream\r\n
    Accept-Ranges: bytes\r\n
    Last-Modified: Mon, 25 Sep 2006 16:57:00 GMT\r\n
    ETag: "096f59dc3e0c61:98a"\r\n
    Content-Length: 1587609\r\n
    \r\n
    ...

    The content type is NOT shockwave, and that may be throwing off the player.  Your mimetype setting ".swf       application/x-Shockwave-Flash" doesnt seem to be effective.  Can you confirm that it was made correctly?

    Thanks,

    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more inside information on IIS7, IIS and ASP.NET

    Mike Volodarsky
    CTO at LeanSentry
    Former IIS/ASP.NET PM

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 05:34 PM|NSTA|LINK

    Not sure I understand, what was made correctly?

    if you down load that file it will open up in flash player, this is one of the files that don't seem to download from the newer servers. I guess shockwave it the rapper, and the actual file that is playing in the white board area is a flash file, and that is kind of like a powerpoint, then it gets the info it needs from the ondemand log file to change the slides and have the mark-up appear over the slides.

    It funny that I can play the archive directly from my mapped drive on that server and it will play on the other server but not on the 2 servers where we have .net(application) web sites.

     

    what file is using the application/octet-stream\r\n? , I guess when you view the .swf file in internet explorer it would be streaming?

    Jeff.

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 05:42 PM|mvolo|LINK

    To put it another way, your mimetype additions dont seem to be working.  Can you double-check that they are in fact set?  My guess is that the mimetype has to be shockwave for the player to work - right now, you are getting the mimetype set to the generic octet-stream.

    Thanks,

    Mike

    Mike Volodarsky
    CTO at LeanSentry
    Former IIS/ASP.NET PM

  • Re: .swf files not down loading and playing in and archive.

    Jul 12, 2007 05:50 PM|NSTA|LINK

    On the one server they are set under IIS 6 manager/ website properties/httpheaders/mime types

    .swf       application/x-Shockwave-Flash

    .flv         video/x-flv

     

    could it be that I have something not allowed under Web Service Extensions?

    Thanks,
    Jeff

     

     

  • Re: .swf files not down loading and playing in and archive.

    Jul 13, 2007 08:51 AM|tomkmvp|LINK

    No - that would only affect handling/processing of server-side code.

    Tom Kaminski (former IIS MVP 2002-2010)
    http://mvp.support.microsoft.com/
  • Re: .swf files not down loading and playing in and archive.

    Jul 14, 2007 10:55 PM|NSTA|LINK

    Ok, just tried it on a server I have set up at home and get the same result.

    Server 2003, IIS 6

    the server it works on is 2000 IIS 5.

    so if it is not a .net thing it must be a IIS 6 or server 2003 thing.

    Jeff

  • Re: .swf files not down loading and playing in and archive.

    Jul 15, 2007 11:55 PM|qbernard|LINK

    Err... is it working now?
    I browsed the url....... it a while to download....... then i see the .swf page. but it just one page - saying webinar bring bla bla to classroom - birds. and url below. that's it.

     

    Cheers,
    Bernard Cheah
  • Re: .swf files not down loading and playing in and archive.

    Jul 16, 2007 08:24 AM|NSTA|LINK

    Up date.

    this url works, running on win 2000 server IIS 5

    http://institute.nsta.org/archive/birds_cd/ava_player.html

     

    This url does not work, running win 2003 IIS 6

    http://supportsciguides.nsta.org/rep/bones_cd/ava_player.html

    Have tried it on 3 different win 2003 servers with IIS 6, same result.

    Thanks,

    Jeff Layman

  • Re: .swf files not down loading and playing in and archive.

    Jul 18, 2007 12:16 PM|NSTA|LINK

    I have figured it out.

    by going to this site

    http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19439&sliceId=1

    flash files not streaming for Widows 2003 Server, I found the mime type was set, but also discovered that there was no mime  type for .log.

    adding the .log mime type as text/plain fixed the problem.

    Thanks to all that responded.

    Jeff

  • Re: .swf files not down loading and playing in and archive.

    Mar 13, 2010 03:45 PM|ashish-1983|LINK

    NSTA

    I have figured it out.

    by going to this site

    http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_19439&sliceId=1

    flash files not streaming for Widows 2003 Server, I found the mime type was set, but also discovered that there was no mime  type for .log.

    adding the .log mime type as text/plain fixed the problem.

    Thanks to all that responded.

    Jeff

     

    Dude you gotta help me..

    i tried everything just you explained but in the end

    it does not work for me.

    the case is it's working fine on my server but does not

    run on my local machine..

    so any help...!

  • Re: .swf files not down loading and playing in and archive.

    Mar 16, 2010 03:12 AM|qbernard|LINK

    You should start a new thread, this post is 3 yrs old.

    Please tell us your setup and actual problem encountered.

    Cheers,
    Bernard Cheah