CGI in IIS 7.0 [Answered]RSS

1 reply

Last post Jun 18, 2007 01:26 PM by ksingla

  • CGI in IIS 7.0

    Jun 18, 2007 12:46 PM|michaelwithersone|LINK

    Hi ,ive been trying to get some executable CGI scripts written in Delphi 7.0 to work with IIS7. These scripts have always tradionally worked with IIS5 and 6 and I just cant seem to get past this error. Ive seen other people have been having problems and I was wondering if anybody could possibly help me out!!  This might be something really silly - but it appears that IIS7 is trying to run my CGI as a .net app maybe judging by the error message.Maybe its just execute permissions. Iam running on vista if this helps.

     

    Server Error in Application "Default Web Site"

    <div class=MsoNormal style="MARGIN: 0cm 0cm 0pt; TEXT-ALIGN: center" align=center>
    </div>

    HTTP Error 500.0 - Internal Server Error

    Description: This application is running in an application pool that uses the Integrated .NET mode. This is the preferred mode for running ASP.NET applications on the current and future version of IIS.

    In this mode, the application using client impersonation configured with <identity impersonate="true" /> may not behave correctly. Client impersonation is not available in early ASP.NET request processing stages and may lead modules in those stages to execute with process identity instead. You have the following options:

    1) Disable client impersonation.

    If your application design allows it, you can disable client impersonation by setting <identity impersonate="false" /> in your web.config file. This will make your application code execute with the process identity.

    NOTE: This option may require permissions on your application's files and data to be changed to allow access to the process identity.\

    2) Disable this error.

    If you do not have any modules executing within the BeginRequest and AuthenticateRequest ASP.NET pipeline stages, or it is acceptable for that code to execute under process identity, you can disable this error by setting <validation validateIntegratedModeConfiguration="false" /> in your application's configuration. Do this only after making sure that the rest of your configuration is compatible with Integrated .NET mode, as thiswill turn off the runtime validation for the application.

    3) Move this application to an application pool using the Classic .NET mode (PREFERRED).

    You can move the application to an application pool that uses the Classic .NET mode by using the following from a command line window (the window must be running as Administrator)

    %systemroot%\system32\inetsrv\APPCMD.EXE set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"

    Alternatively, you can use any other application pool on your system that is running in the Classic .NET mode. You can also use the IIS Administration tool to move this application to another application pool.

    It is preferred that you move this application to the Classic .NET mode by using option 3 to insure that your application continues to work if you are unsure of or unable to use the first two options. Error Code: 0x80070032 Notification: BeginRequest Module: ConfigurationValidationModule Requested URL: http://localhost:80/start.cgi Physical Path: C:\inetpub\wwwroot\start.cgi Logon User: Not yet determined Logon Method: Not yet determined Handler: StaticFile Most likely causes:
    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.
    What you can try:
    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
    More Information... This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error. Microsoft Knowledge Base Articles:
    • 294807
    <div class=MsoNormal style="MARGIN: 0cm 0cm 0pt; TEXT-ALIGN: center" align=center>
    </div>

    Server Version Information: Internet Information Services 7.0.

  • Re: CGI in IIS 7.0

    Jun 18, 2007 01:26 PM|ksingla|LINK

    This indicates that you have system.web/identity@impersonate set to true in web.config of root app. You can use any of the options given to you in the error message. Set impersonate to false or set system.webServer/validation@validateIntegratedModeConfiguration to false if you are sure this won't affect your application. Move application to apppool running in Classic mode otherwise.

    -Kanwal