error 0x80070032 on iis 7.0 for .NET 2.0 project [Answered]RSS

18 replies

Last post Oct 28, 2011 10:05 AM by sridhar2844

  • error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 14, 2007 10:16 PM|W3bM4k3r|LINK

    Hi I am a complete noob with IIS 7.0, actually IIS in general but my project does work in Win XP SP2 IIS 5.1 with no probs.

    However when I install Vista Business and setup IIS 7.0 it automatically referred to .NET 2.0 without installation, (not sure if it comes as a default).

    When I try and run the site using http://localhost/test/default.aspx I get the following error:

    HTTP Error 404.3 - Not Found
    Description: The page you are requesting cannot be served because of
    the Multipurpose Internet Mail Extensions (MIME) map policy that is
    configured on the Web server. The page you requested has a file name
    extension that is not recognized, and is not allowed.

    Error Code: 0x80070032

    Notification: ExecuteRequestHandler

    Module: StaticFileModule

    Requested URL: http://localhost:80/ets/bob.asp

    Physical Path: C:\inetpub\wwwroot\ets\bob.asp

    Logon User: Anonymous

    Logon Method: Anonymous

    Handler: StaticFile

    Most likely causes:

    It is possible that a handler mapping is missing. By default, the
    static file handler processes all content.
    The feature you are trying to use may not be installed.
    The appropriate MIME map is not enabled for the Web site or
    application. (Warning: Do not create a MIME map for content that users
    should not download, such as .ASPX pages or .config files.)
    What you can try:

    In system.webServer/handlers:
    Ensure that the expected handler for the current page is mapped.
    Pay careful attention to preconditions (e.g. runtimeVersion,
    pipelineMode, bitness) and compare them to the settings for your
    application pool.
    Pay careful attention to typographical errors in the expected handler
    line.
    Please verify that the feature you are trying to use is installed.
    Verify that the MIME map is enabled or add the MIME map for the Web
    site using the command-line tool appcmd.exe.
    Open a command prompt and change directory to %windir%
    \system32\inetsrv.
    To set a MIME type, use the following syntax: appcmd set config /
    section:staticContent /+[fileExtension='string',mimeType='string']
    The variable fileExtension string is the file name extension and the
    variable mimeType string is the file type description.
    For example, to add a MIME map for a file which has the extension
    ".xyz", type the following at the command prompt, and then press
    Enter:
    appcmd set config /section:staticContent /+
    [fileExtension='.xyz',mimeType='text/plain']
    Warning: Ensure that this MIME mapping is needed for your Web server
    before adding it to the list. Configuration files such as .CONFIG or
    dynamic scripting pages such as .ASP or .ASPX, should not be
    downloaded directly and should always be processed through a handler.
    Other files such as database files or those used to store
    configuration, like .XML or .MDF, are sometimes used to store
    configuration information. Determine if clients can download these
    file types before enabling them.
    Create a tracing rule to track failed requests for this HTTP status
    code. For more information about creating a tracing rule for failed
    requests, click here.
    More Information... This error occurs when the file extension of the
    requested URL is for a MIME type that is not configured on the server.
    You can add a MIME type for the file extension for files that are not
    dynamic scripting pages, database, or configuration files. Process
    those file types using a handler. You should not allows direct
    downloads of dynamic scripting pages, database or configuration
    files.

    I am not quite sure what the issue is as it wasn't that hard in IIS 5. I added default.aspx in the default parameters to look for if you don't type in the filename of the root folder.

    Can anyone help with how I can overcome this issue, as I have absolutely no clue here.

    thanks for any tips in advance

    Ringo (aka blind venison)

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 15, 2007 05:19 AM|steve schofield|LINK

    Make sure ASP is installed.  By default, ASP is not installed with IIS.

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 18, 2007 07:04 PM|Brainiacrk|LINK

    I encounter the same exact error.

     

    I have all components of IIS 7 installed. I'm running Windows Vista Home Premium with all applicable updates.

     

    There are several posts floating around out there for people who have encountered this and other errors while using IIS 7 in Vista Home Premium.

     

    Any ideas based on that info?? Thanks! :0 

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 18, 2007 08:29 PM|ksingla|LINK

    You say you requested default.aspx but the error indicates that you requested bob.asp. Are you getting 404.3 for default.aspx and bob.asp? Static file module is handling the asp, aspx requests on your machine. That means either you don't have asp and asp.net installed on your machine or your system.webServer/handlers configuration is not correct. Can you make sure you have the components installed on the machine first?

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 21, 2007 04:18 AM|W3bM4k3r|LINK

    Sorry for the misleading info.

    A post that I found was exactly the same error as I was getting but it related to default.aspx not bob.asp.

    I wasn't at home where my computer was and I needed to get the post online to get info so that I could resolve it asap.

    does this shed some light on the issue so that I could possibly get someones help ?

    thanks in advance

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Jun 21, 2007 11:44 AM|W3bM4k3r|LINK

    Ok have had a chance to look at the issue further and I had to do the following:

    First of all I had to put it back to the Pipeline mode as I believe I had it in Classic mode when setting up the virtual application. (sorry if all the terminology is wrong as it is on another machine that is now shut down and I need some sleep)

    I then tried it and I ended up with a 500 server error and it suggested that I add <identity impersonate="false" /> in the first choice to fix the error (from 3 options) as it sounded like it suggested impersonatioon was only avail in .NET 3.0?

    Anywayz, it has got the problem sorted. It isn't or wasn't as hard as I had thought even for a noob like me.

    The error handling messages are fantastic and give some very good suggestions; my hat goes off to the developers just on this alone.

    thanks, problem now sorted.

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 20, 2008 09:27 AM|scotthtaylor|LINK

    One more additional comment.  I'd done everything everyone suggested to no avail.  Finally, changed one thing in IIS Manager, and fixed the problem.

     I added the .aspx extension in MIME Types, with text/html as the MIME Type.  Even though I'd installed asp services, it didn't put this type in IIS, so it was unrecognized.

    After a day of pulling my hair out, finally figured this one out.

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 20, 2008 11:08 AM|anilr|LINK

    This is the wrong thing to do, you are opening a security hole on the server and will cause the source code for your aspx pages to be downloaded rather than the result of the script execution.

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 20, 2008 11:26 AM|scotthtaylor|LINK

    Then what would the right thing to do be?  I couldn't get this to work any other way.

    One note - my development machine is Vista, whereas our webserver is Server 2003.  Don't know if we'll see the same issues on iis 6.0.

    Thanks,

    Scott

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 20, 2008 12:39 PM|anilr|LINK

    You need to install ASP.Net from control panel -> programs and features -> turn windows features on or off under IIS - this will add the correct handler mapping for asp.net content including .aspx extension

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 28, 2008 04:34 PM|mikeyama|LINK

    I've encountered the exact same issue. Did the ASP.NET install and NOW... I get a message to change pool to Classic Mode, which I did. and NOW... I get an access denied message.

    What is going on??? Why did Microsoft change IIS which was so simple to something that I think is so unmanagable?

     

     

     

    IIS7 sucks

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Mar 29, 2008 12:29 AM|qbernard|LINK

    I think you got different error, post the error msgs.

    Cheers,
    Bernard Cheah
  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    May 20, 2008 03:41 PM|mcwallo|LINK

    Hi, I have an old classic asp site I need to work on, but I am really struggling to get it working on vista business. I followed various guides etc to install ASP, but now I get the following error...

     

    HTTP Error 500.0 - Internal Server Error

    Description: This application is running in an application pool that uses the Integrated .NET mode. This is the preferred mode for running ASP.NET applications on the current and future version of IIS.

    In this mode, the application should not specify ASP.NET handler mappings in the <system.web>/<httpHandlers> configuration section. Instead, it should use the <system.webServer>/<handlers> configuration section to configure ASP.NET handler mappings. You have the following options:

    1) Migrate the application to work with the Integrated .NET mode (PREFERRED).

    You can migrate the application configuration, including the contents of the <httpHandlers> configuration section, by using the following from a command line window (the window must be running as Administrator):

    %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "Default Web Site/"

    After you migrate your application, it will run in both Classic and Integrated .NET modes, as well as on downlevel platforms.

    2) Move this application to an application pool using the Classic .NET mode.

    You can move the application to an application pool that uses the Classic .NET mode by using the following from a command line window (the window must be running as Administrator):

    %systemroot%\system32\inetsrv\APPCMD.EXE set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"

    Alternatively, you can use any other application pool on your system that is running in the Classic .NET mode. You can also use the IIS Administration tool to move this application to another application pool.

    It is preferred that you migrate this application by using option 1 to take advantage of the benefits provided by the Integrated .NET mode.

    Error Code: 0x80070032

    Notification: BeginRequest

    Module: ConfigurationValidationModule

    Requested URL: http://localhost:80/

    Physical Path: C:\inetpub\wwwroot

    Logon User: Not yet determined

    Logon Method: Not yet determined

    Handler: StaticFile

     
     

    I'm a bit lost as to what to do now... All I have done is installed ASP and then copy and paste the website into the wwwroot folder to try and get it working.

     

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    May 20, 2008 03:53 PM|anilr|LINK

    Does the suggestion 1 above not work for you?

    Anil Ruia
    Software Design Engineer
    IIS Core Server
  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    May 21, 2008 02:02 PM|mcwallo|LINK

     no, I have tried what you posted, but I still get the same error

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Aug 30, 2008 03:37 PM|maqpoon|LINK

    hi Anil..

    I've a same problem in my asp local site...basically its working with windows xp but now i''ve one server with win 2003 server, but not configuring with this os.. Can you please help me to configure with my server 2k3 containg domain...

    thanks in advance

    regards

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Sep 03, 2008 08:42 AM|qbernard|LINK

    There are different problems in this old thread, can you create a new thread and tell us your exact problem? error msgs, event log, setup detail, etc?
    Cheers,
    Bernard Cheah
  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Sep 03, 2008 02:30 PM|maqpoon|LINK

    Bernard Cheah

    Basically i've one win2003 server (domain is already configured by the dell), I've copied my asp site on wwwroot, and tried to configure like as in windows XP professional, but there are complicated proceedure. in win XP just simple proceedure to deploye the asp local intranet..

    can you please help to setup asp site in domain environment with win2oo3 server..

     thanks..

    Meh

  • Re: error 0x80070032 on iis 7.0 for .NET 2.0 project

    Oct 28, 2011 10:05 AM|sridhar2844|LINK

    hey anilr. the suggestion you gave worked for me