We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

phpmyadmin problems on IIS7 [Answered]RSS

16 replies

Last post Aug 07, 2010 03:08 AM by don.raman

  • phpmyadmin problems on IIS7

    May 30, 2007 02:12 PM|Tudy|LINK

    Hy everybody.

     I've just installed PHP and MySQL on an IIS7 on Longhorn. And now, phpmyadmin.

    The phpmyadmin has some errors, which I think, are from... IIS7 (well, i forgot to say that i'm not so good in iis... i'm just a beginner).

    I will write the errors down here:

    <div class="warning">

    Can not load or save configuration

    Please create web server writable folder config in phpMyAdmin toplevel directory as described in documentation. Otherwise you will be only able to download or display it. </div> <div class="warning">

    Not secure connection

    </div><div class="warning"> You are not using secure connection, all data (including sensitive, like passwords) are transfered unencrypted! If your server is also configured to accept HTTPS request follow this link to use secure connection.</div><div class="warning"> </div><div class="warning">and also some PHP warnings:</div><div class="warning"> </div><div class="warning">Warning: Unknown: open(C:\Windows\SERVIC~2\NETWOR~1\AppData\Local\Temp\\sess_c1b762e199366266cf1a75ecf038523c, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0</div><div class="warning"> </div><div class="warning"> </div><div class="warning">Can anybody help me with these? Thank you very much, </div>

     

     

     

    phpmyadmin iis7

  • bills bills

    415 Posts

    Microsoft

    ~~~~~~~~~~~~~~~~~~~~~~~~
    Bill Staples
    Product Unit Manager, IIS
    blog: http://blogs.iis.net/bills
  • Re: phpmyadmin problems on IIS7

    May 30, 2007 04:11 PM|Tudy|LINK

    I've made what there said but ... same errors ...:( 

  • Re: phpmyadmin problems on IIS7

    May 30, 2007 04:18 PM|Tudy|LINK

    And... i made a folder 'config', in IIS Manager at Default Web Site, i've selected full permission for IIS User at phpmyadmin/config ... 

     And I have the same errors...
     

  • Re: phpmyadmin problems on IIS7

    May 31, 2007 10:51 PM|rickjames|LINK

    Hi Tudy,

    Here is what I did to get phpmyadmin working for me:

    0. php 5.2.3
    1. install mysql-essential-5.0.24a-win32.msi
    2. extract phpMyAdmin-2.8.2.2.zip to D:\inetpub\wwwroot\phpmyadmin
    3. start - run - inetmgr - default web site - right-click phpmyadmin - convert to application
    4. php.ini updates:
    extension_dir = "d:\php\ext"
    uncomment extensions: php_mbstring.dll, php_mysql.dll
    session.save_path = "D:\temp\phpsessions\phpmyadmin"
    5. create D:\temp\phpsessions\phpmyadmin, give "network service" full access
    6. update config: D:\inetpub\wwwroot\phpmyadmin>type config.inc.php
    <?php
    $cfg['blowfish_secret'] = 'ba17c1ec07d65003';  // use here a value of your choice

    $i=0;
    $i++;
    $cfg['Servers'][$i]['auth_type']     = 'cookie';
    ?>

    Cheerz,

    Rick.

  • Re: phpmyadmin problems on IIS7

    Jun 01, 2007 08:46 AM|Tudy|LINK

    Thanks, Rick.

     Well... it's better now but I still have some errors after I type user and password in phpmyadmin:

     
    Warning: session_write_close() [function.session-write-close]: open(C:\inetpub\temp\sessions\sess_c1b762e199366266cf1a75ecf038523c, O_RDWR) failed: Permission denied (13) in C:\inetpub\wwwroot\phpmyadmin\libraries\common.lib.php on line 1065

    Warning: session_write_close() [function.session-write-close]: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\inetpub\temp\sessions) in C:\inetpub\wwwroot\phpmyadmin\libraries\common.lib.php on line 1065

    #0  PMA_sendHeaderLocation(http://localhost/phpmyadmin/index.php?lang=en-utf-8&token=63ae255b172d0657bae2ef6621db26cd) called at [C:\inetpub\wwwroot\phpmyadmin\libraries\auth\cookie.auth.lib.php:488]
    #1 PMA_auth_set_user() called at [C:\inetpub\wwwroot\phpmyadmin\libraries\common.lib.php:3149]
    #2 require_once(C:\inetpub\wwwroot\phpmyadmin\libraries\common.lib.php) called at [C:\inetpub\wwwroot\phpmyadmin\index.php:36]

    Fatal error: PMA_sendHeaderLocation called when headers are already sent! in C:\inetpub\wwwroot\phpmyadmin\libraries\common.lib.php on line 1072


     

    What should I do now?

     

    phpmyadmin iis7

  • Re: phpmyadmin problems on IIS7

    Jun 01, 2007 08:48 AM|Tudy|LINK

     Well.... I've put the session.save_path at the C:\inetpub\temp\sessions :)

     

    Thank you very much. 

  • Re: phpmyadmin problems on IIS7

    Jun 01, 2007 08:59 AM|Tudy|LINK

    OMG! I've resolved this problem.... I think!

     Well, I've selected the C:\inetpub\temp\sessions folder and I gave full permissions for usrs IIS_IUSR, IUSR, IUSR_SERVER ... (something like this and now I can access the phpmyadmin :D)

     
    Thanks very much to all of you :)
     

  • phpmyadmin problems on IIS7

    Dec 02, 2007 06:29 AM|abytes|LINK

    i have php and mysql running on iis7 vista ultimate i run databases in xampp for few my web sites on other machine thats running xampp.Would love to run all on iis.. i am having trouble getting phpmyadmin working being new to this iis thing when i go to open localhost/phpmhadmin/index.php or even localhost/phpmyadmin i get this on the page

    phpMyAdmin - Error

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    can some one help please
  • Re: phpmyadmin problems on IIS7

    Dec 02, 2007 12:38 PM|Tudy|LINK

    Isn't the same think like mine? Go and check the php.ini session settings and give accesses to that folder.

     

  • Re: phpmyadmin problems on IIS7

    Dec 02, 2007 10:44 PM|abytes|LINK

    ok i got it to open and loged in but when i go to open a datebase ion left side it does not open to right side like on xamp for could be cuasing this? and thank you tudy it worked just cant open my databases now any sugestions?

  • Re: phpmyadmin problems on IIS7

    Dec 03, 2007 03:37 PM|abytes|LINK

    now im getting this error soe one please tell me how to fix it....

    Error

    MySQL said: Documentation

    #1045 - Access denied for user 'root'@'localhost' (using password: NO)

  • Re: phpmyadmin problems on IIS7

    Dec 06, 2007 04:06 AM|brashquido|LINK

    That is an authentication error. Double check your credentials and try again. If you are still having trouble you could try having a look at a guide I wrote on how to install and configure phpMyAdmin on IIS. It assumes you already have PHP and MySQL up and running, but should be of some use for the more common phpMyAdmin configuration directives.

    ----------------
    Dominic Ryan
    Microsoft IIS MVP
    IIS Aid
    IIS and Open Source
  • Re: phpmyadmin problems on IIS7

    Jan 13, 2008 03:44 PM|Cooooper|LINK

    hi guys

    thanx 4 all the advice/help 2 date have followed all the instructions listed above, and manged 2 get IIS7, MYSQL 4.0.12, PHP 5.2.0 all 2 run on windows Vista Home Premium. My problem how ever comes in with phpmyadmin, i get most of it to work except when ever i try browse a database i get the following msg

    PHP has encountered an Access Violation at 036F656C <script type=text/javascript> // </script> <script src="./js/functions.js" type=text/javascript></script> <script src="./js/tooltip.js" type=text/javascript></script>

    <div id=TooltipContainer onmouseover=holdTooltip(); onmouseout="swapTooltip('default');">in top of screen and 5 or 6 random charatrer in the place were data should be listed....</div> <div onmouseover=holdTooltip(); onmouseout="swapTooltip('default');"> </div> <div onmouseover=holdTooltip(); onmouseout="swapTooltip('default');">any ideas on why this is haoppening or better yet how 2fix it would be great</div> <div onmouseover=holdTooltip(); onmouseout="swapTooltip('default');"> </div> <div onmouseover=holdTooltip(); onmouseout="swapTooltip('default');">Thanx</div>
  • Re: phpmyadmin problems on IIS7

    Feb 24, 2009 04:04 PM|captaingeek@gmail.com|LINK

    <div id=header>All I get is :</div> <div> </div> <div>Internet Information Services 7.0</div> <div id=content> <div class=content-container>
    Error Summary

    HTTP Error 500.0 - Internal Server Error

    The page cannot be displayed because an internal server error has occurred.

    </div> <div class=content-container>
    Detailed Error Information <div id=details-left>
    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler php
    Error Code 0x00000000
    </div> <div id=details-right>
    Requested URL http://localhost/index.php
    Physical Path E:\www\phpmy\index.php
    Logon Method Anonymous
    Logon User Anonymous
    <div class=clear></div></div>
    </div> <div class=content-container>
    Most likely causes:
    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.
    </div> <div class=content-container>
    Things you can try:
    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.
    </div> <div class=content-container>
    Links and More Information This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.

    View more information »

    Microsoft Knowledge Base Articles:

    • 294807
    </div></div>
  • Re: phpmyadmin problems on IIS7

    Aug 06, 2010 07:59 PM|SearleCom|LINK

    It would seem that if you have IPv6 installed on your PC/Server this can cause the problem of not being able to connect to the SQL Server.

    To test ping localhost if you get:

    Pinging Orac [::1] from ::1 with 32 bytes of data:
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms
    Reply from ::1: time<1ms

    Then this is the case, to fix it try the following

     find the hosts file in \windows\system32\drivers\etc and edit it

    Comment out the following line by putting a # in front of it

    ::1             localhost

    Save the file and try connecting again

     I would guess the MySQL is not IPv6 awere yet??

  • Re: phpmyadmin problems on IIS7

    Aug 07, 2010 03:08 AM|don.raman|LINK