broken downloadRSS

3 replies

Last post May 02, 2007 06:08 PM by rickjames

  • broken download

    Apr 27, 2007 07:40 AM|aocch3|LINK

    The download link for iis7 fastcgi x64 is broken. I have tried this from multiple computers and different ISPs. After clicking on "Agree" for the license, the page is not found. I downloaded the 32 bit version succesfully and tried manually changing the things that needed changing for 64bit operation, but with no luck. Additionally, after working with iis for so long trying to get it to work with PHP, I have made a real mess of things and cannot find an easy to get back to a known good state. I have tried removing iis from my system and manually deleting the config files, but this method doesn't work. It remembers all the settings and the config files are protected. If there is an easy way to reset this please let me know. For now I gave up after spending 6+ hours trying to get this work, downloaded Apache, installed mysql and php support in 5 mins and was up and running.
  • Re: broken download

    Apr 27, 2007 11:52 AM|rickjames|LINK

    Hi aocch3,

    Sorry that the download isn't working. I'm guessing it's related to Longhorn Server Beta 3 launch activities (http://blogs.iis.net/chrisad/archive/2007/04/23/iis7-gettin-ready-are-you-ready.aspx).

    If you have the 32-bit version, IIS support running 32-bit worker processes on a 64-bit OS. (inetmgr - application pools - advanced settings - ...). Remember that the 32-bit version of the DLL should go into windows\syswow64\inetsrv. (It's tricky that the 32-bit DLL goes in the syswow64 folder)

    If you're in the "real mess" stage and don't have anything you'd like to save, I'm guessing that this would work:

    1) uninstall IIS completely

    2) delete windows\system32\inetsrv\config\applicationHost.config (the main settings file, not protected)

    3) re-install IIS

    Cheerz,

    Rick

  • Re: broken download

    Apr 27, 2007 12:27 PM|aocch3|LINK

    During my initial troubelshooting I uninstalled iis, restarted, deleted the applicationhost.config, then attempted to reinstall iis. It would not allow reinstallation without the applicationhost.config file; it errored out. I had to restore the applicationhost.config file to reinstall. Which, of course, left my old configuration in tact. I had to manually read through each line of text trying to figure what was causing my error. I did finally find a line pointing to an isapi-dll file which had gotten imported while running some appcmd statement I found in a blog. The service started working again after that, but still with no PHP support. I'm really amazed at the lack of good documentation with this software in a Vista 64 bit environment. I am not a web developer and rarely have to use web serving software. Most of the documentation I have found assumes you already know most of the basics and skips over them or gives some general statement assuming you know what they are talking about. Or just provides a script which is suppose to run and configure your system for you. when that doesn't work you have a real mess on your hands with no way to restore short of a system restore.

  • Re: broken download

    May 02, 2007 06:08 PM|rickjames|LINK

    Hi aocch3,

    I asked out setup person about this and she said that when you do the uninstall, ensure you also uninstall WAS (Windows Process Activation Server). That way when you re-install everything should be restored.

    Thanks,

    Rick.