We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

deployment issuesRSS

2 replies

Last post Mar 05, 2007 10:28 PM by mrkhan20007

  • deployment issues

    Mar 02, 2007 12:56 AM|mrkhan20007|LINK

    I upload my website to our web server. but there is a problem when i try to display the first page:


    Server Error in '/' Application.
    --------------------------------------------------------------------------------

    Compilation Error
    Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

    Compiler Error Message: CS0246: The type or namespace name 'ServerConnection' could not be found (are you missing a using directive or an assembly reference?)

    Source Error:

    public partial class ClientDetails : System.Web.UI.Page
    {
        private bool isFirst = false;    
        private ServerConnection conn = null; // ***error in this line
    }

    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

    Note: the "ServerConnection" is a classname. i tried to use the methods of this class. so i created an instance of this class.

    the application is compiled successfully and running successfully on my local machine.

    It seems any code within my App_Code wasn't being dragged into the global scope. So, I draged all class files to the global directory to test but still doesn't work. Anything wrong with my server setup? I'm using IIS6.0 on Win2003 server. Now please tell me, what I can do next?

    thanks.

    Mustafiz Khan
  • Re: deployment issues

    Mar 05, 2007 09:04 AM|tomkmvp|LINK

    Sounds like an ASP.NET specific issue.  Have you tried the forums at http://www.asp.net?  Did you set your folder in IIS as an Application?

  • thx

    Mar 05, 2007 10:28 PM|mrkhan20007|LINK

    Thanks a lot............... I solved.
    Mustafiz Khan