We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Microsoft OLE DB Provider for ODBC Drivers fejl '80004005' RSS

15 replies

Last post Mar 14, 2007 12:16 PM by RobertTengs

  • Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 01, 2007 09:43 AM|RobertTengs|LINK

    I´have installed a danish Vista and run IIS7 and have connection problems...

    Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    [Microsoft][ODBC Microsoft Access-driver] Der opstod en disk- eller netværksfejl.

    in english:

    Microsoft OLE DB Provider for ODBC Drivers error '80004005'

    [Microsoft][ODBC Microsoft Access Driver] Disk or network error.

    I´have tried theese commands and it dosent work..

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant Users:(CI)(S,WD,AD,X)

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER":(OI)(CI)(IO)(F)

     And

     %windir%\system32\inetsrv\appcmd set config -section:applicationPools /[name='DefaultAppPool'].processModel.loadUserProfile:false

    But still the same...

    Is there another thing i can do?

    is this script only fore english Vista??

     Please help !! 

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 02, 2007 02:00 AM|qbernard|LINK

    I noticed you have posted this before
    http://forums.iis.net/thread/1563960.aspx

    And I seen few users are able to fix it with above steps you posted. If it is not working in your case, can you double check the application pool identity ? is it network services?

    when you run the scripts above any error msgs?

     

    Cheers,
    Bernard Cheah
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 02, 2007 05:52 AM|RobertTengs|LINK

    Found the solution finally!

     I change the following:

    In the file ApplicationHost.Config (c:\windows>\System32\InetSrv\config\) the section where:
    <applicationPoolDefaults>
      <processModel identityType="NetworkService" />
    </applicationPoolDefaults>

    Change to:

    <applicationPoolDefaults>
      <processModel identityType="NetworkService" loadUserProfile="false" />
    </applicationPoolDefaults>

     And now all my old ASP works again :)

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 04, 2007 12:39 AM|qbernard|LINK

    Did you actually run the following command ?

    %windir%\system32\inetsrv\appcmd set config -section:applicationPools /[name='DefaultAppPool'].processModel.loadUserProfile:false

    Cheers,
    Bernard Cheah
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 04, 2007 10:07 PM|Brian Lee|LINK

    Ok, I've confirmed my C:\Windows\System32\inetsrv\config\applicationHost <applicationPoolDefaults> network services are set to false... the C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp folder has the "CREATOR OWNER" and "IUSR" users. Well, I'am still unable to access my mdb file... did you all did anything else.

    I did the following...

    %windir%\system32\inetsrv\appcmd set appPool "DefaultAppPool" -processModel.loadUserProfile:false

    icacls %WINDIR%\ServiceProfiles\NetworkService\AppData\Local\temp /grant IUSR:(CI)(RX,WD,AD)
    icacls %WINDIR%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER":(OI)(CI)(IO)(F)

    “Accuracy is Timely”
    Brian Lee
    Developer
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 04, 2007 11:18 PM|qbernard|LINK

    Lee, let's stick with one thread, I've replied over there.

     

    Cheers,
    Bernard Cheah
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 05, 2007 02:16 AM|RobertTengs|LINK

    Yes, i did the command and it did not work !

    This:
    %windir%\system32\inetsrv\appcmd set config -section:applicationPools /[name='DefaultAppPool'].processModel.loadUserProfile:false

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 05, 2007 03:52 AM|qbernard|LINK

    Any error msgs? have you run it in elevated mode? run as administrator for the command prompt?

    Cheers,
    Bernard Cheah
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 05, 2007 05:30 AM|RobertTengs|LINK

    No error and did right click and run it in admin mode...

     

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 05, 2007 09:50 AM|Brian Lee|LINK

    Do we need to setup or authorize any permission on the mdb file or folder then?

     

    “Accuracy is Timely”
    Brian Lee
    Developer
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 06, 2007 12:48 AM|steve schofield|LINK

    Try running process monitor on the box and see if something is getting denied.  The other post Bernard mentioned seemed to resolve the issue. 

    Steve Schofield
    Windows Server MVP - IIS
    http://iislogs.com/steveschofield
    http://www.IISLogs.com
    Log archival solution
    Install, Configure, Forget

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 06, 2007 02:13 AM|RobertTengs|LINK

    But i already found the solution and all my ASP and .NET i now working correct...

    The only solution for me was this

    I change the following:

    In the file ApplicationHost.Config (c:\windows>\System32\InetSrv\config\) the section where:
    <applicationPoolDefaults>
      <processModel identityType="NetworkService" />
    </applicationPoolDefaults>

    Change to:

    <applicationPoolDefaults>
      <processModel identityType="NetworkService" loadUserProfile="false" />
    </applicationPoolDefaults>

     And now all my old ASP works again :)

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 06, 2007 04:57 AM|qbernard|LINK

    That's what the command will do if it is executed correctly :)

     

    Cheers,
    Bernard Cheah
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 12, 2007 03:42 AM|jkewlo|LINK

     

    Server Error in Application "Default Web Site"


    HTTP Error 500.0 - Internal Server Error

    Description: This application is running in an application pool that uses the Integrated .NET mode. This is the preferred mode for running ASP.NET applications on the current and future version of IIS.

    In this mode, the application using client impersonation configured with <identity impersonate="true" /> may not behave correctly. Client impersonation is not available in early ASP.NET request processing stages and may lead modules in those stages to execute with process identity instead. You have the following options:

    1) Disable client impersonation.

    If your application design allows it, you can disable client impersonation by setting <identity impersonate="false" /> in your web.config file. This will make your application code execute with the process identity.

    NOTE: This option may require permissions on your application's files and data to be changed to allow access to the process identity.\

    2) Disable this error.

    If you do not have any modules executing within the BeginRequest and AuthenticateRequest ASP.NET pipeline stages, or it is acceptable for that code to execute under process identity, you can disable this error by setting <validation validateIntegratedModeConfiguration="false" /> in your application's configuration. Do this only after making sure that the rest of your configuration is compatible with Integrated .NET mode, as thiswill turn off the runtime validation for the application.

    3) Move this application to an application pool using the Classic .NET mode (PREFERRED).

    You can move the application to an application pool that uses the Classic .NET mode by using the following from a command line window (the window must be running as Administrator)

    %systemroot%\system32\inetsrv\APPCMD.EXE set app "Default Web Site/" /applicationPool:"Classic .NET AppPool"

    Alternatively, you can use any other application pool on your system that is running in the Classic .NET mode. You can also use the IIS Administration tool to move this application to another application pool.

    It is preferred that you move this application to the Classic .NET mode by using option 3 to insure that your application continues to work if you are unsure of or unable to use the first two options.

    Error Code: 0x80070032

    Notification: BeginRequest

    Module: ConfigurationValidationModule

    Requested URL: http://localhost:80/

    Physical Path: C:\inetpub\wwwroot

    Logon User: Not yet determined

    Logon Method: Not yet determined

    Handler: StaticFile

    Most likely causes:

    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

    What you can try:

    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

    More Information... This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.

    Microsoft Knowledge Base Articles:

    • 294807

    Server Version Information: Internet Information Services 7.0.
  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 12, 2007 03:46 AM|jkewlo|LINK

    i have changed this

     

    <applicationPoolDefaults>
                    <processModel identityType="NetworkService" />
                </applicationPoolDefaults>
            </applicationPools>

     

    to

     

    <applicationPoolDefaults>
      <processModel identityType="NetworkService" loadUserProfile="false" />
    </applicationPoolDefaults>

     

    and ran that command line thingie u guys were talking about and i got some error

    Pools /[name='DefaultAppPool'].processModel.loadUserProfile:flase

    ERROR < message:Configuration Error

    Filename: \\?\C:\Windows\system32\inetsrv\config\applicationHost.config

    line number: 153

    Description: Configuration is not well-formed XML .>

    ???

    any help would be great!

  • Re: Microsoft OLE DB Provider for ODBC Drivers fejl '80004005'

    Mar 14, 2007 12:16 PM|RobertTengs|LINK

    don´t know if it was a type failer or what?

     But your wrote this

    Pools /[name='DefaultAppPool'].processModel.loadUserProfile:flase

    Quote the last "flase" to be "false" :)

     Don´t know if this helps ?