Serve ASP page show 404 errorRSS

5 replies

Last post Feb 09, 2007 08:24 AM by qbernard

  • Serve ASP page show 404 error

    Feb 06, 2007 04:07 AM|eg_ckhag|LINK

    I upgraded existing web server in an NT machine to Win2003 and all asp page show up as 404 error.
    ASP service extension is enabled. Anonymous access is enabled. Grant access of the web root directory to Everyone.

    Static html and aspx work fine.
    Searched many posts about 404 error on ASP but cant find a solution to that.

    In the existing web application there are many COM objects, and I dont know if it the cause of the problem. However I already create a new web site in port 81 that only have 1 .asp, 1 .html and 1 .aspx files for testing but no luck.

    Look at the event log, at the first time i load the asp file in browser it saved 6 duplicate logs as following:

    Event Type: Error
    Event Source: DCOM
    Event Category: None
    Event ID: 10021
    Date:  2/6/2007
    Time:  4:53:35 PM
    User:  N/A
    Computer: UAT_WS2
    Description:
    The description for Event ID ( 10021 ) in Source ( DCOM ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: {61738644-F196-11D0-9953-00C04FD919C1}.

    However dont know what it mean, please help. Thanks

     Jason

    IIS 404 ASP

  • Re: Serve ASP page show 404 error

    Feb 06, 2007 09:21 AM|tomkmvp|LINK

    A 404 error simply means resource not found.  It's not permissions or COM related.

    Start here:
    http://support.microsoft.com/kb/248033
    http://support.microsoft.com/kb/315122

  • Re: Serve ASP page show 404 error

    Feb 06, 2007 08:52 PM|eg_ckhag|LINK

    Read the KB but no help.

    I use the MMC to browse the page from local machine, so that would not be file renamed/not exist/moved...

    ASP web service extension is Enabled. And in the log, it show 404.0 error but not 404.2 or 404.3 stated in the KB 238033

  • Re: Serve ASP page show 404 error

    Feb 07, 2007 08:03 AM|qbernard|LINK

    Ok, it could be issue related to the upgrade, can you check the asp.dll path? is it correct ? I mean should be \windows\ instead of winnt. if not luck, try filemon and trace what is actually missing.
    Cheers,
    Bernard Cheah
  • Re: Serve ASP page show 404 error

    Feb 07, 2007 10:32 PM|eg_ckhag|LINK

    Thanks Bernard,

    Finally I found that the UrlScan tool cause the problem.
    We have installed UrlScan in NT4 and after upgrade the IIS 6.0 can't start becos it can't find the urlscan.dll, thus I reinstall the UrlScan in Win2003 box. And the UrlScan will deny ASP request by default....

    Problem got solved by comment out the .asp in [DenyExtensions] in urlscan.ini

    And your filemon suggestion give a great hint to me. (I use the Process Monitor)

    Jason

  • Re: Serve ASP page show 404 error

    Feb 09, 2007 08:24 AM|qbernard|LINK

    Great!  :)
    Cheers,
    Bernard Cheah