We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Setting up classic ASP sites on IIS 7.0RSS

3 replies

Last post Feb 06, 2007 04:48 AM by louib

  • Setting up classic ASP sites on IIS 7.0

    Feb 05, 2007 08:19 AM|louib|LINK

    I have a number of ASP websites using access database which were created on XP Pro & IIS 6.0.

    I have upgraded to Windows Vista Business and the sites are no longer working when I browse to http://localhost/website/default.asp

    All sites use parent paths, I.e. c:/inetpub/wwwroot/website/db/database.mdb.

    Any help would be gratefully appreciated.

    ASP Classic Microsoft Access Vista

  • Re: Setting up classic ASP sites on IIS 7.0

    Feb 05, 2007 12:52 PM|EWoersch|LINK

    Did you go to the control panel and install the ASP module?   (CP > Programs & features > Turn on/off Windows Features> IIS > WWW Services > App Development Features) 

    To be as secure as possible, IIS7 ships locked down by default which means the majority of its 40+ components are not installed by default.

  • bills bills

    415 Posts

    Microsoft

    Re: Setting up classic ASP sites on IIS 7.0

    Feb 05, 2007 06:26 PM|bills|LINK

    please post more information about what error you are getting.  thanks
    ~~~~~~~~~~~~~~~~~~~~~~~~
    Bill Staples
    Product Unit Manager, IIS
    blog: http://blogs.iis.net/bills
  • Re: Setting up classic ASP sites on IIS 7.0

    Feb 06, 2007 04:48 AM|louib|LINK

    Thank you for the reply. I have turned on ASP in the control panel.

    HTML pages will load OK, the standard <%=Response.Write("Hello World")%> will now display OK.

    I created a file in notepad and tried to save to the wwwroot directory and got the error message "You dont have permission to save in this location. Contact administrator to obtain permission. Would you like to save in the LouiB folder instead?"

    I saved in the LouiB folder OK, and then copy and paste to the required wwwroot folder without problems. 

    ASP give the following error message in the browser window if the asp page I browse to attempts to connect to a database using the traditional ADO connection:

    An error occurred on the server when processing the URL. Please contact the system administrator

    Having already run:

    \Windows\system32\inetsrv\appcmd.exe set config -section:system.webServer/asp -scriptErrorSentToBrowser:true

    Also checked Show Friendly Error messages to on or off via IE Tools I get the same message.

    I've checked the same code on an XP Pro IIS 6.0 machine and it connects OK.

    I'm using Vista business connnected to Win Sever 2003 domain.

    --I have updated the applicationHost.config to include settings loadUserProfile="false"  on the applicationPools DefaultAppPool 

    also changed permissions on folders:
    C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp
    C:\Inetpub\wwwroot\Website\db
    to add authenitcated users with write & modify permissions
    & add IUSR account with write & modify permissions

    which allows the ASP to connect to the database and insert records.

    I just need a way to update existing records as this doesn't work?

    ASP Classic IIS 7 Access