(Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate [Answered]RSS

4 replies

Last post Jan 26, 2007 09:21 AM by cgalusha

  • (Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate

    Jan 16, 2007 05:38 PM|cgalusha|LINK

    Hi gang,

    I have followed the instructions found on several sites to manually install and configure PHP 5.2.0.0 with Vista and IIS7.  However, I am running the 64-bit version of Vista and wonder if that is causing the problem I am facing?

    I am receiving an HTTP 500.0 error and when viewing the trace file I find the following information:
    EventName: MODULE_SET_RESPONSE_ERROR-STATUS
    Details: ModuleName="IsapiModule", Notification="EXECUTE_REQUEST_HANDLER", HttpStatus="500", HttpReason="Internal Server Error", HttpSubStatus="0", ErrorCode="%1 is not a valid Win32 application. (0x800700c1)", ConfigExceptionInfo=""

    Any thoughts?  I am new to 64-bit systems and am finding that interoperability with 32-bit files is a bit of a pain and wonder if this is contributing to my pain!??!?

    Thanks for your help,

    Chris
     

    PHP

  • Re: (Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate

    Jan 18, 2007 12:13 AM|chrisad|LINK

    Hey Chris,

    Are you using the community version of FastCGI or the Tech Preview FastCGI for PHP from Microsoft?  I am just curious as this is important -

    Have you reviewed IIS.NET's FastCGI (and PHP) information?

    I ask becuase I was told today that there was some known issues with WoW64 with the community version of FastCGI.

    Thanks,

     

    ~Chris
    Program Manager
    IIS Product Unit (Microsoft)
  • Re: (Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate

    Jan 24, 2007 10:36 PM|cgalusha|LINK

    Hi Chris,

    Thanks for your quick reply - sorry for my slow response back.

    No, I am not using FastCGI - I configured PHP as an ISAPI extension, and in fact do not have CGI enabled on IIS.  So, two questions I guess...(1) should I enable CGI?  and (2) should I use the FastCGI approach given the issues you mention above.

    By the way, I used Bill Staples' blog to configure PHP as ISAPI.

    Thanks again,
    Chris

    PHP FastCGI

  • bills bills

    415 Posts

    Microsoft

    Re: (Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate

    Jan 25, 2007 02:35 PM|bills|LINK

    Hi Chris -

    You can use ISAPI or FastCGI - both should work (although we think FastCGI is the best way to run PHP going forward).

    Your issue is unrelated to either.  You are running 64bit, and both the ISAPI and FastCGI preview we have are 32bit.

    To fix this issue, you need to make the AppPool as 32bit.  Go into the IIS Admin tool, browse to your application Pool and click on "Advanced Settings".  Set the "Enable 32-bit applications" flag to "TRUE".  That should fix it.

    thanks,

     

    Bill

    PHP 64bit

    ~~~~~~~~~~~~~~~~~~~~~~~~
    Bill Staples
    Product Unit Manager, IIS
    blog: http://blogs.iis.net/bills
  • Re: (Trying to) Running PHP 5.2.0.0 with IIS7 and Vista 64 Ultimate

    Jan 26, 2007 09:21 AM|cgalusha|LINK

    Oh my gosh, what an easy fix, although I had no clue at all that was required!

    Bill and Chris, thanks so much to both of you for getting PHP running on my machine - it works like a champ now.  I'll read up some more on FastCGI, as well as WOW64 operability, and look at switching to that.  In the meantime, thank goodness it's working!!!