We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

blank page on asp applicationRSS

13 replies

Last post Nov 22, 2006 12:04 AM by qbernard

  • blank page on asp application

    Nov 06, 2006 08:48 AM|davidclangley|LINK

    Hi

    I have an asp application running on sbs 2003 (iis6) which at some sites comes up as a blank page.

    If i use https i can get to the web site.

     

    Any ideas

    http://www.vcorrespond.com/vcmail

    blank page

  • Re: blank page on asp application

    Nov 07, 2006 03:58 AM|qbernard|LINK

    http:// blank page?

    fixed ? I can browse the page
    http://www.vcorrespond.com/VCMail/ and get redirected to logon.asp

    Cheers,
    Bernard Cheah
  • Re: blank page on asp application

    Nov 07, 2006 09:02 AM|davidclangley|LINK

    fixed -- ???

     

    This only happens at some sites

  • Re: blank page on asp application

    Nov 07, 2006 09:56 AM|tomkmvp|LINK

    We're confused.  You have not made it clear as to what the problem is and specifically what pages/sites have this problem.

    Are you requiring HTTPS for the site?

  • Re: blank page on asp application

    Nov 07, 2006 10:06 PM|qbernard|LINK

    It works for me.......... so it could be the client side.
    Cheers,
    Bernard Cheah
  • Re: blank page on asp application

    Nov 08, 2006 07:23 AM|davidclangley|LINK

    Some clients can browse any site on the net, but when browsing to this site they get a blank page. https is not required but when they do get to our site and are presented with a blank page, then https will present the correct page.

    The clients that have this problem also have a problem when browsing to vcorrespond.com

    The strange thing is that the broswer gets to our servers home page which is browsertest.asp which redirects them to a page depending on the type of browser that they have.

     

    eg the blank page will show an address of www.vcorrespond.com/index.htm 

  • Re: blank page on asp application

    Nov 08, 2006 08:46 AM|tomkmvp|LINK

    I suspect an issue with browsertest.asp and the way it redirects - not specifically an IIS issue per se.
  • Re: blank page on asp application

    Nov 08, 2006 09:02 PM|qbernard|LINK

    Again it works for me via IE or FF :)  so you can try those having problem to use wfetch and test browse it to see if they see anything funny in the output.
    Cheers,
    Bernard Cheah
  • Re: blank page on asp application

    Nov 20, 2006 07:52 AM|davidclangley|LINK

    Hi

     

    I used wfetch and the contents of the code all come through but still a blank page

  • Re: blank page on asp application

    Nov 21, 2006 02:20 AM|qbernard|LINK

    well, are those problematic clients connecting via proxy or some other devices?

    How many clients are not working? do you see their request coming in? I mean as it look at IIS log file and their IP addresses are captured?

     

    Cheers,
    Bernard Cheah
  • Re: blank page on asp application

    Nov 21, 2006 05:45 AM|davidclangley|LINK

    Hi

     

    This customer is behind a squid proxy

  • Re: blank page on asp application

    Nov 21, 2006 11:05 PM|qbernard|LINK

    If browsing without the proxy, works? if yes. ask them to look at their squid proxy. Also what about other question? IP logged in IIS when request via proxy? status code ?

    Cheers,
    Bernard Cheah
  • Re: blank page on asp application

    Nov 22, 2006 12:01 AM|davidclangley|LINK

    Hi

     

    The user can get their if they bypass their proxy. The client IP is in the logs

  • Re: blank page on asp application

    Nov 22, 2006 12:04 AM|qbernard|LINK

    so where do you think the problem resides? show them the log file indicating that proxy didn't hit the server, etc, but why is it not returning to client...  this is not IIS issue.
    Cheers,
    Bernard Cheah