We are excited to announce that the IIS.NET Forums are moving to the new Microsoft Q&A experience. Learn more >

Error 404.3 with asp.net 2.0 and IIS7RSS

7 replies

Last post Oct 23, 2006 12:16 PM by manukahn

  • Error 404.3 with asp.net 2.0 and IIS7

    Oct 12, 2006 08:30 PM|manukahn|LINK

    <div class="ForumPostContentText" id="_ctl0__ctl1_bcr__ctl0___PostRepeater__ctl1_PostViewWrapper">

    I just put vista on my machine and IIS7 with it.

    I have enabled ALL the features including development of asp.net

    I can see the aspx handler in the new handler console of IIS7 and also when executing:
    C:\>%windir%\system32\inetsrv\appcmd list config "Default Web Site/mysite" -section:handlers 

    but still when I browse to any aspx page in my virtual directory I get error 404.3 (MIME not configured etc...)

    I made sure aspx is registered using aspnet_regiis -i

    I also removed and reinstalled IIS (enabling all its features) but still 404.3

    another interesting thing: when creating a new web site on IIS, VS does not to decide if to use framework 2.0 or 1.1 (a message box is asking me to configure something (I do not what and how) so VS will be able to decide)

    What Can I do?

    manu@sela.co.il

    </div>

    IIS7 RC1 Vista VS 2005

  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 16, 2006 01:21 AM|mvolo|LINK

    Are you sure you are making an .aspx request?  You should only get this error if the request is not being routed to ASP.NET, which would happen if either your *.aspx handler mapping is not configured correctly or if something is rewriting the request to the static file handler.

    Are you also changing the CLR runtime version of the application pool, or creating your own application pool?

    To help diagnose this, can you attach the following:
       - the output of the AppCmd command you show above.
      - the output of appcmd list app "Default Web Site/mysite"

    Thanks,

    Mike V.
    CTO at LeanSentry, Former IIS PM

    Expert guides:
    1. Restart IIS correctly
    2. Expert guide to IIS logs
    3. Tune IIS thread pool
  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 16, 2006 04:36 AM|manukahn|LINK

    Hi

    Thanks for your reply

    I know that iis is not targeting aspx to .net but i do not know what to do that I did not try.

    (aspnet_regiis & ReInstall IIS)

    Here is the result off : appcmd list app "Default Web Site/website" -section:handelers

    as you can see aspx is there!!! (bold)

    also I attach appcmd complete (it is very long)

    thanks for your help as now I can not use my iis as it does not respond to asp.net sites

    appcmd list app "Default Web Site/website" -section:handelers

    <system.webServer>
      <handlers accessPolicy="Script, Read">
        <add name="HttpRemotingHandlerFactory-soap-ISAPI-1.1" path="*.soap" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="HttpRemotingHandlerFactory-rem-ISAPI-1.1" path="*.rem" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="WebServiceHandlerFactory-ISAPI-1.1" path="*.asmx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="SimpleHandlerFactory-ISAPI-1.1" path="*.ashx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="PageHandlerFactory-ISAPI-1.1" path="*.aspx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="AXD-ISAPI-1.1" path="*.axd" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
        <add name="AboMapperCustom-31875" path="*.asbx" verb="GET,HEAD,POST" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_isapi.dll" requireAccess="Script" />
        <add name="TRACEVerbHandler" path="*" verb="TRACE" modules="ProtocolSupportModule" requireAccess="None" />
        <add name="OPTIONSVerbHandler" path="*" verb="OPTIONS" modules="ProtocolSupportModule" requireAccess="None" />
        <add name="StaticFile" path="*" verb="*" modules="StaticFileModule,DefaultDocumentModule,DirectoryListingModule" resourceType="Either" requireAccess="Read" />
      </handlers>
    </system.webServer>

    appcmd list app "Default Web Site/website"

    --- SNIP -------- 

    --- END SNIP -----

    thanks

    manu@sela.co.il 

     

     

  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 19, 2006 01:58 AM|mvolo|LINK

    I deleted your two duplicate posts and snortened the remaining once to just the relevant information. 

    Anyway, I think I see your problem.  You only have ASP.NET 1.1 handler mappings, and no ASP.NET 2.0 mappings.  I am guessing your application is running in an ASP.NET 2.0 application pool, which ignores these mappings, and therefore IIS tries to serve your ASPX pages with the static file handler (the default option when nothing else matches).

    So, you have several options here:
    1. Move this application to an ASP.NET 1.1 application pool.
    2. Install ASP.NET 2.0 via the Windows Setup UI, and run this application with ASP.NET 2.0.

    To do #1, first check your current application pool (please use the exact commands I give here, including the trailing "-" character):

    appcmd list app "Default Web Site/website" /XML | appcmd list apppool -

    This should show you the application pool that this app is running in.  Notice the CLR version: does it say 1.1 or 2.0?

    If it says 2.0, set it to 1.1 by doing:

    appcmd set apppool <NAME> /managedRuntimeVersion:v1.1

    Where <NAME> is the name of your application pool.

    To do #2, go to Control Panel>Programs>Turn Windows Features On/Off and install ASP.NET 2.0.

    Hope this helps,

    Mike V.
    CTO at LeanSentry, Former IIS PM

    Expert guides:
    1. Restart IIS correctly
    2. Expert guide to IIS logs
    3. Tune IIS thread pool
  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 20, 2006 08:51 AM|manukahn|LINK

    Hi

    Thanks but ASP.NET 2.0 is installed (All IIS options are installed)

    My Applicaion is on ASP.NET V2 Application pool. (I do not have an ASP.NET V1.1 app pool)

    and still I get 404.3 error.

    one interesting thing: when I open Visual Studio and try to create a new web site, VS tells me it does not know which framework version to choose 1.1 or 2.0 and ask me to config that later (I do not know how)

    I have updated to Vista RC2 but nothing works.

    I am stuck

    Please Help

    manu

     

    IIS7 error404.3

  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 20, 2006 10:48 AM|manukahn|LINK

    Hi,  I still get error 404.3 for every asp.net page

    Thanks  for your answer but asp.net is installed with IIS , The App pool of my virtual directory (under the default site) is asp.net v2

    I found interesting stuff : First visual studio think my site is ASP.Net V1.1

    Second in the IIS config (applicationHost.config) I found the following location section (which I think cause the problem)

    What should I do to solve the 404.3 problem ?

    Help me please.

    location path="Default Web Site">
            <system.webServer>
                <handlers>
                    <clear />
                    <add name="HttpRemotingHandlerFactory-soap-ISAPI-1.1" path="*.soap" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
                    <add name="WebServiceHandlerFactory-ISAPI-1.1" path="*.asmx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
                    <add name="PageHandlerFactory-ISAPI-1.1" path="*.aspx" verb="GET,HEAD,POST,DEBUG" modules="IsapiModule" scriptProcessor="C:\Windows\Microsoft.Net\Framework\v1.1.4322\aspnet_isapi.dll" preCondition="classicMode,runtimeVersionv1.1,bitness32" responseBufferLimit="0" />
                   

    Etc

    Thanks

    Manu 

     

    IIS7 error404.3

  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 23, 2006 01:04 AM|mvolo|LINK

    If its an ASP.NET 2.0 application, be sure to delete the location tag you show above.  It is clearing your ASPX hander mappings for ASP.NET 2.0, and adding back the mappings for ASP.NET 1.1.

    This should make your application work.

    To confirm that its taken effect, open INETMGR.EXE, navigate to your application in the tree view, select "Handler Mappings", and make sure there is an ASPX handler mapping to System.Web.UI.PageHandlerFactory.

    After that, can you find out what is causing this locaton tag to be created?  Whatever it is, its breaking you and is either incompatible with Vista or is has a bug that needs to be fixed.

    Thanks,

    Mike V.
    CTO at LeanSentry, Former IIS PM

    Expert guides:
    1. Restart IIS correctly
    2. Expert guide to IIS logs
    3. Tune IIS thread pool
  • Re: Error 404.3 with asp.net 2.0 and IIS7

    Oct 23, 2006 12:16 PM|manukahn|LINK

    Thanks so much !!! it worked !!!

    I have deleted the location tag in ApplicationHost.Config

    I am so grateful to you

    manu