Virtual directories don't show up in 'Open project from web', VS2003RSS

4 replies

Last post Oct 09, 2006 05:43 AM by OZ-Gump

  • Virtual directories don't show up in 'Open project from web', VS2003

    Sep 28, 2006 03:53 AM|OZ-Gump|LINK

    We're experiencing some strange behaviour. We're not sure it's an IIS problem, but since it involves IIS I thought I might as well give posting in this forum a go.

    The problem
    Virtual directories are not shown when selecting 'Open', 'Project from web' or 'Add', 'Existing project from web' in Visual Studio 2003. When you enter http://localhost/VirtualDirectoryName it won't show any files either. Actually, it jumps right back to the localhost root. It looks like the virtual directory is not there...
    When entering the entire path to the csproj file, Visual Studio jumps back to the localhost root too. Except when a correct webinfo file is present inside the virtual directory: in that case the project opens correctly. Still, in that case the Virtual Directories are not visible in the open dialog.

    Configuration
    It's a VMWare virtual machine with ...
    Windows Server 2003 Enterprise (SP1)
    IIS 6.0 with Frontpage server extensions 2002
    Visual Studio 2003 (SP1)
    Visual Studio 2005
    Microsoft Office 2003 (SP2)
    Rational tooling

    Things we've tried
    iisreset
    reboot
    remove IIS
    (re)install IIS
    remove all ASP.Net installations (aspnet_regiis -u)
    (re)install ASP.Net 1.1
    install web folders update
    install Internet Explorer 7 RC1
    update.microsoft.com

    All of this to no avail. I'm open to any suggestions.

    virtual directory WebProject Visual studio 2003

  • Re: Virtual directories don't show up in 'Open project from web', VS2003

    Sep 28, 2006 09:07 AM|tomkmvp|LINK

    Although this is an old article talking about Visual Interdev, it may be related ...
    http://support.microsoft.com/?kbid=253799
  • Re: Virtual directories don't show up in 'Open project from web', VS2003

    Oct 02, 2006 03:29 AM|OZ-Gump|LINK

    Thanks for your input. Unfortunately, this article doesn't apply to my situation. I'm still not able to see virtual directories. Even stranger: I had a workaround which doesn't work anymore! Things are getting strange over here....

    I'm still open for any input!
  • Re: Virtual directories don't show up in 'Open project from web', VS2003

    Oct 02, 2006 09:55 AM|tomkmvp|LINK

    It sounds like a FrontPage Server Extensions issue.  Are they installed to the virtual directory?
  • Re: Virtual directories don't show up in 'Open project from web', VS2003

    Oct 09, 2006 05:43 AM|OZ-Gump|LINK

    Yup, the FPSE are installed to the virtual. The answer was in allowing WebDAV for the default website. I don't know where this fits in, but it seems allowing the WebDAV extension enables Visual Studio to see the Virtual Directories.